Ошыбка в скрипте

  • Автор темы Maxi
  • Дата начала
Статус
Закрыто для дальнейших ответов.
M

Maxi

Гость
#1
вот в етом скрипте есть 2 синтаксические ошыбки:
Прараметри <<>?>Функции
{Обработка.компоненти.форма.модуль(1)} Переменная не определена(функции)
<<>>Функция вызова
{Обработка компоненти.форма.модуль(5)определение процедур и функций должны розмещатся перед оператором основной програмы.



вот сам скрипт :


Параметры функции
Компонента=1C_HRP.DLL
ПрогИд=Hrp

Функция вызова
// *****************************************************************************
// Описание:
// Загружает внешнюю компоненту, создает объект и включает

Функция Подключить(Компонента, ПрогИд, Объект)
Рез = 0;

Если ЗагрузитьВнешнююКомпоненту(Компонента) = 0 Тогда
ОписаниеРезультата = "ошибка загрузки внешней компоненты """ + Компонента + """";
Иначе
Попытка
Объект = СоздатьОбъект("AddIn." + ПрогИд); // Создание объекта внешней компоненты
Исключение
КонецПопытки;

Если ПустоеЗначение(Объект) = 1 Тогда
ОписаниеРезультата = "ошибка создания объект внешней компоненты с программым идентификатром AddIn." + ПрогИд;
Иначе
ОписаниеРезультата = "Терминал CASIO DT-900 подключен в режиме сервера";
Сообщить ("Терминал CASIO DT-900 подключен в режиме сервера","I");
Рез = 1;
КонецЕсли;
КонецЕсли;

Возврат Рез;
КонецФункции


Ошыбки в принцепе пустяковые синтаксические но языка я незнаю прошу Взгляните острым глазом и скажыте решение проблемы.
Зарание спс!
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
да, что языка не знаешь - это факт бесспорный, только прочитав название темы :(
во-вторых - зачем плодишь одинаковые темы?
в-третьих - куда ты засунул этот код?
 

vbs

Well-Known Member
18.02.2007
1 708
3
#3
Ошыбки в принцепе пустяковые синтаксические но языка я незнаю
Это мягко сказать - языка не знаю. Есть подозрение, что не знаешь ни русского, ни украинского, ни 1С-языка.
Удивительная у нас страна - троечники работают преподавателями, врачами и т.п. А уж совсем дремучие порой лезут в программисты, да еще вешают на других
исправление своей грамматики, находящейся на уровне... даже не знаю, как выразиться, дошкольника, что ли ?
Даже никакого желания разбираться в этом мусоре :(
 

tanat

Well-Known Member
02.03.2007
265
0
#4
Отладчиком пользоваться умеете?

П.С:
Удивительная у нас страна - троечники работают преподавателями, врачами и т.п.
Троечников под одну гребенку на чешите). Оценка - не всегда отражает меру знания учащегося. Часто вопрос бывает в том, нужна ли высокая оценка ему, или нет).
 
M

Maxi

Гость
#5
Отладчиком пользоваться умеете?
К сожелению неумею.
всем остальным скажу да я првда в 1с непонимаю ничево я не програмист а програмирование учил только основание с+ я системный администратор
Скажыте вы сможете мне помоч ??
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#6
я тоже не програмист, а системный администратор.
помочь сможем - тока ответь сначала на поставленные выше вопросы.
 

vbs

Well-Known Member
18.02.2007
1 708
3
#7
Троечников под одну гребенку на чешите). Оценка - не всегда отражает меру знания учащегося. Часто вопрос бывает в том, нужна ли высокая оценка ему, или нет).
Согласен практически полностью. Но иногда факты просто бьют наповал. Ну не может учитель русского языка выпускаться из пединститута с тройкой по данному предмету,
а дипломированный медик не имеет права называться врачом, имея тройку по анатомии. Кажется, я ясно обозначил свою позицию ;)
 

tanat

Well-Known Member
02.03.2007
265
0
#8
//Параметры функции
//Функция вызова - вот так для начала поставте). А то программа думает, что это переменная.
Перем Компонента;
перем ПрогИд;
...

после кода процедур и функций -
Компонента=1C_HRP.DLL; // скорее всего должно быть так : "1C_HRP.DLL", судя по тому, как вы к ней обращаетесь в коде
ПрогИд=Hrp;// или "Hrp"

Либо в самой функции описывайте эти переменные.

Для справки - все что пишется после // - программой не читается, это "комментарии".
 
Статус
Закрыто для дальнейших ответов.