Остатки за период ?

  • Автор темы mrrose
  • Дата начала
Статус
Закрыто для дальнейших ответов.
M

mrrose

Гость
#1
Как в бухгалтерской конфигурации 1С 7.7 выбрать остатки за определенный период
Не могу разобраться с бухг. итогами.
Помогите плиз
 
M

mrrose

Гость
#5
Так получаются просто остатки, а надо выбрать именно за определенный период и заполнить документ

[codebox]Перем МестоХранения;

МестоХранения = глЗначениеПоУмолчанию("ОсновнойСклад");
ТЗ= СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("Номенклатура","Справочник.Номенклатура");
ТЗ.НоваяКолонка("Остаток","Число",14,3);
ТЗ.НоваяКолонка("Сумма","Число",15,2);
ТЗ.НоваяКолонка("Квопродаж","Число",14,3);
ТЗ.НоваяКолонка("СуммаПродаж","Число",15,2);

Сч43 = СчетПоКоду("43");
Сч41_1 = СчетПоКоду("41.1");
Сч41_3 = СчетПоКоду("41.3");
Сч41_4 = СчетПоКоду("41.4");
Сч004 = СчетПоКоду("004");

БухИт=СоздатьОбъект("БухгалтерскиеИтоги");
БухИт.ПериодМ(ТекущаяДата());

спр = СоздатьОбъект("Справочник.Номенклатура");
спр.выборГруппы(1);
спр.Выбрать("Выберите группу товаров", );
Если спр.Выбран() = 0 Тогда
Возврат;
КонецЕсли;
спр.выборГруппы(0);

наценка=10;
Если ВвестиЧисло(наценка,"Ввести наценку %:",10,3)=0 Тогда
Возврат;
КонецЕсли;

УдалитьСтроки();

ВыбРодитель = спр.ТекущийЭлемент();
спр.ИспользоватьРодителя(ВыбРодитель);
спр.ВыбратьЭлементы();
Пока спр.ПолучитьЭлемент() = 1 Цикл
//спТоваров.ДобавитьЗначение(спр.ТекущийЭлемент());
Состояние("Заполняется табл. часть документа");
Стр = "";
Если спр.ТекущийЭлемент().Выбран() = 0 Тогда
ИначеЕсли спр.ТекущийЭлемент().ЭтоГруппа() = 0 Тогда
СчетУчета = "";
Если спр.ТекущийЭлемент().ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция Тогда
СчетУчета = Сч43;
ИначеЕсли спр.ТекущийЭлемент().ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Товар Тогда
Если спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.Тара Тогда
СчетУчета = Сч41_3;
ИначеЕсли спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.ПокупныеИзделия Тогда
СчетУчета = Сч41_4;
ИначеЕсли спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.НаКомиссии Тогда
СчетУчета = Сч004;
Иначе //Если ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.Собственный Тогда
СчетУчета = Сч41_1;
КонецЕсли;
КонецЕсли;

Если ПустоеЗначение(СчетУчета) = 1 Тогда
ИначеЕсли КонМесяца(ТекущаяДата()) > КонецРассчитанногоПериодаБИ() Тогда
Стр = "На " + КонМесяца(ТекущаяДата()) + " бухгалтерские итоги не рассчитаны!"+РазделительСтрок+
"Расчет итогов выполняется в режиме"+РазделительСтрок+
"""Операции - Управление бухгалтерскими итогами"".";

Предупреждение(Стр);
Возврат;
Иначе
Остаток = БухИт.СКД(СчетУчета,"К",,спр.ТекущийЭлемент());
Если БухИт.СКД(СчетУчета,"К",,спр.ТекущийЭлемент()) > 0 Тогда
НоваяСтрока();
Товар = спр.ТекущийЭлемент();
Количество = Остаток;
Цена = Окр(БухИт.СКД(СчетУчета,"С",,спр.ТекущийЭлемент())/Остаток, 2)*(1+наценка/100);
Сумма= Окр(Остаток * Цена, 2);
Всего = Сумма;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла; [/codebox]
 
M

mrrose

Гость
#7
Зачем же мне <<Голосуем за закрытие темы!>> T\Если и так ответа нет
 

vitfil

IT-интегратор
02.04.2004
2 062
0
44
Минск
#8
А что можно ответить на бред "остатки за период"?
Понимаю, что такое "Остатки на дату".
Понимаю, что такое "Обороты за период".
Но вы, извините меня за резкость и прямолинейность, не могли бы отсыпать травки?
Так изощренно бредить можно только при хорошем приходе.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#11
с бух итогами имхо все понятно в синтакс-помощьнике. СКК, СКД, СНД, СНК - не должны вызывать затруднений ИМХО
 
K

kaa

Гость
#12
БИ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ВыполнитьЗапрос(НачДата,КонДата,);//и т.д по справке
БИ.СКД();//конечное сальдо дебитовое
БИ.СКК();//конечное сальдо кредитовое
 
Статус
Закрыто для дальнейших ответов.