Остатки за период ?

Тема в разделе "1C и всё что с ней связано", создана пользователем mrrose, 6 фев 2009.

Статус темы:
Закрыта.
  1. mrrose

    mrrose Гость

    Как в бухгалтерской конфигурации 1С 7.7 выбрать остатки за определенный период
    Не могу разобраться с бухг. итогами.
    Помогите плиз
     
  2. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Классный вопрос. Сейчас туча советчиков набежит
     
  3. mrrose

    mrrose Гость

    А чем собственно говоря не нравится
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Синтаксис-помощник, ЖКК... будет не получаться - выкладывайте код.
     
  5. mrrose

    mrrose Гость

    Так получаются просто остатки, а надо выбрать именно за определенный период и заполнить документ

    [codebox]Перем МестоХранения;

    МестоХранения = глЗначениеПоУмолчанию("ОсновнойСклад");
    ТЗ= СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Номенклатура","Справочник.Номенклатура");
    ТЗ.НоваяКолонка("Остаток","Число",14,3);
    ТЗ.НоваяКолонка("Сумма","Число",15,2);
    ТЗ.НоваяКолонка("Квопродаж","Число",14,3);
    ТЗ.НоваяКолонка("СуммаПродаж","Число",15,2);

    Сч43 = СчетПоКоду("43");
    Сч41_1 = СчетПоКоду("41.1");
    Сч41_3 = СчетПоКоду("41.3");
    Сч41_4 = СчетПоКоду("41.4");
    Сч004 = СчетПоКоду("004");

    БухИт=СоздатьОбъект("БухгалтерскиеИтоги");
    БухИт.ПериодМ(ТекущаяДата());

    спр = СоздатьОбъект("Справочник.Номенклатура");
    спр.выборГруппы(1);
    спр.Выбрать("Выберите группу товаров", );
    Если спр.Выбран() = 0 Тогда
    Возврат;
    КонецЕсли;
    спр.выборГруппы(0);

    наценка=10;
    Если ВвестиЧисло(наценка,"Ввести наценку %:",10,3)=0 Тогда
    Возврат;
    КонецЕсли;

    УдалитьСтроки();

    ВыбРодитель = спр.ТекущийЭлемент();
    спр.ИспользоватьРодителя(ВыбРодитель);
    спр.ВыбратьЭлементы();
    Пока спр.ПолучитьЭлемент() = 1 Цикл
    //спТоваров.ДобавитьЗначение(спр.ТекущийЭлемент());
    Состояние("Заполняется табл. часть документа");
    Стр = "";
    Если спр.ТекущийЭлемент().Выбран() = 0 Тогда
    ИначеЕсли спр.ТекущийЭлемент().ЭтоГруппа() = 0 Тогда
    СчетУчета = "";
    Если спр.ТекущийЭлемент().ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция Тогда
    СчетУчета = Сч43;
    ИначеЕсли спр.ТекущийЭлемент().ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Товар Тогда
    Если спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.Тара Тогда
    СчетУчета = Сч41_3;
    ИначеЕсли спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.ПокупныеИзделия Тогда
    СчетУчета = Сч41_4;
    ИначеЕсли спр.ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.НаКомиссии Тогда
    СчетУчета = Сч004;
    Иначе //Если ТекущийЭлемент().ТипТовара = Перечисление.ТипыТоваров.Собственный Тогда
    СчетУчета = Сч41_1;
    КонецЕсли;
    КонецЕсли;

    Если ПустоеЗначение(СчетУчета) = 1 Тогда
    ИначеЕсли КонМесяца(ТекущаяДата()) > КонецРассчитанногоПериодаБИ() Тогда
    Стр = "На " + КонМесяца(ТекущаяДата()) + " бухгалтерские итоги не рассчитаны!"+РазделительСтрок+
    "Расчет итогов выполняется в режиме"+РазделительСтрок+
    """Операции - Управление бухгалтерскими итогами"".";

    Предупреждение(Стр);
    Возврат;
    Иначе
    Остаток = БухИт.СКД(СчетУчета,"К",,спр.ТекущийЭлемент());
    Если БухИт.СКД(СчетУчета,"К",,спр.ТекущийЭлемент()) > 0 Тогда
    НоваяСтрока();
    Товар = спр.ТекущийЭлемент();
    Количество = Остаток;
    Цена = Окр(БухИт.СКД(СчетУчета,"С",,спр.ТекущийЭлемент())/Остаток, 2)*(1+наценка/100);
    Сумма= Окр(Остаток * Цена, 2);
    Всего = Сумма;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла; [/codebox]
     
  6. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Голосуем за закрытие темы!
     
  7. mrrose

    mrrose Гость

    Зачем же мне <<Голосуем за закрытие темы!>> T\Если и так ответа нет
     
  8. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    А что можно ответить на бред "остатки за период"?
    Понимаю, что такое "Остатки на дату".
    Понимаю, что такое "Обороты за период".
    Но вы, извините меня за резкость и прямолинейность, не могли бы отсыпать травки?
    Так изощренно бредить можно только при хорошем приходе.
     
  9. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    А что такое "просто остатки"???)
     
  10. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Не могу разобраться с бухг. итогами
    Тогда, может и не стоит браться за то, чего не понимаешь ?
     
  11. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    с бух итогами имхо все понятно в синтакс-помощьнике. СКК, СКД, СНД, СНК - не должны вызывать затруднений ИМХО
     
  12. kaa

    kaa Гость

    БИ = СоздатьОбъект("БухгалтерскиеИтоги");
    БИ.ВыполнитьЗапрос(НачДата,КонДата,);//и т.д по справке
    БИ.СКД();//конечное сальдо дебитовое
    БИ.СКК();//конечное сальдо кредитовое
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей