Отчет по справочнику Цены

Тема в разделе "1C и всё что с ней связано", создана пользователем midnighter, 8 апр 2010.

Статус темы:
Закрыта.
  1. midnighter

    midnighter Гость

    Доброго времени суток всем читающим сие.

    У меня возникла проблема с казалось бы простой задачей - создать отчет, строками которого были бы записи из справочника Цены.
    По форумам походил, прежде погуглил - все как полагется - не помогло. Нашел примеры (отдельные кусочки кода) как это сделать, готовых запросов не нашел. На основе найденного состряпал свое:

    Код ( (Unknown Language)):
    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");

    Цн=СоздатьОбъект("Справочник.Цены");
    Цн.ИспользоватьВладельца("Алиот"); // Алиот - это да, хардкод. Используется что бы не усложнять и не описывать всю задачу
    Цн.ВыбратьЭлементы();
    Пока Цн.ПолучитьЭлемент() = 1 Цикл
    Таб.ВывестиСекцию("Цен");
    КонецЦикла;

    Таб.Опции(0);  
    Таб.ТолькоПросмотр(1);
    Таб.Показать();         
    КонецПроцедуры
    Проблема заключается в том, что после работы отчета получаю пустые строки. Отладчик показал, что Цн.ПолучитьЭлемент() = 0, то есть выборка по Контрагенту "Алиот" пустая, хотя в ручном режиме, выборка цен по нему формируется.

    Всем кто поможет или просто проявит интерес - заранее огромное спасибо!
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Подсказка: использовать надо не наименование владельца, а ссылку на элемент справочника, созданную функцией "СоздатьОбъект()"
     
  3. midnighter

    midnighter Гость

    Вот так? :)

    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");
    Контр = СоздатьОбъект("Справочник.Контрагенты");
    Контр.НайтиПоНаименованию("Алиот",0,0);

    Цн=СоздатьОбъект("Справочник.Цены");
    Цн.ИспользоватьВладельца(Контр.ПолнНаименование);
    Цн.ВыбратьЭлементы();
    Пока Цн.ПолучитьЭлемент() = 1 Цикл
    Таб.ВывестиСекцию("Цен");
    КонецЦикла;

    Таб.Опции(0);
    Таб.ТолькоПросмотр(1);
    Таб.Показать();
    КонецПроцедуры

    Контрагент нашелся, Цены по нему - нет ;)


    ЗЫ: я 1С только начинаю осваивать, поэтому так туго идет...
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
     
  5. midnighter

    midnighter Гость

    Отработало!

    unknown181538, спасибо! Сам я б еще долго думал (второй вечер трачу на это) :)
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей