Отчет в 1С

Тема в разделе "1C и всё что с ней связано", создана пользователем oza, 5 май 2008.

  1. oza

    oza Гость

    Репутация:
    0
    Существует конфигурация Библиотека. Необходимо создать отчет, в котором пользователь выбирает начальную и конечную дату, определенного читателя и отчет выводит ему те книги которые он брал или возвращал и вид движения(выдача,возврат). Все сделала, однако в поле вид движения(это регистратор), почему-то все записи дублируются 2 раза. Отчего так?

    Сам отчет:
    Вывести
    Процедура ОтчетПоЧитателямВывести()

    ЭлементыФормы.ПолеТабличногоДокумента.Очистить();

    ПостроительОтчетаОтчетПоЧитателям.Параметры.Вставить("Конец", Конец);
    ПостроительОтчетаОтчетПоЧитателям.Параметры.Вставить("Начало", Начало);
    ПостроительОтчетаОтчетПоЧитателям.Параметры.Вставить("Читатель", Читатель);

    ПостроительОтчетаОтчетПоЧитателям.Выполнить();
    ПостроительОтчетаОтчетПоЧитателям.РазмещениеИзмеренийВСтроках = ТипРазмещенияИзмерений.Вместе;
    ПостроительОтчетаОтчетПоЧитателям.РазмещениеРеквизитовИзмеренийВСтроках = ТипРазмещенияРеквизитовИзмерений.ВместеСИзмерениями;
    ПостроительОтчетаОтчетПоЧитателям.РазмещениеРеквизитовИзмеренийВКолонках = ТипРазмещенияРеквизитовИзмерений.ВместеСИзмерениями;
    ПостроительОтчетаОтчетПоЧитателям.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Классика);
    ПостроительОтчетаОтчетПоЧитателям.Вывести(ЭлементыФормы.ПолеТабличногоДокумента)
    ;

    КонецПроцедуры

    Инициализация

    Процедура ОтчетПоЧитателямИнициализация()


    ПостроительОтчетаОтчетПоЧитателям.Текст =
    "ВЫБРАТЬ РАЗЛИЧНЫЕ
    | ДвижениеКнигОстаткиИОбороты.Книги.Ссылка КАК Книга,
    | ДвижениеКниг.Регистратор КАК ВидДвижения
    |ИЗ
    | РегистрНакопления.ДвижениеКниг КАК ДвижениеКниг,
    | РегистрНакопления.ДвижениеКниг.ОстаткиИОбороты КАК ДвижениеКнигОстаткиИОбороты
    |ГДЕ
    | ДвижениеКниг.Период > &Начало
    | И ДвижениеКниг.Период <= &Конец
    | И ДвижениеКниг.Читатели.Ссылка = &Читатель";
    ПостроительОтчетаОтчетПоЧитателям.ЗаполнитьНастройки();
    ПостроительОтчетаОтчетПоЧитателям.ЗаполнениеРасшифровки = ВидЗаполненияРасшифровкиПостроителяОтчета.ЗначенияГруппировок;
    ПостроительОтчетаОтчетПоЧитателям.ТекстЗаголовка = "Отчет по читателям";
    Настройка = ВосстановитьЗначение("НастройкаОтчетыОтчетПоЧитателямОтчетПоЧитателям_7dbd8393-1c62-4ae0-a8f0-7eb85d74495b");
    Если Настройка <> Неопределено Тогда
    ПостроительОтчетаОтчетПоЧитателям.УстановитьНастройки(Настройка);
    КонецЕсли;

    КонецПроцедуры
     
Загрузка...

Поделиться этой страницей