Отчеты2 - ячейка для вычисления ср. арифметического

  • Автор темы hakuei
  • Дата начала
Статус
Закрыто для дальнейших ответов.
H

hakuei

Гость
#1
Здраствуйте... Мне хотелось бы спросить, как сделать так, чтобы в отчете итогом выводилось среднее арифметичекское (средний балл студентов). Что нужно дописать в модуле и в таблице, чтобы по оценкам выводилось среднее арифметическое?

Модуль отчета:


Процедура Сформировать()
Перем Т;
Перем Ту;
Т=СоздатьОбъект("Таблица");
Ту=СоздатьОбъект("Документ");
Т.ВывестиСекцию("Секция_1");
Т.ВывестиСекцию("Секция_2");
Ту.ВыбратьДокументы(ДатаНачало, ДатаКонец);
Пока Ту.ПолучитьДокумент()=1 Цикл
Если Ту.Предмет = Предмет Тогда
Т.ВывестиСекцию("Секция_3");
КонецЕсли;
КонецЦикла;

Т.ТолькоПросмотр(1);
Т.Показать()
КонецПроцедуры

Таблица
 
L

LSH

Гость
#2
Делаем секцию Ср. арифм
Заводим переменные ОбщийБалл и КоличествоОценок
В Итог по колонке оценка выводим ОбщийБалл/КоличествоОценок (с проверкой / на 0 конечно же).

В модуле:
ОбщийБалл = 0;
КоличествоОценок = 0;

Пока Ту.ПолучитьДокумент()=1 Цикл
Если Ту.Предмет = Предмет Тогда
Т.ВывестиСекцию("Секция_3");
ОбщийБалл = ОбщийБалл + ТУ.Оценка;
КоличествоОЦенок = КоличетсвоОценок + 1;

КонецЕсли;
КонецЦикла;
 
Статус
Закрыто для дальнейших ответов.