Отчеты2 - ячейка для вычисления ср. арифметического

Тема в разделе "1C и всё что с ней связано", создана пользователем hakuei, 19 дек 2006.

Статус темы:
Закрыта.
  1. hakuei

    hakuei Гость

    Здраствуйте... Мне хотелось бы спросить, как сделать так, чтобы в отчете итогом выводилось среднее арифметичекское (средний балл студентов). Что нужно дописать в модуле и в таблице, чтобы по оценкам выводилось среднее арифметическое?

    Модуль отчета:


    Процедура Сформировать()
    Перем Т;
    Перем Ту;
    Т=СоздатьОбъект("Таблица");
    Ту=СоздатьОбъект("Документ");
    Т.ВывестиСекцию("Секция_1");
    Т.ВывестиСекцию("Секция_2");
    Ту.ВыбратьДокументы(ДатаНачало, ДатаКонец);
    Пока Ту.ПолучитьДокумент()=1 Цикл
    Если Ту.Предмет = Предмет Тогда
    Т.ВывестиСекцию("Секция_3");
    КонецЕсли;
    КонецЦикла;

    Т.ТолькоПросмотр(1);
    Т.Показать()
    КонецПроцедуры

    Таблица
    [​IMG]
     
  2. LSH

    LSH Гость

    Делаем секцию Ср. арифм
    Заводим переменные ОбщийБалл и КоличествоОценок
    В Итог по колонке оценка выводим ОбщийБалл/КоличествоОценок (с проверкой / на 0 конечно же).

    В модуле:
    ОбщийБалл = 0;
    КоличествоОценок = 0;

    Пока Ту.ПолучитьДокумент()=1 Цикл
    Если Ту.Предмет = Предмет Тогда
    Т.ВывестиСекцию("Секция_3");
    ОбщийБалл = ОбщийБалл + ТУ.Оценка;
    КоличествоОЦенок = КоличетсвоОценок + 1;

    КонецЕсли;
    КонецЦикла;
     
Загрузка...
Похожие Темы - Отчеты2 ячейка для
  1. Normann
    Ответов:
    0
    Просмотров:
    2.667
Статус темы:
Закрыта.

Поделиться этой страницей