ОткрытьФормуМодально

Тема в разделе "1C и всё что с ней связано", создана пользователем Renat11111, 20 сен 2008.

  1. Renat11111

    Renat11111 Well-Known Member

    Регистрация:
    20 апр 2008
    Сообщения:
    123
    Симпатии:
    0
    7.7 Типовая конфигурция

    Есть документ выплатаЗПКасса в процедуре ПриОткрытии следующий код:

    Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" Тогда
    Если Форма.Параметр.Получить("Печать") = 1 Тогда
    Печать();
    КонецЕсли;
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;

    Так вот можно как ниб способом не методом тыка, а каким либо другим способом узнать в каком другом документе или отчете или еще где вызывалась ОткрытьФормуМодально
    где соответственно через параметр контекстФормы с передавался данный списокЗначений
     
  2. zavyzka

    zavyzka Гость

    Есть мнение, что кроме как, в модуле формы журнала "ЗаработнаяПлата", в типовой конфигурации приведенный кусок кода больше нигде не используется:

    Код (Text):
    Если ТекущийДокумент.Вид() = "ВыплатаЗПКасса" Тогда
    Параметр = СоздатьОбъект("СписокЗначений");
    Параметр.Установить("Печать", 1);
    ОткрытьФорму(ТекущийДокумент, Параметр,);
    КонецЕсли;
    А откуда появились подозрения про ОткрытьФормуМодально(), мне не сильно понятно.
     
  3. GOsha

    GOsha Гость

    Мне кацца проще сделать КОнфигурация/поиск во всех текстах. БЫстрее бут
     
  4. Renat11111

    Renat11111 Well-Known Member

    Регистрация:
    20 апр 2008
    Сообщения:
    123
    Симпатии:
    0

    Ок на самом деле ОткрытьФормуМодально() здесь не причем, спасибо что помогли действительно в форме журнала "ЗаработнаяПлата" есть такой код. Но сути вопроса это не меняет..... можно как ниб по тому куску кода, который приведен выше, определить откуда передавалось значение в Форма.Параметр.
     

Поделиться этой страницей