Открытие формы\документа во фрейме

  • Автор темы KLif
  • Дата начала
K

KLif

#1
Всем привет.

Столкнулся с проблемой, пока не знаю как её разрулить (все в web)

1. Есть frameset, в нём два фрейма: верхний(в нем есть поле UserName) и центральный. При открытии БД нужно чтобы в центральный фрейм грузился документ.

В чем проблема: для каждого пользователся есть только один документ, если пользователь уже был в системе и сохранил для себя документ, то во фрейм должен загрузиться документ с его настройками, если пользователя ещё не было в системе, то должна загрузиться форма для настройки дока и дальнейшего сохранения.

Раньше для этого всего была кнопка, которая вызывает агент с параметром UserName, и агент проверяет есть ли док в базе и, в зависимости от результата, открывает либо форму, либо док ... теперь надо чтоб это происходило при открытии БД.

Может кто-нибудь подсказать как решить такую проблему?
 
S

Sandr

#2
По умолчанию делаете загрузку во фрейме формы для настройки дока. На вебквериоупен формы проверяете есть ли уже документ настроек пользователя, если есть - меняете локейшен документа на тот, который Вам нужен.
 
K

KLif

#3
Как раз это делаю ... только пока агент не срабатывает на вебквериоупен, но при этом срабатывает по кнопке ... где то глюк
 
S

Sandr

#4
Как раз это делаю ... только пока агент не срабатывает на вебквериоупен, но при этом срабатывает по кнопке ... где то глюк
Таргет агента посмотрите (он должен быть non) и aget List Selection.

При этом Run as Web User и секюрити левел 2 на 2-й закладке
 
K

KLif

#5
Таргет агента посмотрите (он должен быть non) и aget List Selection.

При этом Run as Web User и секюрити левел 2 на 2-й закладке
Все поставил ... оказывается агент срабатывает, и если расставить месаджи в коде, то сервер показывает что они все выводятся ... но при это агент не может вернуть результат спомощью принта ... беспонятия в чем проблема

Нашел другой путь, сделал тип фрейма url и вызвал агента ... как то сразу не подумал об этом

Sandr, спасибо
 
S

Sandr

#6
KLif
А чт оВы принтили, если не секрет? Может ошиблись?
 
K

KLif

#7
KLif
А что Вы принтили, если не секрет? Может ошиблись?
Два принта:
1. window.frames['center'].location.href = 'тут урл открытия формы'
2. window.frames['center'].location.href = 'тут урл открытия документа'
в зависимости то условия в коде открывается либо 1ое, либо 2ое ...

Но, потом тупо поставил в начале агента:
Код:
Print {<script>alert(1)</script>}
... и он ниразу не сработал при открытие формы ... также как и остальные принты

Нет, вроде не ошибся ... если вызов агента повесить на какую нить кнопку, то он нормально отработает ... без понятия что это может быть ...
До этого пару раз делал запуск агента на опен, всегда работало ... но там то просто форма грузилась, а здесь она грузится во фрейме ... можт из за этого что то портится ...
 
S

Sandr

#8
KLif
Я не так имел ввиду :)

По умолчанию во фрейме открывать форму для регистрации.

В самом агенте, который подключается на вебквериоупен формы регистрации проверять зарегистрирован ли пользователь. Если зарегистрирован то принтить

Код:
<script>window.document.location.href='тут урл открытия документа'</script>
если не зарегистрирован - ничего не делать... :)
 
K

KLif

#9
KLif
Я не так имел ввиду :)

По умолчанию во фрейме открывать форму для регистрации.

В самом агенте, который подключается на вебквериоупен формы регистрации проверять зарегистрирован ли пользователь. Если зарегистрирован то принтить

Код:
<script>window.document.location.href='тут урл открытия документа'</script>
если не зарегистрирован - ничего не делать... :)
Я понял, просто старый вариант свой написал :) ... ну эт всё равно ничего не меняет, он отказывается любой принт выкидывать
 
S

Sandr

#10
KLif
А нет ли случайно в агенте принтов с квадратными скобками?
 
S

Sandr

#12
KLif
Есть ращница только в запуске по ссылке и запуске формулой...
При запуске формулой текущий документ - документконтекст, при запуске ссылкой документ нужно полчать другими способами.
При запуске формулой по кнопкесабмититься документ на сервер, если на кнопке запуск по ссылке - не сабмитится...

Квадратные скобки замените на нормальный скрипт, тогда и остальные принты работать будут...