• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фазинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь

Печатная Форма

  • Автор темы nub
  • Дата начала
N
#1
Подскажи пожалуйста
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.РасчётЦены.ПолучитьМакет("Печать");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| РасчётЦены.Заказ,
| РасчётЦены.Заказчик,
| РасчётЦены.КалькуляционнаяЕдиница,
| РасчётЦены.НаименованиеИзделия,
| РасчётЦены.ЦехИзготовитель
|
|ИЗ
|
| Документ.РасчётЦены КАК РасчётЦены
|ГДЕ
|
| РасчётЦены.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьЗаголовок1 = Макет.ПолучитьОбласть("Заголовок1");
Шапка = Макет.ПолучитьОбласть("Шапка");
ОбластьТабличнаяЧасть1Шапка = Макет.ПолучитьОбласть("ТабличнаяЧасть1Шапка");

ОбластьПоле1 = Макет.ПолучитьОбласть("Поле1");
ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;
ТабДок.Вывести(ОбластьЗаголовок1);

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ТабДок.Вывести(ОбластьТабличнаяЧасть1Шапка);
ТабДок.Вывести(ОбластьПоле1);
ВставлятьРазделительСтраниц = Истина;
КонецЦикла;


//}}
КонецПроцедуры




вот код,что нужно сюда добавить что бы значения выбирались не из одного документа а из 2-ух
 

Skellar

Well-known member
22.07.2008
87
0
#2
Добавь в запрос еще один документ и свяжи его с первым.
 
U

User1C

#4
Добавь массив документов, или используй
Код:
ВЫБРАТЬ ПЕРВЫЕ 2
, укажи тады с... по...
 
Вверх Снизу