Печатная Форма

Тема в разделе "1C и всё что с ней связано", создана пользователем nub, 29 сен 2011.

  1. nub

    nub Гость

    Подскажи пожалуйста
    Процедура Печать(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    Макет = Документы.РасчётЦены.ПолучитьМакет("Печать");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | РасчётЦены.Заказ,
    | РасчётЦены.Заказчик,
    | РасчётЦены.КалькуляционнаяЕдиница,
    | РасчётЦены.НаименованиеИзделия,
    | РасчётЦены.ЦехИзготовитель
    |
    |ИЗ
    |
    | Документ.РасчётЦены КАК РасчётЦены
    |ГДЕ
    |
    | РасчётЦены.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьЗаголовок1 = Макет.ПолучитьОбласть("Заголовок1");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьТабличнаяЧасть1Шапка = Макет.ПолучитьОбласть("ТабличнаяЧасть1Шапка");

    ОбластьПоле1 = Макет.ПолучитьОбласть("Поле1");
    ТабДок.Очистить();

    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
    Если ВставлятьРазделительСтраниц Тогда
    ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;
    ТабДок.Вывести(ОбластьЗаголовок1);

    ТабДок.Вывести(ОбластьЗаголовок);

    Шапка.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(Шапка, Выборка.Уровень());

    ТабДок.Вывести(ОбластьТабличнаяЧасть1Шапка);
    ТабДок.Вывести(ОбластьПоле1);
    ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;


    //}}
    КонецПроцедуры




    вот код,что нужно сюда добавить что бы значения выбирались не из одного документа а из 2-ух
     
  2. Skellar

    Skellar Well-Known Member

    Регистрация:
    22 июл 2008
    Сообщения:
    87
    Симпатии:
    0
    Добавь в запрос еще один документ и свяжи его с первым.
     
  3. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Мое сообщение надо удалить
     
  4. User1C

    User1C Гость

    Добавь массив документов, или используй
    Код ( (Unknown Language)):
    ВЫБРАТЬ ПЕРВЫЕ 2
    , укажи тады с... по...
     
Загрузка...

Поделиться этой страницей