Почему Javacompiler Скидывется На 1.5 Вместо 1.6

Тема в разделе "Lotus + Java + LS2J", создана пользователем Omh, 21 мар 2013.

  1. Omh

    Omh Lotus team
    Lotus team

    Регистрация:
    4 июл 2007
    Сообщения:
    2.210
    Симпатии:
    0
    Камрады, добрый день.

    Делаю очередную интеграцию.

    По идее, в 8.5.3 версии включена JVM версии 1.6
    Почему же всегда Java compiler version скидывается на 1.5?
    Т.е. я выставляю 1.6, рестарт дизайнера - в результате опять компилятор 1.5.
    Пробовал как в пропертях всего воркспейса, так и в пропертях проекта - монопенисуально, скидывается.

    1.5. мне не катит, т.к. те классы, которые я должен использовать, юзают (скопмпилированы?) версию 1.6.
    В результате получаю ошибку JVMCFRE003 bad major version

    При использовании внешней джавы (File - Properties - Java - Installed JREs - Add - c:\Program Files\Java\jre7) всё работает.
    Но хотелось бы использовать внутреннюю джаву.

    Ани суджештанс?
     
  2. VladSh

    VladSh начинающий
    Lotus team

    Регистрация:
    11 дек 2009
    Сообщения:
    1.251
    Симпатии:
    2
    Вопрос задавался здесь. Ответа вроде как нет.
     
  3. Omh

    Omh Lotus team
    Lotus team

    Регистрация:
    4 июл 2007
    Сообщения:
    2.210
    Симпатии:
    0
    VladSh
    "Обрадовал"

    Но что интересно...
    В Эклипсе этот код работает даже если поставить Java Compiler версии 1.5.
    Пошто может в домине отваливатся (даже и на 1.5)?

    Ошибка такая:
    Exception in thread "main" java.lang.UnsupportedClassVersionError: JVMCFRE003 неверная основная версия; класс=com/sun/org/apache/xml/internal/resolver/CatalogManager, смещение=6
    Почему на русском вылезла - не знаю :)
     
  4. Omh

    Omh Lotus team
    Lotus team

    Регистрация:
    4 июл 2007
    Сообщения:
    2.210
    Симпатии:
    0
    У себя нашёл проблему.
    Был конфликт двух классов в разных джарниках.
     
  5. lmike

    lmike нет, пердело совершенство
    Команда форума Lotus team

    Регистрация:
    27 авг 2008
    Сообщения:
    6.081
    Симпатии:
    300
    изначально претензии были "ошибочны" http://javacore.ru/topic/item/15-core-jdk....1FCDBF10C8B116C
    т.к. уровень нашего взаимодействия не достигает различий :)
    а вот класс из 1.4 вызывающий др. класс - может и заглючить (деталей не знаю/не экперементировал)
     
Загрузка...

Поделиться этой страницей