Подбор номенклатуры в таблицу значений

Тема в разделе "1C и всё что с ней связано", создана пользователем shane13, 26 авг 2008.

Статус темы:
Закрыта.
  1. shane13

    shane13 Гость

    Суть: Есть документ с таблицей значений на форме, в которую надо осуществить подбор номенклатуры и записывать всякие параметры. Я сделала внешнюю обработку, на форме которой разместила реквизиты типа Наименование, Количество, Единица и т.д. По нажатию на кнопку Ок, это всё должно переноситься в таблицу значений в моем документе.
    Что я делаю:
    В документе пишу:
    _________________________________
    Процедура НоваяСтрока()
    Перем Врем;

    Сп=СоздатьОбъект("СписокЗначений");
    ТаблРаботы.Выгрузить(Врем);
    Сп.Установить("ТабличнаяЧасть",Врем);

    Путь=КаталогИБ()+"/ExtForms/NewWork.ert";
    ОткрытьФормуМодально("Отчет",Сп, Путь);

    Если Число(Сп.Получить("Ок"))=1 Тогда
    Врем=Сп.Получить("ТабличнаяЧасть");
    ТаблРаботы.Загрузить(Врем);
    КонецЕсли;
    КонецПроцедуры
    _________________________________

    В модуле формы внешней обработки пишу:
    _________________________________
    Процедура ПриОткрытии()
    ТаблЧасть=Форма.Параметр.Получить("ТабличнаяЧасть");
    КонецПроцедуры // ПриОткрытии()

    Процедура Ок()
    Форма.Параметр.Установить("ТабличнаяЧасть",ТаблЧасть);
    Форма.Параметр.Установить("Работа", ИмяРаботыВн);
    Форма.Параметр.Установить("Ок",1);
    Форма.Закрыть();
    КонецПроцедуры

    Что ещё нужно сделать? и как сохранять значения из ТЗ?
    Заранее спасибо!!!!
     
  2. kaa

    kaa Гость

    так и что не работает?
     
  3. shane13

    shane13 Гость

    Документ как будто ничего не получает(((
     
  4. kaa

    kaa Гость

    Процедура Ок()
    Пар = создатьобъект("СписокЗначений");
    Пар.Установить("ТабличнаяЧасть",ТаблЧасть);
    Пар.Установить("Работа", ИмяРаботыВн);
    Пар.Установить("Ок",1);
    Форма.Параметр = Пар;
    Форма.Закрыть();
    КонецПроцедуры

    попробуйте так
     
  5. shane13

    shane13 Гость

    всё равно... в ТЗ ничего не загружается
     
  6. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Опишите ещё раз последовательность действий - сначала делается таблица в обработке из которой формируется документ, или сначала есть документ, из которого вызывается обработка, в которой что-то меняется и возвращается в документ?
     
  7. shane13

    shane13 Гость

    С алгоритмом загрузки разобрались!!! Спасибо!
    Объясню последовательность: есть документ, из него вызывается обработка, на форме которой осуществляется подбор. Значения из формы передаются с таблицу значений документа.

    Можно ещё вопрос? ) У меня получается так: например, выбираю товар "Сок", который принадлежит группе "Детское питание", а группа "Детское питание" принадлежит группе "Продукты". Так вот у меня в ТЗ записывается "Продукты", а не "Сок".... Т.е. записывается старший родитель. А как этого избежать?

    Очень хотелось бы узнать, как сохранить значения??? Если использовать метод Выгрузка.ВСтрокуСРазделителями() ???
     
Загрузка...
Похожие Темы - Подбор номенклатуры таблицу
  1. ~~DarkNode~~
    Ответов:
    0
    Просмотров:
    11
  2. SergaevOleg
    Ответов:
    6
    Просмотров:
    161
  3. olga13
    Ответов:
    9
    Просмотров:
    3.719
  4. olga13
    Ответов:
    3
    Просмотров:
    7.744
  5. AnaStas
    Ответов:
    0
    Просмотров:
    1.911
Статус темы:
Закрыта.

Поделиться этой страницей