Подбор номенклатуры в таблицу значений

  • Автор темы shane13
  • Дата начала
Статус
Закрыто для дальнейших ответов.
S

shane13

#1
Суть: Есть документ с таблицей значений на форме, в которую надо осуществить подбор номенклатуры и записывать всякие параметры. Я сделала внешнюю обработку, на форме которой разместила реквизиты типа Наименование, Количество, Единица и т.д. По нажатию на кнопку Ок, это всё должно переноситься в таблицу значений в моем документе.
Что я делаю:
В документе пишу:
_________________________________
Процедура НоваяСтрока()
Перем Врем;

Сп=СоздатьОбъект("СписокЗначений");
ТаблРаботы.Выгрузить(Врем);
Сп.Установить("ТабличнаяЧасть",Врем);

Путь=КаталогИБ()+"/ExtForms/NewWork.ert";
ОткрытьФормуМодально("Отчет",Сп, Путь);

Если Число(Сп.Получить("Ок"))=1 Тогда
Врем=Сп.Получить("ТабличнаяЧасть");
ТаблРаботы.Загрузить(Врем);
КонецЕсли;
КонецПроцедуры
_________________________________

В модуле формы внешней обработки пишу:
_________________________________
Процедура ПриОткрытии()
ТаблЧасть=Форма.Параметр.Получить("ТабличнаяЧасть");
КонецПроцедуры // ПриОткрытии()

Процедура Ок()
Форма.Параметр.Установить("ТабличнаяЧасть",ТаблЧасть);
Форма.Параметр.Установить("Работа", ИмяРаботыВн);
Форма.Параметр.Установить("Ок",1);
Форма.Закрыть();
КонецПроцедуры

Что ещё нужно сделать? и как сохранять значения из ТЗ?
Заранее спасибо!!!!
 
K
#4
Процедура Ок()
Пар = создатьобъект("СписокЗначений");
Пар.Установить("ТабличнаяЧасть",ТаблЧасть);
Пар.Установить("Работа", ИмяРаботыВн);
Пар.Установить("Ок",1);
Форма.Параметр = Пар;
Форма.Закрыть();
КонецПроцедуры

попробуйте так
 

puh14

Well-known member
11.07.2008
1 412
0
#6
Опишите ещё раз последовательность действий - сначала делается таблица в обработке из которой формируется документ, или сначала есть документ, из которого вызывается обработка, в которой что-то меняется и возвращается в документ?
 
S

shane13

#7
С алгоритмом загрузки разобрались!!! Спасибо!
Объясню последовательность: есть документ, из него вызывается обработка, на форме которой осуществляется подбор. Значения из формы передаются с таблицу значений документа.

Можно ещё вопрос? ) У меня получается так: например, выбираю товар "Сок", который принадлежит группе "Детское питание", а группа "Детское питание" принадлежит группе "Продукты". Так вот у меня в ТЗ записывается "Продукты", а не "Сок".... Т.е. записывается старший родитель. А как этого избежать?

Очень хотелось бы узнать, как сохранить значения??? Если использовать метод Выгрузка.ВСтрокуСРазделителями() ???
 
Статус
Закрыто для дальнейших ответов.