Подключение компоненти

Тема в разделе "1C и всё что с ней связано", создана пользователем Maxi, 24 июл 2009.

  1. Maxi

    Maxi Гость

    Задача состоит в том штобы подключить терминал сбора данных (Casio-DT 930) к 1с
    Подключается он с помощю библиотеки HRP .
    вот уривок с инструкцыи

    1. Скопировать 1C_Hrp.dll в каталог с базой данных 1С
    2. Скопировать Hrp.dll в системный каталог, например C:\Windows\System32

    3. Из обработки вызвать функцию загрузки компоненты, она вернет объект.
    вот по поводу етого у меня и возникли вопросы . Пожалуста подскажыте как ето зделать у меня имеется скрипт подключения вот он:


    Параметры функции
    Компонента=1C_HRP.DLL
    ПрогИд=Hrp

    Функция вызова
    // *****************************************************************************
    // Описание:
    // Загружает внешнюю компоненту, создает объект и включает

    Функция Подключить(Компонента, ПрогИд, Объект)
    Рез = 0;

    Если ЗагрузитьВнешнююКомпоненту(Компонента) = 0 Тогда
    ОписаниеРезультата = "ошибка загрузки внешней компоненты """ + Компонента + """";
    Иначе
    Попытка
    Объект = СоздатьОбъект("AddIn." + ПрогИд); // Создание объекта внешней компоненты
    Исключение
    КонецПопытки;

    Если ПустоеЗначение(Объект) = 1 Тогда
    ОписаниеРезультата = "ошибка создания объект внешней компоненты с программым идентификатром AddIn." + ПрогИд;
    Иначе
    ОписаниеРезультата = "Терминал CASIO DT-900 подключен в режиме сервера";
    Сообщить ("Терминал CASIO DT-900 подключен в режиме сервера","I");
    Рез = 1;
    КонецЕсли;
    КонецЕсли;

    Возврат Рез;
    КонецФункции









    Но вся фишка в том што я в 1с не работал.
    Обясните пожалуста где найти етот модуль штобы ввести етот скрипт ...!
    Заране спасибо.
     
  2. kaa

    kaa Гость

    Сервис-Подключение торгового оборудования, закладка Терминалы указываешь dll и имя обекта и т.д.
     
  3. Maxi

    Maxi Гость

    Почемуто не нашол такой вкладки Настройка торгового оборудывания нашол а вот подключение нету в меню Сервис у меня 1с 7.7
    вот скрин:
     

    Вложения:

    • _____.JPG
      _____.JPG
      Размер файла:
      80,9 КБ
      Просмотров:
      20
  4. KSergei

    KSergei Гость

    Зайди в настройку торгового оборудования
     
  5. Maxi

    Maxi Гость

    Там нету у меня там просто заведены торговые точки
    повторюсь моей целю является :
    Загрузка функции присойденения компоненты.
     
Загрузка...

Поделиться этой страницей