Подключение компоненти

  • Автор темы Maxi
  • Дата начала
M

Maxi

#1
Задача состоит в том штобы подключить терминал сбора данных (Casio-DT 930) к 1с
Подключается он с помощю библиотеки HRP .
вот уривок с инструкцыи

1. Скопировать 1C_Hrp.dll в каталог с базой данных 1С
2. Скопировать Hrp.dll в системный каталог, например C:\Windows\System32

3. Из обработки вызвать функцию загрузки компоненты, она вернет объект.
вот по поводу етого у меня и возникли вопросы . Пожалуста подскажыте как ето зделать у меня имеется скрипт подключения вот он:


Параметры функции
Компонента=1C_HRP.DLL
ПрогИд=Hrp

Функция вызова
// *****************************************************************************
// Описание:
// Загружает внешнюю компоненту, создает объект и включает

Функция Подключить(Компонента, ПрогИд, Объект)
Рез = 0;

Если ЗагрузитьВнешнююКомпоненту(Компонента) = 0 Тогда
ОписаниеРезультата = "ошибка загрузки внешней компоненты """ + Компонента + """";
Иначе
Попытка
Объект = СоздатьОбъект("AddIn." + ПрогИд); // Создание объекта внешней компоненты
Исключение
КонецПопытки;

Если ПустоеЗначение(Объект) = 1 Тогда
ОписаниеРезультата = "ошибка создания объект внешней компоненты с программым идентификатром AddIn." + ПрогИд;
Иначе
ОписаниеРезультата = "Терминал CASIO DT-900 подключен в режиме сервера";
Сообщить ("Терминал CASIO DT-900 подключен в режиме сервера","I");
Рез = 1;
КонецЕсли;
КонецЕсли;

Возврат Рез;
КонецФункции









Но вся фишка в том што я в 1с не работал.
Обясните пожалуста где найти етот модуль штобы ввести етот скрипт ...!
Заране спасибо.
 
K
#2
Сервис-Подключение торгового оборудования, закладка Терминалы указываешь dll и имя обекта и т.д.
 
M

Maxi

#3
Сервис-Подключение торгового оборудования, закладка Терминалы указываешь dll и имя обекта и т.д.
Почемуто не нашол такой вкладки Настройка торгового оборудывания нашол а вот подключение нету в меню Сервис у меня 1с 7.7
вот скрин:
 

Вложения