Поиск документа в журналах документов

  • Автор темы pinhead
  • Дата начала
P

pinhead

#1
Имеется журнал документов, в модуле формы журнала документов выполняется процедура "ОбработкаВнешнегоСобытия(Источник, Событие, Данные)", при выполнении которой в параметре "Данные" имеется число (номер документа).
Необходимо, чтобы в процессе выполнения прцедуры указатель переместился на документ с номером записанном в параметре "Данные".
Проще: имеется считыватель штрих кодов, надо чтобы после сканирования указатель в журнале документов позиционировался на документ с номером считанным сканером.
 
T

TimeDontWait

#4
тоесть вы просто хотите поменять координаты мыши в определенный момент, или я не правильно понял ? а если так, то зачем стоко расписывать...
 
P

pinhead

#5
тоесть вы просто хотите поменять координаты мыши в определенный момент, или я не правильно понял ? а если так, то зачем стоко расписывать...
Под указателем я понимаю не указатель мыши а вот это -
 

Вложения

G

Gluk8888

#6
Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
Если Событие="BarCodeValue" Тогда
ТаблицаДоков = ПолучитьДокументыПоШтрихкоду(Данные); --- должна быть ваша обработка данных полученных со сканера ШК, в итоге должна получится таблица значений
Если ТаблицаДоков.КоличествоСтрок() <> 0 Тогда
Док = СоздатьОбъект("Документ");
Док.НайтиДокумент(ТаблицаДоков.ПолучитьЗначение(1,1));
Если Док.ДатаДок < НачалоИнтервала() Тогда
УстановитьИнтервал(Док.ДатаДок,КонецИнтервала(),1);
КонецЕсли;
Если Док.ДатаДок > КонецИнтервала() Тогда
УстановитьИнтервал(НачалоИнтервала(),Док.ДатаДок,1);
КонецЕсли;
АктивизироватьОбъект(Док.ТекущийДокумент());
КонецЕсли;
КонецЕсли;
КонецПроцедуры // ОбработкаВнешнегоСобытия
 

unknown181538

НеГуру
28.12.2008
1 417
0
#7
Между прочим, автор не указал платформу:) Конечно, по скрину видно...
:happy: