Поиск документа в журналах документов

Тема в разделе "1C и всё что с ней связано", создана пользователем pinhead, 9 ноя 2010.

  1. pinhead

    pinhead Гость

    Имеется журнал документов, в модуле формы журнала документов выполняется процедура "ОбработкаВнешнегоСобытия(Источник, Событие, Данные)", при выполнении которой в параметре "Данные" имеется число (номер документа).
    Необходимо, чтобы в процессе выполнения прцедуры указатель переместился на документ с номером записанном в параметре "Данные".
    Проще: имеется считыватель штрих кодов, надо чтобы после сканирования указатель в журнале документов позиционировался на документ с номером считанным сканером.
     
  2. kaa

    kaa Гость

    И где вопрос? :)
     
  3. pinhead

    pinhead Гость

    Необходимо, чтобы в процессе выполнения прцедуры указатель переместился на документ с номером записанном в параметре "Данные".
     
  4. TimeDontWait

    TimeDontWait Well-Known Member

    Регистрация:
    4 янв 2010
    Сообщения:
    383
    Симпатии:
    0
    тоесть вы просто хотите поменять координаты мыши в определенный момент, или я не правильно понял ? а если так, то зачем стоко расписывать...
     
  5. pinhead

    pinhead Гость

    Под указателем я понимаю не указатель мыши а вот это -
     

    Вложения:

    • Clipboard01.jpg
      Clipboard01.jpg
      Размер файла:
      41,8 КБ
      Просмотров:
      28
  6. Gluk8888

    Gluk8888 Гость

    Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
    Если Событие="BarCodeValue" Тогда
    ТаблицаДоков = ПолучитьДокументыПоШтрихкоду(Данные); --- должна быть ваша обработка данных полученных со сканера ШК, в итоге должна получится таблица значений
    Если ТаблицаДоков.КоличествоСтрок() <> 0 Тогда
    Док = СоздатьОбъект("Документ");
    Док.НайтиДокумент(ТаблицаДоков.ПолучитьЗначение(1,1));
    Если Док.ДатаДок < НачалоИнтервала() Тогда
    УстановитьИнтервал(Док.ДатаДок,КонецИнтервала(),1);
    КонецЕсли;
    Если Док.ДатаДок > КонецИнтервала() Тогда
    УстановитьИнтервал(НачалоИнтервала(),Док.ДатаДок,1);
    КонецЕсли;
    АктивизироватьОбъект(Док.ТекущийДокумент());
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры // ОбработкаВнешнегоСобытия
     
  7. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Между прочим, автор не указал платформу:) Конечно, по скрину видно...
    :happy:
     
Загрузка...

Поделиться этой страницей