Поиск дублирующих строк в документе

BBDragon

Well-known member
04.05.2008
148
0
#1
В общем необходимо найти дубли в многострочном документе (дублем считается строка совпадающая с более ранней строкой по ряду параметров). Первоначально делал как отдельную процедуру - не работало. В итоге внес проверку в тело основной процедуры, в итоге заработало, но некорректно - за дубль программа принимает только предпоследнюю дублирующую строку в документе вне зависимости от того сколько их имеется. Поясню: например у нас 10 строк, строки 1 и 3 имеют дубликаты с номерами 2, 6 и 8,9 соответственно. Так вот, в результате проверки как дубль будет выведена только строка 8 и все!!

Код:
СписокДублей = СоздатьОбъект("СписокЗначений");
ВыбратьСтроки(); 
НомерПоПорядку=1;
Пока ПолучитьСтроку() = 1 Цикл

Если СписокДублей.НайтиЗначение (НомерПоПорядку)= 0 Тогда 
Для СчетСтр=1 по КоличествоСтрок() Цикл 
ПолучитьСтрокуПоНомеру(СчетСтр);
Если (СчетСтр<>НомерПоПорядку) Тогда 
Если (Фамилия=ФамилияПациента) и (Имя=ИмяПациента) и
(Отчество=ВРЕГ(СокрЛП(ОтчествоПациента) и 
ДатаРожд=ДатаРожденияПациента) и (Профиль =КодПрофиля) Тогда //
СписокДублей.ДобавитьЗначение(СчетСтр);
КонецЕсли; 
КонецЕсли;
КонецЦикла;
КонецЕсли; 
ПолучитьСтрокуПоНомеру(НомерПоПорядку);
Если СписокДублей.НайтиЗначение (НомерПоПорядку)= 1 Тогда
Дубли="V";
КонецЕсли;
Если (Дубли="V") Тогда 
ТЗ.НоваяСтрока();
ТЗ.Фамилия = Фамилия;
ТЗ.Имя = Имя;
ТЗ.Отчество = Отчество;
ТЗ.ДатаРождения = ДатаРожд;
ТЗ.Дубликат = Дубли; 
КонецЕсли;
НомерПоПорядку=НомерПоПорядку+1;
КонецЦикла;

Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Ошибки");
Таб.ВывестиСекцию("Заголовок");
ТЗ.ВыбратьСтроки(); // открываем выборку строк из д. таблицы
Пока ТЗ.ПолучитьСтроку()=1 Цикл
Фамилия=ТЗ.Фамилия; 
Имя=ТЗ.Имя;	  
Отчество=ТЗ.Отчество;
ДатаРождения = ТЗ.ДатаРождения;
Повтор = ТЗ.Дубликат;
Таб.ВывестиСекцию("Ошибка");
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.ПараметрыСтраницы(1,100,1);
Таб.Показать("Ошибки","");
Список параметров для сравнения и количество полей в Таблице Значений сокращены для улучшения читаемости; за вывод результата отвечает переменная Повтор печатной формы "Ошибки". Вроде бы простецкая задачка, а все никак не могу наладить корректный вывод результатов ;)
 
T

TimeDontWait

#2
А какое действие должно быть в результате нахождения дубля?
И много строчек может быть в т.ч. ?
 

BBDragon

Well-known member
04.05.2008
148
0
#3
А какое действие должно быть в результате нахождения дубля?
И много строчек может быть в т.ч. ?
Ну я вообще хотел сделать такой алгоритм:

Предварительно создаю список значений. Далее начинаю перебирать строки документа. Если номер текущей строки отсутствует в СЗ, то начинаем проверять все строки документа с первой по последнюю. При совпадении указанных параметров заносим номер строки (из второго цикла) в СЗ (естественно строку с самой собой не сравниваем). После окончания проверки позиционируемся опять на нужную строку (НомерПоПорядку) и проверяем наличие этого номера в СЗ, если есть - то переменную Дубли приравниваем к "V". Далее при наличии ошибки заносим данные по человеку в ТЗ, по окончании полного цикла проверки перебираем ее строки и выводим на экран.
Строчек может быть и 1, и 1000, я пока проверяю на маленьких примерах (копирую 2-3 строки по 2-3 раза и запускаю проверку). Код очень корявый, но он работает, правда совсем не так как надо(
 
T

TimeDontWait

#4
Вообщем так. Лень разбираться в коде, преложу такой вариант.
- выгружаеш в тз;
- задаеш переменную дубль=0;
- Выборка строк;
- пока получаеш строку перебираеш тз, если находиш дубль по параметрам - ставиш переменную+1;
- В конце проверка - Если дубль>1 тогда действие;
- обнуление переменной;
Вообщем как-то так
 

BBDragon

Well-known member
04.05.2008
148
0
#5
Вообщем так. Лень разбираться в коде, преложу такой вариант.
- выгружаеш в тз;
- задаеш переменную дубль=0;
- Выборка строк;
- пока получаеш строку перебираеш тз, если находиш дубль по параметрам - ставиш переменную+1;
- В конце проверка - Если дубль>1 тогда действие;
- обнуление переменной;
Вообщем как-то так
Умная мысль, тоже думал попробовать вариант с ТЗ, но детально еще не продумывал. Спасибо огромное за подсказку! ;)
Завтра с утра проверю все, а то осталось 15 минут и процессор уже совсем не варит..
 

Дайнеко

Well-known member
19.11.2009
951
0
#7
- выгружаеш в тз;
- задаеш переменную дубль=0;
Да, мысль с переменной можно развить.
- выгружаеш в тз;
- добавить колонку Дубль
- пройти по строкам и проставить 1
- Свернуть. Полей для сравнения вижу много.
Получается компактненько.
 
K
#8
выгрузить таб часть в 2 таблицы значений, одну свернуть по параметрам и сравнить количество строк отличается, есть дубли строк
 

BBDragon

Well-known member
04.05.2008
148
0
#9
Уфф.. наконец-то, я это сделал. Сделал с использованием второй ТЗ и СЗ, но дело было совсем не в этом. Виновата была строчка

Код:
Если СписокДублей.НайтиЗначение (НомерПоПорядку)= 1 Тогда
Помня, что если значение не найдено, то возвращается 0, я автоматически решил, что при обнаружении возвращаться должно 1, не удосужившись проверить синтаксис :)
Само собой что при выводе он видел только первую дублирующую строку :)
Хула мне, стало быть и позор :)

Потратил кучу времени на элементарную процедуру, но еще раз понял простую мысль:
Если алгоритм правильный, а что-то не получается - надо обязательно проверить синтаксис.

Всем еще раз спасибо :)