1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

поиск элементов справочника7

Тема в разделе "Базы данных и администрирование", создана пользователем kleo, 31 авг 2007.

  1. kleo

    kleo Гость

    Репутация:
    0
    Люди добрые, подскажите, пожалуйста, как найти элементы справочника с одиннаковым наименованием, а потом среди них один элемент с нужными мне реквизитами!! Заранее очень спасибо!!!
     
  2. vitfil

    vitfil IT-интегратор

    Репутация:
    0
    Регистрация:
    2 апр 2004
    Сообщения:
    2.062
    Симпатии:
    0
    Например, простым перебором.
     
  3. kaa

    kaa Гость

    Репутация:
    0
    Табло=СоздатьОбъект("ТаблицаЗначения");
    Табло.НоваяКолонка("Элемент");
    Табло.НоваяКолонка("НужныйРеквизит");
    Наим = "одинаковое наименование";

    Запрос = СоздатьОбъект("Запрос");

    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Элем = Справочник.ХХХ.ТекущийЭлемент;
    |Наименование = Справочник.ХХХ.Наименование;
    |Условие (Найти(Наименование,Наим)>0);
    |Группировка Элем без групп;
    |";

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    Пока Запрос.Группировка(1) = 1 Цикл
    Табло.НоваяСтрока();
    Табло.Элемент = Запрос.Элем;
    Табло.НужныйРеквизит = Запрос.Элем.НужныйРеквизит
    КонецЦикла;

    НужныйРеквизитПоиск = """"";

    Стр = "";
    Если Табло.НайтиЗначение(НужныйРеквизитПоиск,Стр,"НужныйРеквизит")=1 Тогда
    НужныйЭлементПоПоиску = Табло.ПолучитьЗначение(Стр,"Элемент");
    КонецЕсли;
     
  4. kleo

    kleo Гость

    Репутация:
    0
    Насчет перебора предложение не пойдет, так как займет очень много времени, а вот запрос сейчас испробую. Спасибо большое!!!!!
     
  5. Zab

    Zab Well-Known Member

    Репутация:
    0
    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Можешь еще глянуть метод справочника НайтиПоНаименованию().
     
  6. vbs

    vbs Well-Known Member

    Репутация:
    0
    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    ... и наткнувшись на нужное наименование, проверять нужные реквизиты, пока совпадает наименование
     
  7. ModusPonens

    ModusPonens Гость

    Репутация:
    0
    Можно еще попробовать метод ВыбратьЭлементыПоРеквизиту, и из выборки выбрать нужный.
    Но лучше всего - запросом.
     
Загрузка...

Поделиться этой страницей