поиск элементов справочника7

  • Автор темы kleo
  • Дата начала
K

kleo

#1
Люди добрые, подскажите, пожалуйста, как найти элементы справочника с одиннаковым наименованием, а потом среди них один элемент с нужными мне реквизитами!! Заранее очень спасибо!!!
 
K
#3
Табло=СоздатьОбъект("ТаблицаЗначения");
Табло.НоваяКолонка("Элемент");
Табло.НоваяКолонка("НужныйРеквизит");
Наим = "одинаковое наименование";

Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Элем = Справочник.ХХХ.ТекущийЭлемент;
|Наименование = Справочник.ХХХ.Наименование;
|Условие (Найти(Наименование,Наим)>0);
|Группировка Элем без групп;
|";

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

Пока Запрос.Группировка(1) = 1 Цикл
Табло.НоваяСтрока();
Табло.Элемент = Запрос.Элем;
Табло.НужныйРеквизит = Запрос.Элем.НужныйРеквизит
КонецЦикла;

НужныйРеквизитПоиск = """"";

Стр = "";
Если Табло.НайтиЗначение(НужныйРеквизитПоиск,Стр,"НужныйРеквизит")=1 Тогда
НужныйЭлементПоПоиску = Табло.ПолучитьЗначение(Стр,"Элемент");
КонецЕсли;
 
K

kleo

#4
Насчет перебора предложение не пойдет, так как займет очень много времени, а вот запрос сейчас испробую. Спасибо большое!!!!!
 

Zab

Well-known member
07.08.2006
583
0
#5
Можешь еще глянуть метод справочника НайтиПоНаименованию().
 

vbs

Well-known member
18.02.2007
1 708
1
#6
... и наткнувшись на нужное наименование, проверять нужные реквизиты, пока совпадает наименование
 
M

ModusPonens

#7
Можно еще попробовать метод ВыбратьЭлементыПоРеквизиту, и из выборки выбрать нужный.
Но лучше всего - запросом.