Поиск подчиненного документа 1С 7.7

  • Автор темы Guest
  • Дата начала
G

Guest

#1
Конфигурация 7.7
Не могу найти похожих статей... Подскажите плз....
Надо перебрать в журнале документов все Приходные накладные (с нач года и по тек дату) и проверить если у них подчиненные документы СчетФактуры, если есть то поменять сумму документа или есче что0нить сотворить над ней....
Находил несколько решений, но все какие-то ошибки вылазят...
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
во-первых можно сделать запрос и отбирать только нужные докуметны - т.е. те, которые содержат подчиненные СчетФактуры (указать в запросе подобное условие)
во-вторых - любые ошибки в студию. ибо иначе предметного разговора не получицо.
 
G

Guest

#3
Код:
Док = СоздатьОбъект("Документ.ЛМБ_ОперацияПоЗалогу");
Если Док.ВыбратьПодчиненныеДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()),ТекущийДокумент())=1 Тогда
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Вид() = "СчетаФактурыВыданные" Тогда
//Абра-Кадабра
КонецЕсли;
КонецЦикла;
КонецЕсли;
Вот такой кусок кода написал... вот только до Абры-Кадабры он не доходит....
 

vbs

Well-known member
18.02.2007
1 708
1
#4
Док = СоздатьОбъект("Документ.ЛМБ_ОперацияПоЗалогу");
ДокП = СоздатьОбъект("Документ");
Док.ВыбратьДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()))
Пока Док.ПолучитьДокумент()=1 Цикл
Если ДокП.ВыбратьПодчиненныеДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()),Д
ок.ТекущийДокумент())=1 Тогда
Пока ДокП.ПолучитьДокумент()=1 Цикл
Если ДокП.Вид() = "СчетаФактурыВыданные" Тогда
//Абра-Кадабра
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;
 
G

Guest

#5
Vbs, 3яя строчка не проходит, т.к. нужен 3й параметр... ТекущийДокумент() тоже не канает =(
Код:
Док.ВыбратьДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()))
 

vbs

Well-known member
18.02.2007
1 708
1
#6
И зачем тебе 3-й параметр, если данный метод подразумевает только два ? Три нужно для выбора подчиненных.
Вот правильный синтаксис (точки с запятой не было) :
Док.ВыбратьДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()));
ТекущийДокумент() тоже не канает =(
а эту предъяву просто не понял :)
ДокП.ВыбратьПодчиненныеДокументы(НачГода(ТекущаяДата()),
КонГода(ТекущаяДата()),Док.ТекущийДокумент()); - и вот это не работает ?
Вспомни Станиславского :)
 
G

Guest

#7
аааа... маза-фака... пардон текст серый - расплывается не разгладел Извини тем более глаза слипаются а завтра сдаваться =) Щас переделаю и попробую...
 

vbs

Well-known member
18.02.2007
1 708
1
#8
Для настоящего программиста полночь - самое время творить -:)
 

DiasA

New member
05.03.2016
1
0
#10
Док = СоздатьОбъект("Документ.ЛМБ_ОперацияПоЗалогу");
Если Док.ВыбратьПодчиненныеДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()),ТекущийДокумент())=1 Тогда
Пока Док.ПолучитьДокумент()=1 Цикл
Если Док.Вид() = "СчетаФактурыВыданные" Тогда
//Абра-Кадабра
КонецЕсли;
КонецЦикла;
КонецЕсли;
------------------------------
Вот такой кусок кода написал... вот только до Абры-Кадабры он не доходит....
-----------------------------

Мой ответ :
Вы что белены объелись ?
вы изначально выбираете документы только (ЛМБ_ОперацияПоЗалогу) Док = СоздатьОбъект("Документ.ЛМБ_ОперацияПоЗалогу");
какая тогда может быть проверка на Если Док.Вид() = "СчетаФактурыВыданные" Тогда ????