Поиск подчиненного документа 1С 7.7

Тема в разделе "1C и всё что с ней связано", создана пользователем -, 18 дек 2009.

  1. Гость

    Конфигурация 7.7
    Не могу найти похожих статей... Подскажите плз....
    Надо перебрать в журнале документов все Приходные накладные (с нач года и по тек дату) и проверить если у них подчиненные документы СчетФактуры, если есть то поменять сумму документа или есче что0нить сотворить над ней....
    Находил несколько решений, но все какие-то ошибки вылазят...
     
  2. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    во-первых можно сделать запрос и отбирать только нужные докуметны - т.е. те, которые содержат подчиненные СчетФактуры (указать в запросе подобное условие)
    во-вторых - любые ошибки в студию. ибо иначе предметного разговора не получицо.
     
  3. Гость

    Код (Text):
    Док = СоздатьОбъект("Документ.ЛМБ_ОперацияПоЗалогу");
    Если Док.ВыбратьПодчиненныеДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()),ТекущийДокумент())=1 Тогда
    Пока Док.ПолучитьДокумент()=1 Цикл
    Если Док.Вид() = "СчетаФактурыВыданные" Тогда
    //Абра-Кадабра
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    Вот такой кусок кода написал... вот только до Абры-Кадабры он не доходит....
     
  4. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Док = СоздатьОбъект("Документ.ЛМБ_ОперацияПоЗалогу");
    ДокП = СоздатьОбъект("Документ");
    Док.ВыбратьДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()))
    Пока Док.ПолучитьДокумент()=1 Цикл
    Если ДокП.ВыбратьПодчиненныеДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()),Д
    ок.ТекущийДокумент())=1 Тогда
    Пока ДокП.ПолучитьДокумент()=1 Цикл
    Если ДокП.Вид() = "СчетаФактурыВыданные" Тогда
    //Абра-Кадабра
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
     
  5. Гость

    Vbs, 3яя строчка не проходит, т.к. нужен 3й параметр... ТекущийДокумент() тоже не канает =(
    Код (Text):
    Док.ВыбратьДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()))
     
  6. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    И зачем тебе 3-й параметр, если данный метод подразумевает только два ? Три нужно для выбора подчиненных.
    Вот правильный синтаксис (точки с запятой не было) :
    Док.ВыбратьДокументы(НачГода(ТекущаяДата()),КонГода(ТекущаяДата()));
    а эту предъяву просто не понял :)
    ДокП.ВыбратьПодчиненныеДокументы(НачГода(ТекущаяДата()),
    КонГода(ТекущаяДата()),Док.ТекущийДокумент()); - и вот это не работает ?
    Вспомни Станиславского :)
     
  7. Гость

    аааа... маза-фака... пардон текст серый - расплывается не разгладел Извини тем более глаза слипаются а завтра сдаваться =) Щас переделаю и попробую...
     
  8. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Для настоящего программиста полночь - самое время творить -:)
     
  9. WildAnther

    WildAnther Гость

    Ночью и компьютер лучше работает.=)
     
Загрузка...

Поделиться этой страницей