Поиск в 1С

  • Автор темы arhiordinator
  • Дата начала
A

arhiordinator

#1
Всем привет, пишу программу для поиска данных в справочнике, вот мой код:
Процедура Поиск()
Т.УдалитьСтроки();
спрняни.ВыбратьЭлементы();
Пока спрняни.ПолучитьЭлемент()=1 Цикл
обрз=спрняни.образование;
Если Найти (СокрЛП(обрз),СокрЛП(обр.наименование))>0 Тогда
Т.НоваяСтрока();
Т.образ=обрз;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Он находит слово "Среднее" -ток если оно указано с большой буквы, а как сделать, что бы поиск не был чувствителен в регистру
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
Можешь сделать так
Код:
ЕслиНайти (СокрЛП(ВРЕГ(обрз)),СокрЛП(ВРЕГ(обр.наименование)))>0 Тогда
он тогда все будет переводить в верхний регистр и сравнивать между собой.
P.S. возможно Врег и СокрЛП нужно будет поменять местами
 

gorlanovmax

Well-known member
19.06.2008
286
0
#3
Если Найти (ВРег(СокрЛП(обрз)),Врег(СокрЛП(обр.наименование)))>0 Тогда


Опоздал ;)
 
A

arhiordinator

#4
А что интересная идея надо попробовать, спасибки!!! И от куда вы всё знаете?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#5
далеко не все! но с подобным сталкиваться приходится пожалуй каждому
 
A

arhiordinator

#8
Блин этот поиск не правильно работает, а что надо использовать если пользователь вводит только часть слова?

не работает как надо поиск, надо ещё чтобы он искал только используя часть слова, как это сделать)

а то он всё сразу выводит, если часть слова ввести
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#9
Найти(<?>,)
Синтаксис:
Найти(<Строка1>,<Строка2>)
Назначение:
Возвращает позицию первого вхождения в строку поиска заданной подстроки.
Параметры:
<Строка1> - строка в которой ищем (место поиска);
<Строка2> - строка которую ищем (шаблон поиска).
Замечание:
Если не находит - возвращает число 0.
Первая позиция имеет индекс 1.

Соответсвенно если пользователь введет последовательность символов и она будет таки в тексте (напрмер ищем "ДНЕ" в строке "СРЕДНЕЕ") то все отработано верно.
несовсем ясно это:
Блин этот поиск не правильно работает, а что надо использовать если пользователь вводит только часть слова?

P.S. объясни подробно что тебе нужно сделать и мы подумаем какой самый лучший способ для этого
 
A

arhiordinator

#10
ой да, точно, я лохонулся малость) Надо бы поспать пожалуй)))

Спасибки, я разобрался, просто не к тому окну обращался)