1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

ПоказыватьУдаленные

Тема в разделе "Базы данных и администрирование", создана пользователем Renat11111, 16 окт 2008.

  1. Renat11111

    Renat11111 Well-Known Member

    Репутация:
    0
    Регистрация:
    20 апр 2008
    Сообщения:
    123
    Симпатии:
    0
    В одной умной книжке про метод ПоказыватьУдаленные сказано:

    ПоказыватьУдаленные
    Установить режим показа удаленных записей в базе.
    Синтаксис:
    ПоказыватьУдаленные(<Режим>)
    Англоязычный синоним:
    ShowDeleted
    Параметры:
    <Режим> Необязательный параметр. Числовое выражение: 1 — установить режим показа удаленных записей в базе. 0 — снять режим.
    Возвращаемое значение:
    Текущее числовое значение режима показа удаленных записей в базе (на момент до исполнения метода).
    Описание:
    Метод ПоказыватьУдаленные позволяет определить и изменить режим показа удаленных записей в базе.
    В случае, если параметр не указан, изменения режима не происходит.
    Пример:
    Процедура ПоказатьНомераУдалЗап()
    РежПокУд = ДБФ.ПоказыватьУдаленные(1);
    ДБФ.Первая();
    Пока ДБФ.ВКонце() = 0 Цикл
    Если ДБФ.ЗаписьУдалена() = 1 Тогда
    Предупреждение("Номер удаленной записи — " +
    Строка(ДБФ.НомерЗаписи()), 3);
    КонецЕсли;
    Если ДБФ.Следующая() = 0 Тогда
    Прервать;
    КонецЕсли;
    КонецЦикла;
    ДБФ.ПоказыватьУдаленные(РежПокУд);
    КонецПроцедуры
    См. также: Удалить, Восстановить

    Как я понял с данного примера что дбф по любому хранит даже удаленные записи, в связи с чем вопрос влияет ли это на размер дбф и второй
    если влияет то можно ли удалить полность эти записи из дбф?
     
  2. vbs

    vbs Well-Known Member

    Репутация:
    0
    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Живут они в общем виде как помеченные на удаление. Процедура Pack() удаляет их физически и размер файла уменьшается
     

Поделиться этой страницей