ПоказыватьУдаленные

Renat11111

Well-known member
20.04.2008
123
0
#1
В одной умной книжке про метод ПоказыватьУдаленные сказано:

ПоказыватьУдаленные
Установить режим показа удаленных записей в базе.
Синтаксис:
ПоказыватьУдаленные(<Режим>)
Англоязычный синоним:
ShowDeleted
Параметры:
<Режим> Необязательный параметр. Числовое выражение: 1 — установить режим показа удаленных записей в базе. 0 — снять режим.
Возвращаемое значение:
Текущее числовое значение режима показа удаленных записей в базе (на момент до исполнения метода).
Описание:
Метод ПоказыватьУдаленные позволяет определить и изменить режим показа удаленных записей в базе.
В случае, если параметр не указан, изменения режима не происходит.
Пример:
Процедура ПоказатьНомераУдалЗап()
РежПокУд = ДБФ.ПоказыватьУдаленные(1);
ДБФ.Первая();
Пока ДБФ.ВКонце() = 0 Цикл
Если ДБФ.ЗаписьУдалена() = 1 Тогда
Предупреждение("Номер удаленной записи — " +
Строка(ДБФ.НомерЗаписи()), 3);
КонецЕсли;
Если ДБФ.Следующая() = 0 Тогда
Прервать;
КонецЕсли;
КонецЦикла;
ДБФ.ПоказыватьУдаленные(РежПокУд);
КонецПроцедуры
См. также: Удалить, Восстановить

Как я понял с данного примера что дбф по любому хранит даже удаленные записи, в связи с чем вопрос влияет ли это на размер дбф и второй
если влияет то можно ли удалить полность эти записи из дбф?
 

vbs

Well-known member
18.02.2007
1 708
1
#2
Живут они в общем виде как помеченные на удаление. Процедура Pack() удаляет их физически и размер файла уменьшается