Получение остатка

Тема в разделе "1C и всё что с ней связано", создана пользователем SeverBap, 7 окт 2008.

  1. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Вообщем есть регистр остатков СуммаОплат;
    Измерения: Год (Справочник.НалоговыйПериод - грыппы), месяц (число), Налог (Справочник.ОтчетныеПериоды);
    Ресурсы: СуммаОплат (Число,15,2), СуммаОплатПени (Число,15,2);

    :)

    Незнаю как оброщатся к регистру с получение значения СуммаОплат на заданную дату!!! я написал такой:
    Код (Text):
    Функция ПолучитьСуммуОплатНаДату(ДатаОпределения,Элемент)
    РегистрВиртуальный=СоздатьОбъект("Регистр.СуммаОплат");
    РегистрВиртуальный.ВременныйРасчет(1);
    СуммаОплат=0;
    РегистрВиртуальный.ВыбратьДвижения(,ДатаОпределения);
    Пока РегистрВиртуальный.ПолучитьДвижение()=1 Цикл
    Если (РегистрВиртуальный.Налог=Элемент) И (РегистрВиртуальный.Год=Элемент.Владелец.Родитель) И (РегистрВиртуальный.Месяц=Число(Элемент.Код)) Тогда
    СуммаОплат=СуммаОплат+РегистрВиртуальный.СуммаОплат;
    КонецЕсли;
    КонецЦикла;
    Возврат СуммаОплат;
    КонецФункции
    он же через цикл!!!!!!! А дата меняется тоже через цикл!!!!! И налог сам тоже из выборки вот и результ тормоз а не результ на 12 сек!!!!

    :) Пацаны посоветуйте че к чему мне исправить!!!!!!
     
  2. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    РегистрВиртуальный.УстановитьФильтр(Элемент.Владелец.Родитель, Число(Элемент.Код), Элемент);

    Попробуй фильтрануть до выборки движений - а то он у тебя все движения перебирает.


    а просто сводный остаток не устраивает - надо именно в интервале ДатаОпределения? Тогда проще через запрос сделать
     
  3. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Пацаны, братва, откликнитесь, помогите пацану!
    Тьфу, аж читать противно. Словно в подворотне какой московской очутился.
     
  4. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    vitfil Главный пацан проснулся!!! ..., пока Вы тут думали я уже решел все проблемы!!!!
    :)
    Сори если кого оскорбил!!! Я сам не мальчик!!!!
     
  5. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Bap
    Дело не в возрасте, а в уважительном обращении к софорумчанам...
     
  6. kaa

    kaa Гость

    Функция ПолучитьСуммуОплатНаДату(ДатаОпределения,Элемент)
    РегистрВиртуальный=СоздатьОбъект("Регистр");
    РегистрВиртуальный1 = РегистрВиртуальный.СуммаОплат;
    РегистрВиртуальный1.ВременныйРасчет(1);
    РегистрВиртуальный.РассчитатьРегистрыПо(ДатаОпределения);
    СуммаОплат= РегистрВиртуальный1.СводныйОстаток(Элемент.Владелец.Родитель,Число(Элемент.Код),
    Элемент,"СуммаОплат");
    Возврат СуммаОплат;
    КонецФункции
    Это если регистр остатков и вставить проверку на актуальнсть итогов,
    если оборотный тогда через движения и установитьзначениефильтра без расчета
     
  7. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Код (Text):
    РегистрВиртуальный=СоздатьОбъект("Регистр");
    пишит что неудачная попытка создать регистр .... :) очень странно однако ... наверно из-за того что это функция !!!!!!
     
  8. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    РегистрВиртуальный=СоздатьОбъект("Регистры");
     
  9. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Бред какой-то, теперь она в цикле дохнит (верней зацикливается) а поменял только листинг в этой функции!!!

    Вот я старый хрычь!!! Циклится (верней зависла) по пречине мой забывчивости не дописал по дате уточнение!!! ТА вообщем как всегда!! (хотя по моему методу работает нормально без вопросов к ТА!!!) .... вот так!!! Счас допишу и проверю!!!!

    Скажите кто-нибудь знает для чего "%"???? и с чем его едят, смотрю в встроином языке нет его и ошибок нет при написание!! где можно это прочесть для чего он этот "%" ....
     
  10. kaa

    kaa Гость

    Вот черт очепятка :)
     
  11. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    все нормально я опечатку сам нашел!!!
     
Загрузка...

Поделиться этой страницей