Поменять видимость

  • Автор темы Leon3
  • Дата начала
L

Leon3

#1
Помогите пожалйста кто знает? Нужно Из обработки Поменять видимость колонки Таблицы !
Форма.<НазваниеКолонки>.Видимость(0);
Док.Форма.НП.Видимость(0) - ТАк Не Работает! Форма - можно использовать только из модуля документа! Можно ли вообще это сделать?
 

puh14

Well-known member
11.07.2008
1 412
0
#2
Что ты имеешь ввиду под таблицей? ТаблицуЗначений? или табличную часть документа?
попробуй тоже-только без ДОК

Форма.НП.Видимость(0)
 

vbs

Well-known member
18.02.2007
1 708
1
#3
Для таблицы значений :
ВидимостьКолонки(<?>,,);
ColumnVisibility(<?>,,);
Синтаксис:
ВидимостьКолонки(<Колонки>,<Видимость>,<Позиция>)
Назначение:
Показать/скрыть колонки таблицы значений в визуальном представлении таблицы значений.

Если надо скрыть колонку в табличной части документа (в о бработке), выгрузи табличную часть в таблицу значений и ...
далее см. выше
 
L

Leon3

#4
табличную часть документа! А именно Многострочную часть документа поступление материалов

Табл = СоздатьОбъект("ТаблицаЗначений");
Док.ВыгрузитьТабличнуюЧасть(Табл);
Табл.ВидимостьКолонки("НП",0);

Док.ЗагрузитьТабличнуюЧасть(Табл);

Так Не получилось Сделать невидным!! Не подскажите Как Пожал?
 

puh14

Well-known member
11.07.2008
1 412
0
#5
Ты имеешь ввиду чтобы видимость была в форме документа или внешнеё обработке?
Если в форме документа тогда Форма.НП.Видимость(0)

Если в внешней обработке создаешь в обработке таблицу, обзываешь её Табл , при этом в модуле никакого СоздатьОбъект("ТаблицаЗначений") не надо, достаточно

Док.ВыгрузитьТабличнуюЧасть(Табл);
Табл.ВидимостьКолонки("НП",0);
 
L

Leon3

#6
Спасибо конечно, Но Нет, пух14 Ты понял не правильно ! Нужно из обработки по нажатию кнопки, Что бы в создавшемся документе поступление материалов Колонки Нп Небыло видно! Если создать документ вручную в предприятии документ проверяет и не выводит колонку НП! А вот из обработки как это же сделать - вот в чем вопрос!
 

puh14

Well-known member
11.07.2008
1 412
0
#7
Создать реквизит шапки числовой и записывать в него число из обработки, а дальше при открытии по условию этого числа делать видимой или невидимой колонку НП ф модуле формы.
 
L

Leon3

#8
Тогда же нужно нужно изменять документ, а этого делать нельзя
 

puh14

Well-known member
11.07.2008
1 412
0
#9
А в чем проблема? ну добавил реквизит шапки, ну и что?
 
K
#10
1. Посмотри модуль формы где-то в зависимости от какого-то рекивизита устанвливается видимость реквизита НП
2. При програмном создании документа надо этому реквизиту присвоить соответствующие значение , ВСЕ!
 
L

Leon3

#11
Пух14: Эта Обработка используется Для многих фирм,Баз, Везде менять реквизит шапки НИкак!


каа: 2 . При програмном создании документа надо этому реквизиту присвоить соответствующие значение , ВСЕ!

Я вот как раз это и Пытаюсь сделать, но не получается никак
 
K
#12
Я вот как раз это и Пытаюсь сделать, но не получается никак
Привожу аналогию торговля

Если УчитаватьНДС = 1 Тогда
Форма.СатвкаНДС.Видимость(1);
Форма.СуммаНДС.Видимость(1);
Иначе
Форма.СатвкаНДС.Видимость(0);
Форма.СуммаНДС.Видимость(0);
КонецЕсли;

Если создовать документ програмно
Док = СоздатьОбъект("Документ.Реализация");
Док.УчитыватьНДС = 1; // при открытии получаем Форма.СатвкаНДС.Видимость(1);

или

Док.УчитыватьНДС = 0; // при открытии получаем Форма.СатвкаНДС.Видимость(0);

надо в документе найти реквизит отвечающий за видимость нужного тебе реквизита
 

puh14

Well-known member
11.07.2008
1 412
0
#13
О Идея - у тебя из обработки Автор записывается? если нет тогда в модуле формы в процедуре ПриОткрытии()

Если ПустоеЗначение(Автор) = 1 Тогда
Форма.НП.Видимость(0);
КонецЕсли;

Проверь чтобы автор записывался в процедуре ВводНового - ТОгда в созданых вручную документах колонка НП будет видна.

Автор чаще всего живёт в общих реквизитах документов. Можешь условие повесить не на пустого автора, а на конкретного пользователя.

а если не работает ПустоеЗначение(Автор) = 1 попробуй

Если Автор = "" Тогда
Форма.НП.Видимость(0);
КонецЕсли;
 
L

Leon3

#14
надо в документе найти реквизит отвечающий за видимость нужного тебе реквизита
А нет такого теквизита вроде!
 

puh14

Well-known member
11.07.2008
1 412
0
#15
Ну нет такого реквизита - если не можешь создать - тогда пользуйся имеющимеся. Наверняка у тебя есть какой-то из общих реквизитов, который тебе из обработки не нужен, типа того-же автора. Завяжи условие видимости в форме на точное значение этого реквизита, при котором у тебя отключается видимость колонки. А из обработки записывай это точное значение!
 
K
#16
Ну нет такого реквизита - если не можешь создать - тогда пользуйся имеющимеся. Наверняка у тебя есть какой-то из общих реквизитов, который тебе из обработки не нужен, типа того-же автора. Завяжи условие видимости в форме на точное значение этого реквизита, при котором у тебя отключается видимость колонки. А из обработки записывай это точное значение!
Не надо ни чего править !
Выложи код МодульФормы