Помогите! Активизция поля в модуле формы

Тема в разделе "1C и всё что с ней связано", создана пользователем Liolik, 16 мар 2007.

Статус темы:
Закрыта.
  1. Liolik

    Liolik Гость

    При переходе в другое поле выполняется процедура, в конце процедуры пишу "Активизировать("Такое-то Поле")", в ответ получаю: "В данной формуле не может быть выполнена данная процедура-функция". Прошу подсказать, как перейти программным методом в нужное поле формы, при условии, что процедура находится в то же модуле формы...please...
     
  2. LSH

    LSH Гость

    Есть такое. Непонятно зачем сделанное ограничение. Процедуру Активизировать() можно вызывать только из предопределенных процедур.

    ВОт пример как можно обойти:
    Код (Text):
    Перем Закр;

    Процедура ПриЗакрытии()
    Если Закр=0 тогда
    Активизировать("Какой_То_Реквизит");
    СтатусВозврата(0);
    КонецЕсли;        
    Закр=1;
    КонецПроцедуры

    Процедура ПриИзмененииКакого_ТоРеквизита() //вешаем на реквизит
    Закр=0;
    Форма.Закрыть(0);
    КонецПроцедуры

    Закр=1;
     
  3. jj_mail

    jj_mail Гость

    а зачем Форма.Закрыть(0); ?
    Изменение реквизита не должно приводить к закрытию формы ведь...
     
  4. LSH

    LSH Гость

    <!--QuoteBegin-jj_mail+20:03:2007, 08:48 -->
    <span class="vbquote">(jj_mail @ 20:03:2007, 08:48 )</span><!--QuoteEBegin-->а зачем Форма.Закрыть(0); ?
    Изменение реквизита не должно приводить к закрытию формы ведь...
    [snapback]59544" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    Я же написал, что функция может вызываться только из предопределенных процедур.
    Заметь, что в функции ПриЗакрытии() стоит СтатусВозврата(0);
     
  5. jj_mail

    jj_mail Гость

    Да, сорь, не подумал, о том, что ПриЗакрытии() нужно как-то инициировать... :)
     
  6. Liolik

    Liolik Гость

    Благодарю за помощь.

    Тема раскрыта полностью...
     
Загрузка...
Похожие Темы - Помогите Активизция поля
  1. limbra
    Ответов:
    3
    Просмотров:
    46
  2. NylevoiChelovek
    Ответов:
    4
    Просмотров:
    102
  3. Ruska132
    Ответов:
    44
    Просмотров:
    339
  4. gURaBA_N
    Ответов:
    7
    Просмотров:
    148
  5. uxbmw3w
    Ответов:
    0
    Просмотров:
    65
Статус темы:
Закрыта.

Поделиться этой страницей