1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Помогите! Активизция поля в модуле формы

Тема в разделе "Базы данных и администрирование", создана пользователем Liolik, 16 мар 2007.

Статус темы:
Закрыта.
  1. Liolik

    Liolik Гость

    Репутация:
    0
    При переходе в другое поле выполняется процедура, в конце процедуры пишу "Активизировать("Такое-то Поле")", в ответ получаю: "В данной формуле не может быть выполнена данная процедура-функция". Прошу подсказать, как перейти программным методом в нужное поле формы, при условии, что процедура находится в то же модуле формы...please...
     
  2. LSH

    LSH Гость

    Репутация:
    0
    Есть такое. Непонятно зачем сделанное ограничение. Процедуру Активизировать() можно вызывать только из предопределенных процедур.

    ВОт пример как можно обойти:
    Код:
    Перем Закр;
    
    Процедура ПриЗакрытии()
    Если Закр=0 тогда
    Активизировать("Какой_То_Реквизит");
    СтатусВозврата(0);
    КонецЕсли;			
    Закр=1;
    КонецПроцедуры
    
    Процедура ПриИзмененииКакого_ТоРеквизита() //вешаем на реквизит
    Закр=0;
    Форма.Закрыть(0);
    КонецПроцедуры
    
    Закр=1;
     
  3. jj_mail

    jj_mail Гость

    Репутация:
    0
    а зачем Форма.Закрыть(0); ?
    Изменение реквизита не должно приводить к закрытию формы ведь...
     
  4. LSH

    LSH Гость

    Репутация:
    0
    <!--QuoteBegin-jj_mail+20:03:2007, 08:48 -->
    <span class="vbquote">(jj_mail @ 20:03:2007, 08:48 )</span><!--QuoteEBegin-->а зачем Форма.Закрыть(0); ?
    Изменение реквизита не должно приводить к закрытию формы ведь...
    [snapback]59544" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    Я же написал, что функция может вызываться только из предопределенных процедур.
    Заметь, что в функции ПриЗакрытии() стоит СтатусВозврата(0);
     
  5. jj_mail

    jj_mail Гость

    Репутация:
    0
    Да, сорь, не подумал, о том, что ПриЗакрытии() нужно как-то инициировать... :)
     
  6. Liolik

    Liolik Гость

    Репутация:
    0
    Благодарю за помощь.

    Тема раскрыта полностью...
     
Загрузка...
Похожие Темы - Помогите Активизция поля
  1. Tayrus
    Ответов:
    2
    Просмотров:
    35
  2. KanycTa
    Ответов:
    1
    Просмотров:
    50
  3. Samyrro
    Ответов:
    1
    Просмотров:
    56
  4. Tayrus
    Ответов:
    0
    Просмотров:
    50
  5. bronnn
    Ответов:
    0
    Просмотров:
    110
Статус темы:
Закрыта.

Поделиться этой страницей