Помогите! Активизция поля в модуле формы

  • Автор темы Liolik
  • Дата начала
Статус
Закрыто для дальнейших ответов.
L

Liolik

Гость
#1
При переходе в другое поле выполняется процедура, в конце процедуры пишу "Активизировать("Такое-то Поле")", в ответ получаю: "В данной формуле не может быть выполнена данная процедура-функция". Прошу подсказать, как перейти программным методом в нужное поле формы, при условии, что процедура находится в то же модуле формы...please...
 
L

LSH

Гость
#2
Есть такое. Непонятно зачем сделанное ограничение. Процедуру Активизировать() можно вызывать только из предопределенных процедур.

ВОт пример как можно обойти:
Код:
Перем Закр;

Процедура ПриЗакрытии()
Если Закр=0 тогда
Активизировать("Какой_То_Реквизит");
СтатусВозврата(0);
КонецЕсли;			
Закр=1;
КонецПроцедуры

Процедура ПриИзмененииКакого_ТоРеквизита() //вешаем на реквизит
Закр=0;
Форма.Закрыть(0);
КонецПроцедуры

Закр=1;
 
J

jj_mail

Гость
#3
а зачем Форма.Закрыть(0); ?
Изменение реквизита не должно приводить к закрытию формы ведь...
 
L

LSH

Гость
#4
<!--QuoteBegin-jj_mail+20:03:2007, 08:48 -->
<span class="vbquote">(jj_mail @ 20:03:2007, 08:48 )</span><!--QuoteEBegin-->а зачем Форма.Закрыть(0); ?
Изменение реквизита не должно приводить к закрытию формы ведь...
[snapback]59544" rel="nofollow" target="_blank[/snapback]​
[/quote]

Я же написал, что функция может вызываться только из предопределенных процедур.
Заметь, что в функции ПриЗакрытии() стоит СтатусВозврата(0);
 
J

jj_mail

Гость
#5
Да, сорь, не подумал, о том, что ПриЗакрытии() нужно как-то инициировать... :)
 
L

Liolik

Гость
#6
Благодарю за помощь.

Тема раскрыта полностью...
 
Статус
Закрыто для дальнейших ответов.