ПОМОГИТЕ! Использование Справочников в ТиС

Тема в разделе "1C и всё что с ней связано", создана пользователем Texnik, 27 окт 2007.

Наш партнер Genesis Hackspace
Статус темы:
Закрыта.
  1. Texnik

    Texnik Гость

    Есть код в 1с бух. Там он работает. Надо его переписать под Торговлю и Склад. Уже 2 дня мучаю.Буду рад любому совету! Заранее благодарен.

    НазначитьВид(Док.Материал, "Материалы");
    Док.Материал = СпрМат.ТекущийЭлемент();
    Если Док.Материал.ЕдиницаИзмерения.Код = "006" Тогда
    Док.КоличествоЗатребовано = Тз1.Длина/1000;
    Док.КоличествоОтпущено = Тз1.Длина/1000;
    Иначе Док.Материал.ЕдиницаИзмерения.Код = "055" Тогда
    Док.КоличествоЗатребовано = Тз1.Длина/1000000;
    Док.КоличествоОтпущено = Тз1.Длина/1000000;
    КонецЕсли;
     
  2. kaa

    kaa Гость

    Справочника материалы в ТиС нет - Номенклатура принадлежность определяется Перечислением ВидыНоменклатуры (но вида материалы там нет :))
    ЕдиницаИзмерения в ТиС основных для номенклатры две Базовая в ней хранятся остатки и формируются движения и основная наиболее часто используемая поэтому будет что-то типа:

    Док.Номенклатура = Спр.ТекущийЭлемент();
    Если Док.Номенклатура.ВидНоменклатуры = Перечисление.ВидыНоиенклатуры.ХХХ Тогда
    Если Док.Номенклатура.YYYЕдиницаИзмерения.Код= "006" Тогда
    КонецЕсли;
    //ну и так далее
    КонецЕсли;
     
Загрузка...
Похожие Темы - ПОМОГИТЕ Использование Справочников
  1. Makc
    Ответов:
    4
    Просмотров:
    104
  2. Sniff
    Ответов:
    1
    Просмотров:
    96
  3. 777
    Ответов:
    2
    Просмотров:
    91
  4. (((_CYBORG_)))
    Ответов:
    9
    Просмотров:
    246
  5. Heavy10110
    Ответов:
    10
    Просмотров:
    293
Статус темы:
Закрыта.

Поделиться этой страницей