1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

ПОМОГИТЕ! Использование Справочников в ТиС

Тема в разделе "Базы данных и администрирование", создана пользователем Texnik, 27 окт 2007.

Статус темы:
Закрыта.
  1. Texnik

    Texnik Гость

    Репутация:
    0
    Есть код в 1с бух. Там он работает. Надо его переписать под Торговлю и Склад. Уже 2 дня мучаю.Буду рад любому совету! Заранее благодарен.

    НазначитьВид(Док.Материал, "Материалы");
    Док.Материал = СпрМат.ТекущийЭлемент();
    Если Док.Материал.ЕдиницаИзмерения.Код = "006" Тогда
    Док.КоличествоЗатребовано = Тз1.Длина/1000;
    Док.КоличествоОтпущено = Тз1.Длина/1000;
    Иначе Док.Материал.ЕдиницаИзмерения.Код = "055" Тогда
    Док.КоличествоЗатребовано = Тз1.Длина/1000000;
    Док.КоличествоОтпущено = Тз1.Длина/1000000;
    КонецЕсли;
     
  2. kaa

    kaa Гость

    Репутация:
    0
    Справочника материалы в ТиС нет - Номенклатура принадлежность определяется Перечислением ВидыНоменклатуры (но вида материалы там нет :))
    ЕдиницаИзмерения в ТиС основных для номенклатры две Базовая в ней хранятся остатки и формируются движения и основная наиболее часто используемая поэтому будет что-то типа:

    Док.Номенклатура = Спр.ТекущийЭлемент();
    Если Док.Номенклатура.ВидНоменклатуры = Перечисление.ВидыНоиенклатуры.ХХХ Тогда
    Если Док.Номенклатура.YYYЕдиницаИзмерения.Код= "006" Тогда
    КонецЕсли;
    //ну и так далее
    КонецЕсли;
     
Загрузка...
Похожие Темы - ПОМОГИТЕ Использование Справочников
  1. Tayrus
    Ответов:
    2
    Просмотров:
    46
  2. KanycTa
    Ответов:
    1
    Просмотров:
    51
  3. Samyrro
    Ответов:
    1
    Просмотров:
    61
  4. Tayrus
    Ответов:
    0
    Просмотров:
    51
  5. bronnn
    Ответов:
    0
    Просмотров:
    112
Статус темы:
Закрыта.

Поделиться этой страницей