Помогите написать процедуру!

  • Автор темы Guest
  • Дата начала
G

Guest

#1
Помогите написать процедуру! Написать отчет, в котором будут выводится остатки по всем балансовым счетам (из плана счетов), у которых есть ненулевое сальдо на заданную дату (задается в форме).То,что писанно ниже не подходит(((
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
блин, да в чем сложности? используешь объект бухгалтерские итоги. собираешь счита и ставишь двойное условие - если балансовые сличта и СКД <>0 и СКК <>0. и все - дальше выводи как тебе удобно
 
G

Guest

#3
блин, да в чем сложности? используешь объект бухгалтерские итоги. собираешь счита и ставишь двойное условие - если балансовые сличта и СКД <>0 и СКК <>0. и все - дальше выводи как тебе удобно
Процедура Сформировать()
Таб = СоздатьОбъект("Таблица");//будем все выводить в таблицу
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.Опции (0,1);
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,,,, 1,, "С"); //выполняем запрос
Таб.ВывестиСекцию("Шапка"); //выводим заголовок таблицы
Таб.Опции(1,0,Таб.ВысотаТаблицы(),0);
Ит.ВыбратьСчета(); //открываем выборку по счетам
Пока Ит.ПолучитьСчет() = 1 Цикл
сч=Ит.Счет;//получили номер счета
//получаем итоги по каждому счету
СНД=Ит.СНД();
СНК=Ит.СНК();
СКД=Ит.СКД();
СКК=Ит.СКК();
До=Ит.ДО();
КО=Ит.КО();
Ит.СКД();//конечное сальдо дебитовое
Ит.СКК();//конечное сальдо кредитовое
Если СКД <>0 и СКК <>0 тогда
Таб.ВывестиСекцию("Счет");//выводим итоги в таблицу
КонецЦикла;


Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать","");
КонецПроцедуры

Прпавильно?Поправьте если не правильно!!Спасибо,что откликнулись и помогаете.
 

vbs

Well-known member
18.02.2007
1 708
1
#4
Прпавильно?Поправьте если не правильно!!Спасибо,что откликнулись и помогаете
Работает ? Таблица заполняется ?

Ошибок навскидку не видно,
разве что
вместо Если СКД <>0 и СКК <>0 тогда
вроде бы надо
Если (СКД <>0) ИЛИ (СКК <>0) тогда
Да и условие не закрыто
КонецЕсли,

Ну и в комментарии одна ошибка есть

дебитовое
надо заменить на
дебЕтовое
:)

А весь огород-то зачем ? Сформировал бы себе на основе ОСВ свою таблицу...
 
G

Guest

#5
Работает ? Таблица заполняется ?

Ошибок навскидку не видно,
разве что
вместо Если СКД <>0 и СКК <>0 тогда
вроде бы надо
Если (СКД <>0) ИЛИ (СКК <>0) тогда
Да и условие не закрыто
КонецЕсли,

Ну и в комментарии одна ошибка есть

дебитовое
надо заменить на
дебЕтовое
:)

А весь огород-то зачем ? Сформировал бы себе на основе ОСВ свою таблицу...
спс за критику!!1Но не могли бы Вы подсказать,а вернее помочь написать эту процедуру?!
За ранее благодарен от души))))
 

vbs

Well-known member
18.02.2007
1 708
1
#6
Берешь обычную ОСВ и снимаешь признак "Данные по забалансовым счетам"
Вот оно и счастье :)
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#10
вместо Если СКД <>0 и СКК <>0 тогда
вроде бы надо
Если (СКД <>0) ИЛИ (СКК <>0) тогда
Да и условие не закрыто
КонецЕсли,
Павлов, вот этот вариант опробован? если да - что не устраивает? если нет - бегом пробовать!