1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Помогите написать процедуру!

Тема в разделе "Базы данных и администрирование", создана пользователем -, 19 фев 2010.

  1. Гость

    Репутация:
    0
    Помогите написать процедуру! Написать отчет, в котором будут выводится остатки по всем балансовым счетам (из плана счетов), у которых есть ненулевое сальдо на заданную дату (задается в форме).То,что писанно ниже не подходит(((
     
  2. KiR

    KiR НЕ шибка опытный програмер)

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    блин, да в чем сложности? используешь объект бухгалтерские итоги. собираешь счита и ставишь двойное условие - если балансовые сличта и СКД <>0 и СКК <>0. и все - дальше выводи как тебе удобно
     
  3. Гость

    Репутация:
    0
    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");//будем все выводить в таблицу
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.Опции (0,1);
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,,,, 1,, "С"); //выполняем запрос
    Таб.ВывестиСекцию("Шапка"); //выводим заголовок таблицы
    Таб.Опции(1,0,Таб.ВысотаТаблицы(),0);
    Ит.ВыбратьСчета(); //открываем выборку по счетам
    Пока Ит.ПолучитьСчет() = 1 Цикл
    сч=Ит.Счет;//получили номер счета
    //получаем итоги по каждому счету
    СНД=Ит.СНД();
    СНК=Ит.СНК();
    СКД=Ит.СКД();
    СКК=Ит.СКК();
    До=Ит.ДО();
    КО=Ит.КО();
    Ит.СКД();//конечное сальдо дебитовое
    Ит.СКК();//конечное сальдо кредитовое
    Если СКД <>0 и СКК <>0 тогда
    Таб.ВывестиСекцию("Счет");//выводим итоги в таблицу
    КонецЦикла;


    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
    КонецПроцедуры

    Прпавильно?Поправьте если не правильно!!Спасибо,что откликнулись и помогаете.
     
  4. vbs

    vbs Well-Known Member

    Репутация:
    0
    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Работает ? Таблица заполняется ?

    Ошибок навскидку не видно,
    разве что
    вместо Если СКД <>0 и СКК <>0 тогда
    вроде бы надо
    Если (СКД <>0) ИЛИ (СКК <>0) тогда
    Да и условие не закрыто
    КонецЕсли,

    Ну и в комментарии одна ошибка есть

    дебитовое
    надо заменить на
    дебЕтовое
    :)

    А весь огород-то зачем ? Сформировал бы себе на основе ОСВ свою таблицу...
     
  5. Гость

    Репутация:
    0
    спс за критику!!1Но не могли бы Вы подсказать,а вернее помочь написать эту процедуру?!
    За ранее благодарен от души))))
     
  6. vbs

    vbs Well-Known Member

    Репутация:
    0
    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Берешь обычную ОСВ и снимаешь признак "Данные по забалансовым счетам"
    Вот оно и счастье :)
     
  7. Гость

    Репутация:
    0
    Это при создании нового отчета?верно снимем признак ивсе?!
     
  8. physik_gumanitar

    physik_gumanitar Гость

    Репутация:
    0
    Чем ковырять такой универсальный отчет, типа ОСВ, проще писать свою отсебячину.
     
  9. vbs

    vbs Well-Known Member

    Репутация:
    0
    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    А его и ковырять не надо - по всем признакам она ему просто годится, разве что таблицу чуть поправить
     
  10. KiR

    KiR НЕ шибка опытный програмер)

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Павлов, вот этот вариант опробован? если да - что не устраивает? если нет - бегом пробовать!
     
Загрузка...

Поделиться этой страницей