Помогите новичку!

Тема в разделе "1C и всё что с ней связано", создана пользователем SashaR, 17 апр 2007.

Наш партнер Genesis Hackspace
Статус темы:
Закрыта.
  1. SashaR

    SashaR Гость

    Надо создать обработку, выводящую в визуальную таблицу значений структуру папок и файлов диска C с колонками:
    должно отображаться наименование папок и файлов, размер файлов, дата последней модификации...

    Ну саму таблицу сделал ничего сложного в этом нет...
    А как сделать чтоб папки и файлы диска С появлялись, что не как не могу догодаться...

    Подскажите как это сделать...
    заранее благодарю за помощь!!!

    есть вот это, но не работает... что и как поменять что заработало, если можно поподробнее...

    Функция ПрочитатьКаталог(ИмяКаталога)
    Перем ТекКат;
    ФС.УстТекКаталог(ИмяКаталога);
    ФС.НайтиПервыйФайл();
    флВозврат=0;
    Пока ФлВозврат=0 Цикл
    ТекИмяФайла = ФС.НайтиСледующийФайл();
    ТекКат = фС.ТекКаталог();
    ФС.АтрибутыФайла(ТекИмяФайла,<РазмерФайла>,<АтрибутыФайла>,<ВремяСоздания>,
    <ВремяПоследнегоДоступа>,<ВремяПоследнейЗаписи>,<РасширенноеИмяФайла>)
    Если Каталог=1 Тогда
    ТЗ.НоваяСтрока()
    ТЗ.ИмяФайла = ТекИмяФайла;
    ПрочитатьКаталог(ТекИмяФайла);
    Иначе
    ТЗ.НоваяСтрока()
    ТЗ.ИмяФайла = ТекИмяФайла;
    КонецЕсли;
    КонецЦикла;
    КонецФункции
     
  2. LSH

    LSH Гость

    Для: SashaR

    Гуглите обработку "Сусанин". Как раз ваш случай.
     
  3. SashaR

    SashaR Гость

    Для: LSH благодарю, сейчас посмотрю...


    а можно ссылку...
     
  4. SashaR

    SashaR Гость

    благодарю...

    не работает...
     
  5. LSH

    LSH Гость

    Для: SashaR

    ЧТо не работает? Ссылка живая, перед постом сам проверил (открывать левой кнопкой). Обработка которая лежит по ней тоже работает.
     
  6. SashaR

    SashaR Гость

    все благодарю... вчера с инетом что - то было...
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей