Помогите новичку!

  • Автор темы SashaR
  • Дата начала
Статус
Закрыто для дальнейших ответов.
S

SashaR

#1
Надо создать обработку, выводящую в визуальную таблицу значений структуру папок и файлов диска C с колонками:
должно отображаться наименование папок и файлов, размер файлов, дата последней модификации...

Ну саму таблицу сделал ничего сложного в этом нет...
А как сделать чтоб папки и файлы диска С появлялись, что не как не могу догодаться...

Подскажите как это сделать...
заранее благодарю за помощь!!!

есть вот это, но не работает... что и как поменять что заработало, если можно поподробнее...

Функция ПрочитатьКаталог(ИмяКаталога)
Перем ТекКат;
ФС.УстТекКаталог(ИмяКаталога);
ФС.НайтиПервыйФайл();
флВозврат=0;
Пока ФлВозврат=0 Цикл
ТекИмяФайла = ФС.НайтиСледующийФайл();
ТекКат = фС.ТекКаталог();
ФС.АтрибутыФайла(ТекИмяФайла,<РазмерФайла>,<АтрибутыФайла>,<ВремяСоздания>,
<ВремяПоследнегоДоступа>,<ВремяПоследнейЗаписи>,<РасширенноеИмяФайла>)
Если Каталог=1 Тогда
ТЗ.НоваяСтрока()
ТЗ.ИмяФайла = ТекИмяФайла;
ПрочитатьКаталог(ТекИмяФайла);
Иначе
ТЗ.НоваяСтрока()
ТЗ.ИмяФайла = ТекИмяФайла;
КонецЕсли;
КонецЦикла;
КонецФункции
 
L
#2
Для: SashaR

Гуглите обработку "Сусанин". Как раз ваш случай.
 
S

SashaR

#3
Для: LSH благодарю, сейчас посмотрю...


а можно ссылку...
 
L
#6
Для: SashaR

ЧТо не работает? Ссылка живая, перед постом сам проверил (открывать левой кнопкой). Обработка которая лежит по ней тоже работает.
 
S

SashaR

#7
все благодарю... вчера с инетом что - то было...
 
Статус
Закрыто для дальнейших ответов.