помогите новичку

  • Автор темы Mikki556
  • Дата начала
Статус
Закрыто для дальнейших ответов.
M

Mikki556

Гость
#1
1с Производство 7.7

Надо сделать заполнение документа методом подбора, написал следующий код.
// ********************
//
Процедура ОбработкаПроведения()

//Здесь следует написать алгоритм проведения документа

КонецПроцедуры


Процедура Подбор()

ОткрытьПодбор("Номенклатура","ФормаСписка");

КонецПроцедуры

Процедура ОбработкаПодбора(Выб)

ЗапросКоличестваВПодборе(Выб);
УстанЦеныПрих();
Выч_суммы_накл();
АктивизироватьСтроку();

КонецПроцедуры



Процедура ЗапросКоличестваВПодборе(Выб)

Если Выб.ПометкаУдаления()=1 Тогда

Предупреждение("Нельзя выбирать помеченные на удаление товары!");
Возврат;

КонецЕсли;

Кол=1;
Если ВвестиЧисло(Кол, "Введите количество",10,2)=1 Тогда
НоваяСтрока();
Товар=Выб;
Количество=Кол;

КонецЕсли;


КонецПроцедуры

Процедура УстанЦеныПрих()

Цена=Товары.Себестоимость.Получить(ДатаДок);
СтавкаНДС=Товары.СтавкаНДС.Получить(ДатаДок);
КонецПроцедуры

Процедура Выч_суммы_накл()
Сумма=Цена*Количество;
НДС=Сумма/(СтавкаНДС+100)*СтавкаНДС;
КонецПроцедуры


Потом в форме доку мента поставил кнопку Подбор с сылкой на процедуру Подбор(). Но при нажатии кнопки или например попытки пометить накладную на удаление, пишет


ОткрытьПодбор<<?>>("Номенклатура","ФормаСписка");
{Документ.ПрихНакл.Модуль Документа(5)}: Процедура не обнаружена (ОткрытьПодбор)
ЗапросКоличестваВПодборе<<?>>(Выб);
{Документ.ПрихНакл.Модуль Документа(11)}: Процедура не обнаружена (ЗапросКоличестваВПодборе)
УстанЦеныПрих<<?>>();
{Документ.ПрихНакл.Модуль Документа(12)}: Процедура не обнаружена (УстанЦеныПрих)
Выч_суммы_накл<<?>>();
{Документ.ПрихНакл.Модуль Документа(13)}: Процедура не обнаружена (Выч_суммы_накл)
АктивизироватьСтроку<<?>>();
{Документ.ПрихНакл.Модуль Документа(14)}: Процедура не обнаружена (АктивизироватьСтроку)

что я не прально написал?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
Процедура Подбор()

ОткрытьПодбор("Номенклатура","ФормаСписка");

КонецПроцедуры
Тут ты вызываешь процедуру ОткрытьПодбор в которую передаешь 2 парамера. Существования такой процедуры в твоем коде я что-то не обнаружил. То же самое кассается и АктивизироватьСтроку. Если это предопределенные функции - почитай к ним описание
 
M

Mikki556

Гость
#3
уже разобрался надо было писать вот так

Код:
Процедура Подбор()

ОткрытьПодбор("Справочник.Номенклатура","ФормаСписка");

КонецПроцедуры  


Процедура ЗапросКоличестваВПодборе(Выб)

Если Выб.ПометкаУдаления()=1 Тогда

Предупреждение("Нельзя выбирать помеченные на удаление товары!");
Возврат;

КонецЕсли;

Кол=1;
Если ВвестиЧисло(Кол, "Введите количество",10,2)=1 Тогда
НоваяСтрока();
Товар=Выб;
Количество=Кол;

КонецЕсли; 

КонецПроцедуры  

Процедура УстанЦеныПрих()

Цена=Товары.Себестоимость.Получить(ДатаДок);
СтавкаНДС=Товары.СтавкаНДС.Получить(ДатаДок);
КонецПроцедуры 

Процедура Выч_суммы_накл()
Сумма=Цена*Количество;
НДС=Сумма/(СтавкаНДС+100)*СтавкаНДС;
КонецПроцедуры

Процедура ОбработкаПодбора(Выб)

ЗапросКоличестваВПодборе(Выб);
УстанЦеныПрих();
Выч_суммы_накл();
АктивизироватьСтроку();

КонецПроцедуры
 
K

Kiri4

Гость
#4
Вследствии почти нулевых знаний программирования 1С, не могу понять вот это... обьясните если можете:
При выводе на печать посредствам внешней печатной формы выдает ошибку
_______________________________________________________________________
err Общество <<?>>с ограниченной ответственностью
Переменная не определена (с)
_______________________________________________________________________
 
H

Hryv

Гость
#5
Видимо где-то в печатной форме есть текст "Общество с ограниченной ответственностью" и при этом тип ячейки: Выражение
Видимо надо поменять ее тип на Текст
 
Статус
Закрыто для дальнейших ответов.