помогите новичку

Тема в разделе "1C и всё что с ней связано", создана пользователем Mikki556, 15 янв 2009.

Статус темы:
Закрыта.
  1. Mikki556

    Mikki556 Гость

    1с Производство 7.7

    Надо сделать заполнение документа методом подбора, написал следующий код.
    // ********************
    //
    Процедура ОбработкаПроведения()

    //Здесь следует написать алгоритм проведения документа

    КонецПроцедуры


    Процедура Подбор()

    ОткрытьПодбор("Номенклатура","ФормаСписка");

    КонецПроцедуры

    Процедура ОбработкаПодбора(Выб)

    ЗапросКоличестваВПодборе(Выб);
    УстанЦеныПрих();
    Выч_суммы_накл();
    АктивизироватьСтроку();

    КонецПроцедуры



    Процедура ЗапросКоличестваВПодборе(Выб)

    Если Выб.ПометкаУдаления()=1 Тогда

    Предупреждение("Нельзя выбирать помеченные на удаление товары!");
    Возврат;

    КонецЕсли;

    Кол=1;
    Если ВвестиЧисло(Кол, "Введите количество",10,2)=1 Тогда
    НоваяСтрока();
    Товар=Выб;
    Количество=Кол;

    КонецЕсли;


    КонецПроцедуры

    Процедура УстанЦеныПрих()

    Цена=Товары.Себестоимость.Получить(ДатаДок);
    СтавкаНДС=Товары.СтавкаНДС.Получить(ДатаДок);
    КонецПроцедуры

    Процедура Выч_суммы_накл()
    Сумма=Цена*Количество;
    НДС=Сумма/(СтавкаНДС+100)*СтавкаНДС;
    КонецПроцедуры


    Потом в форме доку мента поставил кнопку Подбор с сылкой на процедуру Подбор(). Но при нажатии кнопки или например попытки пометить накладную на удаление, пишет


    ОткрытьПодбор<<?>>("Номенклатура","ФормаСписка");
    {Документ.ПрихНакл.Модуль Документа(5)}: Процедура не обнаружена (ОткрытьПодбор)
    ЗапросКоличестваВПодборе<<?>>(Выб);
    {Документ.ПрихНакл.Модуль Документа(11)}: Процедура не обнаружена (ЗапросКоличестваВПодборе)
    УстанЦеныПрих<<?>>();
    {Документ.ПрихНакл.Модуль Документа(12)}: Процедура не обнаружена (УстанЦеныПрих)
    Выч_суммы_накл<<?>>();
    {Документ.ПрихНакл.Модуль Документа(13)}: Процедура не обнаружена (Выч_суммы_накл)
    АктивизироватьСтроку<<?>>();
    {Документ.ПрихНакл.Модуль Документа(14)}: Процедура не обнаружена (АктивизироватьСтроку)

    что я не прально написал?
     
  2. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Тут ты вызываешь процедуру ОткрытьПодбор в которую передаешь 2 парамера. Существования такой процедуры в твоем коде я что-то не обнаружил. То же самое кассается и АктивизироватьСтроку. Если это предопределенные функции - почитай к ним описание
     
  3. Mikki556

    Mikki556 Гость

    уже разобрался надо было писать вот так

    Код (Text):
    Процедура Подбор()

    ОткрытьПодбор("Справочник.Номенклатура","ФормаСписка");

    КонецПроцедуры  


    Процедура ЗапросКоличестваВПодборе(Выб)

    Если Выб.ПометкаУдаления()=1 Тогда

    Предупреждение("Нельзя выбирать помеченные на удаление товары!");
    Возврат;

    КонецЕсли;

    Кол=1;
    Если ВвестиЧисло(Кол, "Введите количество",10,2)=1 Тогда
    НоваяСтрока();
    Товар=Выб;
    Количество=Кол;

    КонецЕсли;

    КонецПроцедуры  

    Процедура УстанЦеныПрих()

    Цена=Товары.Себестоимость.Получить(ДатаДок);
    СтавкаНДС=Товары.СтавкаНДС.Получить(ДатаДок);
    КонецПроцедуры

    Процедура Выч_суммы_накл()
    Сумма=Цена*Количество;
    НДС=Сумма/(СтавкаНДС+100)*СтавкаНДС;
    КонецПроцедуры

    Процедура ОбработкаПодбора(Выб)

    ЗапросКоличестваВПодборе(Выб);
    УстанЦеныПрих();
    Выч_суммы_накл();
    АктивизироватьСтроку();

    КонецПроцедуры
     
  4. Kiri4

    Kiri4 Гость

    Вследствии почти нулевых знаний программирования 1С, не могу понять вот это... обьясните если можете:
    При выводе на печать посредствам внешней печатной формы выдает ошибку
    _______________________________________________________________________
    err Общество <<?>>с ограниченной ответственностью
    Переменная не определена (с)
    _______________________________________________________________________
     
  5. Hryv

    Hryv Гость

    Видимо где-то в печатной форме есть текст "Общество с ограниченной ответственностью" и при этом тип ячейки: Выражение
    Видимо надо поменять ее тип на Текст
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей