Помогите новичку!

Тема в разделе "1C и всё что с ней связано", создана пользователем iliych747, 29 сен 2009.

  1. iliych747

    iliych747 Гость

    1С 7.7 Конфигурация "Бухгалтерский учет, редакция 4.5" 7.70.504
    В документе "Отгрузка товаров, продукции" в пункте "Налоги" можно выбрать только 2 пункта из 4-х: "Без налогов" и "НДС сверху".
    Как сделать, чтобы выбирались все пункты справочника "Варианты расчета налогов"? Как например в документе "Поступление ОС"...
     
  2. iliych747

    iliych747 Гость

    Выкладываю текст процедуры "ПриВыбореВариантаРасчетаНалогов()" из модуля формы документа, которая вызывается при раскрытии списка "Вариант расчета налогов". Идентификатор этого поля "ВариантРасчетаНалогов".

    // ПриВыбореВариантаРасчетаНалогов()
    //
    // Вызывается из формул элементов диалога:
    // Поле ввода "ВариантРасчетаНалогов".
    //
    // Описание:
    // Пересчитывает суммы в документе при смене варианта расчета налогов.
    //
    Процедура ПриВыбореВариантаРасчетаНалогов()

    Если ВариантРасчетаНалогов = ТекущийВариантРасчетаНалогов Тогда
    Возврат
    КонецЕсли;

    Если КоличествоСтрок() > 0 Тогда
    Ответ = Вопрос("Пересчитать суммы налогов в существующих строках
    |табличной части (суммы налогов будут
    |обновлены в соответствии с выбранным вариантом)?", "Да+Нет+Отмена");
    Если Ответ = "Да" Тогда

    ОбщееКоличество = КоличествоСтрок();
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    РассчитатьНалоги();
    Состояние("Обработано: " + Окр(НомерСтроки/ОбщееКоличество*100, 0, 1) + "%");
    КонецЦикла;

    ИначеЕсли Ответ = "Отмена" Тогда
    ВариантРасчетаНалогов = ТекущийВариантРасчетаНалогов;
    КонецЕсли;

    КонецЕсли;
    УчитыватьНП = глПризнакУчетаНалога(Контекст, "НП");
    УчитыватьНДС = глПризнакУчетаНалога(Контекст, "НДС");
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    НДС = ?(УчитыватьНДС = 0, 0, НДС);
    НП = ?(УчитыватьНП = 0, 0, НП);
    КонецЦикла;
    Форма.НДС.Видимость(УчитыватьНДС);
    Форма.НП.Видимость(УчитыватьНП);

    КонецПроцедуры // ПриВыбореВариантаРасчетаНалогов()

    Также в модуле формы есть процедура "ВариантРасчетаНалогов()", название которой совпадает с идентификатором.

    Выкладываю текст этой процедуры:

    // ВариантРасчетаНалогов()
    //
    // Вызывается из формул элементов диалога:
    // Нет.
    //
    // Описание:
    // Подбирает вариант расчета налогов.
    //
    Процедура ВариантРасчетаНалогов(ВРН)
    Если (ВРН.СтавкаНП.Ставка = 0) и
    (ВРН.СтавкаНДС.Ставка = 0) Тогда
    ВариантРасчетаНалогов = ВРН;

    Иначе // попробуем найти подходящий из существующих вариантов расчета налогов

    СпрВариант = СоздатьОбъект("Справочник.ВариантыРасчетаНалогов");
    СпрВариант.ВыбратьЭлементы();
    Пока СпрВариант.ПолучитьЭлемент() = 1 Цикл

    Если ((ВРН.СтавкаНДС.Ставка = 0)
    и (СпрВариант.СтавкаНДС = ВРН.СтавкаНДС)
    и (СпрВариант.СуммаВключаетНДС = ВРН.СуммаВключаетНДС))

    или ((ВРН.СтавкаНДС.Ставка <> 0)
    и (СпрВариант.СтавкаНДС.Выбран() = 0)
    и (СпрВариант.СуммаВключаетНДС = ВРН.СуммаВключаетНДС)) Тогда

    Если ((ВРН.СтавкаНП.Ставка = 0)
    и (СпрВариант.СтавкаНП = ВРН.СтавкаНП)
    и (СпрВариант.СуммаВключаетНП = ВРН.СуммаВключаетНП))

    или ((ВРН.СтавкаНП.Ставка <> 0)
    и (СпрВариант.СтавкаНП.Выбран() = 0)
    и (СпрВариант.СуммаВключаетНП = ВРН.СуммаВключаетНП)) Тогда

    ВариантРасчетаНалогов = СпрВариант.ТекущийЭлемент();
    Прервать;
    КонецЕсли;
    КонецЕсли;

    КонецЦикла;

    КонецЕсли;
    // Форма.НДС.Видимость(УчитыватьНДС);
    // Форма.НП.Видимость(УчитыватьНП);
    КонецПроцедуры // ВариантРасчетаНалогов()

    Други!!!!!!!!!!!!!
    ПОДСКАЖИТЕ ГДЕ КОПАТЬ!!!
     
  3. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    В расходной накладной допускается выбор только тех вариантов налогов, где ставка = 0,
    Т.е, если в справочнике "ВариантыРасчетаНалогов" явно указана ставка, то данный элемент не попадает в список
    допустимых вариантов для выбора.
    Возможный подход - в справочнике "ВариантыРасчетаНалогов" поставить переключатель в вид "Использовать ставку из справочника"
     
  4. iliych747

    iliych747 Гость

    Для какого налога переключатель поменять?
    У меня переключатель стоит на пункте "Использовать ставку из справочника" только для "НДС сверху"...
    Остальные : "Без налогов", "НДС в сумме 18%" и "НДС Сверху 18%" - переключатель стоит в "Использовать ставку...."

    Понял!!!!
    Теперь пункт появляется :) ...
    Сейчас буду смотреть как считать будет....

    ;) Работает..Но налоги не пересчитывает... :(
     
  5. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Это - вряд ли :)
     
Загрузка...
Похожие Темы - Помогите новичку
  1. rn3rjd
    Ответов:
    9
    Просмотров:
    1.230
  2. maxiik
    Ответов:
    3
    Просмотров:
    1.572
  3. zaza41rus
    Ответов:
    0
    Просмотров:
    1.054
  4. Radion2
    Ответов:
    0
    Просмотров:
    1.669
  5. forem0st
    Ответов:
    6
    Просмотров:
    3.540

Поделиться этой страницей