Помогите передать контекст формы

Тема в разделе "1C и всё что с ней связано", создана пользователем shane13, 24 сен 2008.

  1. shane13

    shane13 Гость

    Дело обстоит так: Есть справочник Объекты, в котором при нажатии на кнопку "Новый контакт", открывается форма списка справочника "Контакты". При этом из спр.Объекты передается контекст в Контакты так:

    ПараметрПодбора = СоздатьОбъект("СписокЗначений");
    ПараметрПодбора.ДобавитьЗначение(ТекущийЭлемент(), "Объект");
    ПараметрПодбора.ДобавитьЗначение(Область, "Область");

    В справочнике контакты я принимаю контекст так:

    Процедура ПриОткрытии()
    Параметры = Форма.Параметр;
    Если ТипЗначенияСтр(Параметры) = "СписокЗначений" Тогда
    Объект = Параметры.Получить("Объект");
    Область = Параметры.Получить("Область");
    КонецЕсли;
    КонецПроцедуры

    Всё нормально принимается. И я записываю принятые значения куда мне надо. Вопрос в следующем:
    Если я хочу создать новый элемент в справочнике Контакты (редактируется только в диалоге), то как мне получить этот же контекст в форме элемента???

    Фишка в том, что новый элемент создается так:
    Процедура ВводНового(Ск)
    глПриВводеНового(Контекст, Ск);
    КонецПроцедуры,
    т.е. фактического открытия формы нет... Как же мне передать туда параметры??? ПОМОГИТЕ!!!!
     
  2. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    переменную в начале модуля формы и она у тебя будет видна во всех процедурах формы. Типа

    перем параметр;

    Процедура ПриОТкрытии()
    параметр = Форма.Параметр;
    КонецПроцедуры

    процедура ВВодНового()
    Если ПустоеЗначение(параметр) = 0 Тогда
    КонецЕсли;
    КонецПроцедуры
     
  3. shane13

    shane13 Гость

    Это понятно, так и сделано. Только формы то разные. Мне нужно в Форме Элемента получить параметры, переданные в Форму Списка...
     
  4. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Тогда через переменную в глобальном модуле с очищением при закрытии форм.
     
  5. shane13

    shane13 Гость

    Не получается тоже... Я делаю так:
    В ФормеСписка ПриОткрытии()
    Параметры = Форма.Параметр;
    МойКонтекст = Параметры; (МойКонтекст - глобальная переменная)

    Далее в ФормеЭлемента при открытии присваиваю значение МойКонтекст нужной мне переменной...
    Что-то не так??
     
  6. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    ну не знаю - у меня всё работает . вот тебе пример - по красной кнопке в справочнике товары

    "Далее в ФормеЭлемента при открытии присваиваю значение МойКонтекст нужной мне переменной..." - а если в процедуре вводНового попробовать? через глобальную всё нормально епередается.
     

    Вложения:

    • 1.rar
      Размер файла:
      20,8 КБ
      Просмотров:
      11
  7. shane13

    shane13 Гость

    Спасибо! Действительно получилось. Просто я написала много лишнего и забыла убрать... оно-то всё и портило!!
     
Загрузка...

Поделиться этой страницей