Помогите разобраться с документом ГТД

Тема в разделе "1C и всё что с ней связано", создана пользователем -, 28 сен 2010.

  1. Гость

    Всем привет, помогите разобраться, комплексная конфигурация, документ ГТД. Формируются проводки не так как бы хотелось. Необходимо чтобы в проводке 281-632, по 281 счету в проводке было указано субконто 1, субконто 2 ну и + количество. Вроде и в плане счетов все предусмотрено, а проводки формируются итоговыми суммами по документу (а надо грубо говоря в цикле по строкам), соответственно тогда и в 281 нет аналитики по субконто. Может где то есть какая то загвоздочка и можно быстро решить мою проблему, вместо того чтобы изобретать заново велосипед?
    про обработку ЭП_ФормированиеПроводокТорговля

    текОперация.Дебет.Счет = текСчетД;
    Если ПустоеЗначение(текСчетД) = 0 Тогда
    Для Инд = 1 по 3 Цикл
    //Если текСчетД.ВидСубконто(Инд) = ВидыСубконто.Партии Тогда
    // раскомментировать, если необходимо формирование поводок по счетам учета товаров с аналитикой
    // нужно найти или создать партию
    спПартия = тбПроводки.ПолучитьЗначение(тбПроводки.НомерСтроки, "СубконтоД"+Инд);
    ЗначениеСубк = 0;
    Если ТипЗначенияСтр(спПартия)="СписокЗначений" Тогда
    глПолучитьПартию(ЗначениеСубк,спПартия.Получить("ТМЦ"),спПартия.Получить("Партия"));
    КонецЕсли;
    Иначе
    ЗначениеСубк = тбПроводки.ПолучитьЗначение(тбПроводки.НомерСтроки, "СубконтоД"+Инд);
    КонецЕсли;
    КонецЦикла;

    Так вот в чем дело: когда я раскоментировала необходимые строки для ведения аналитики по товарам, ничего не произошло, такие же проводки как были такие и остались, как заставить программу видеть 281 счет по товарам.

    и ещё один вопрос:
    Справочник ЭП_Проводки

    Если ПустоеЗначение(ВидСубконто) = 0 Тогда
    Если (ТипЗначенияСтр(Счет) = "Счет") и ((Лев(Сч.Код,2) = "28") или (Лев(Сч.Код,2) = "66")) Тогда
    // для счетов 28х и 66х запрещено редактирование субконто
    Форма.ПолучитьАтрибут(Субконто).Видимость(0);
    Форма.ПолучитьАтрибут(тСубконто).Заголовок("Пустое субконто");
    Форма.ПолучитьАтрибут(тСубконто).Видимость(1);
    Форма.ПолучитьАтрибут(АвтоСубконто).Доступность(0);
    Форма.ПолучитьАтрибут(Параметр).Доступность(0);
    ИначеЕсли (ТипЗначенияСтр(Счет) = "Справочник")
    и (Лев(Сч.Код,2) = "28") Тогда
    // для доп.параметров "Счет учета товаров", "Счет учета товаров в рознице"
    // и "Счет учета товаров, отданных на комиссию"
    // запрещено редактирование субконто
    Форма.ПолучитьАтрибут(Субконто).Видимость(0);
    Форма.ПолучитьАтрибут(тСубконто).Заголовок("Определяется автоматически");
    Форма.ПолучитьАтрибут(тСубконто).Видимость(1);
    Форма.ПолучитьАтрибут(АвтоСубконто).Доступность(0);
    Форма.ПолучитьАтрибут(Параметр).Доступность(0);
    Иначе
    ........
    и т.д.

    почему ЗАПРЕЩЕНО РЕДАКТИРОВАНИЕ СУБКОНТО по 28 счету?
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    А это в Белорусии такие большие номера счетов?
    Ваша конфа кем-то дописывалась? Кто ж может знать, зачем это делалось...
     
  3. Гость

    Это комплексная конфигурация для Украины(( Типа стандарт, в данном контексте не дописывалась, т.е. это по умолчанию так есть(
     
Загрузка...

Поделиться этой страницей