помогите с импортом в 1С

  • Автор темы mic-at
  • Дата начала
Статус
Закрыто для дальнейших ответов.
M

mic-at

#1
1С 7.7 установленная SQL версия и в базу данных 1С на SQL Server необходимо подкидывать данные из другой базы данных на этом же сервере. Как это организовать? Мое приложение написано на VB6 работает с базами данных и именно оно должно производить импорт данных в базу 1С. Возможно ли это? Подскажите в каком направлении двигаться.

С уважением mic-at
 
T

Typhoon

#2
А что тебе мешает конектить саму 1с к базе и тягать то что ей нада из другой?
 
M

mic-at

#3
А что тебе мешает конектить саму 1с к базе и тягать то что ей нада из другой?
Я не очень давно изучаю 1С, по тому как это сделать стандартными средствами не знаю, подскажите где почитать. А еще база имеет структуру отличную от структуры 1С и возможно ли в таком случае стандартными средствами 1С взять информацию и перенести ее в базу 1С
 
T

Typhoon

#4
никаких проблем нет в том чтобы подключиться через оле соедиение из приемника к источнику и читать то что нада и писать куда нада! Могу только порекомендовать возпользоваться мистой там есть инфа для новичков!
 
M

mic-at

#5
никаких проблем нет в том чтобы подключиться через оле соедиение из приемника к источнику и читать то что нада и писать куда нада! Могу только порекомендовать возпользоваться мистой там есть инфа для новичков!
:( что такое миста по подробней скажите. А вот что еще спросить хотел этот процесс можно както автоматизировать чтоб не приходилось каждый раз руками все это делать? И как это сделать легче програмировать под 1С или самому писать прогу?
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#6
Миста - www.mista.ru
Автоматизировать можно так: шедулером запускать вашу программу для экспорта данных в 1С (как один из вариантов).
Программировать "под 1С" придется в любом случае, если планируете использовать ОЛЮ для передачи данных.
 
T

Typhoon

#7
Если будет больше информации могу помочь написать обработку для синхронизации баз!
 
M

mic-at

#8
Если будет больше информации могу помочь написать обработку для синхронизации баз!
у меня есть база в ней хранится информация к примеру об остатках средств и необходимо синхронизировать её с базой учета в 1С. Я просто сам еще не знаю какую точно информацию надо синхронизировать если можите помогите с примером
 
T

Typhoon

#9
Вот примитивный пример:

БазаОле= Новый COMОбъект("V77.Application");
РезультатПодключения = БазаОле.Initialize(БазаОле.RMTrade,"","");
Если РезультатПодключения = 0 Тогда
Предупреждение("Ошибка подключения.");
КонецЕсли;
СпрОле = БазаОле.CreateObject("Справочник."+Имя);
СпрОлеГруппа = БазаОле.CreateObject("Справочник."+Имя);
СпрОлеГруппа.ВыборГруппы(1);
СпрОлеГруппа.Выбрать();
СпрОле.ИспользоватьРодителя(СпрОлеГруппа);
СпрОле.ВыбратьЭлементы();
МенеджерДанных = Новый("СправочникМенеджер."+ТипДанных);
Пока СпрОле.ПолучитьЭлемент() = 1 Цикл
Если МенеджерДанных.НайтиПоКоду(СпрОле.Код).Пустая() Тогда
НовСпр=МенеджерДанных.СоздатьЭлемент();
НовСпр.Код=СпрОле.Код;
НовСпр.Наименование=СпрОле.Наименование;
НовСпр.Записать();
Иначе

КонецЕсли;
КонецЦикла;
 
Статус
Закрыто для дальнейших ответов.