помогите с импортом в 1С

Тема в разделе "1C и всё что с ней связано", создана пользователем mic-at, 1 июн 2007.

Статус темы:
Закрыта.
  1. mic-at

    mic-at Гость

    1С 7.7 установленная SQL версия и в базу данных 1С на SQL Server необходимо подкидывать данные из другой базы данных на этом же сервере. Как это организовать? Мое приложение написано на VB6 работает с базами данных и именно оно должно производить импорт данных в базу 1С. Возможно ли это? Подскажите в каком направлении двигаться.

    С уважением mic-at
     
  2. Typhoon

    Typhoon Гость

    А что тебе мешает конектить саму 1с к базе и тягать то что ей нада из другой?
     
  3. mic-at

    mic-at Гость

    Я не очень давно изучаю 1С, по тому как это сделать стандартными средствами не знаю, подскажите где почитать. А еще база имеет структуру отличную от структуры 1С и возможно ли в таком случае стандартными средствами 1С взять информацию и перенести ее в базу 1С
     
  4. Typhoon

    Typhoon Гость

    никаких проблем нет в том чтобы подключиться через оле соедиение из приемника к источнику и читать то что нада и писать куда нада! Могу только порекомендовать возпользоваться мистой там есть инфа для новичков!
     
  5. mic-at

    mic-at Гость

    :( что такое миста по подробней скажите. А вот что еще спросить хотел этот процесс можно както автоматизировать чтоб не приходилось каждый раз руками все это делать? И как это сделать легче програмировать под 1С или самому писать прогу?
     
  6. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Миста - www.mista.ru
    Автоматизировать можно так: шедулером запускать вашу программу для экспорта данных в 1С (как один из вариантов).
    Программировать "под 1С" придется в любом случае, если планируете использовать ОЛЮ для передачи данных.
     
  7. Typhoon

    Typhoon Гость

    Если будет больше информации могу помочь написать обработку для синхронизации баз!
     
  8. mic-at

    mic-at Гость

    у меня есть база в ней хранится информация к примеру об остатках средств и необходимо синхронизировать её с базой учета в 1С. Я просто сам еще не знаю какую точно информацию надо синхронизировать если можите помогите с примером
     
  9. Typhoon

    Typhoon Гость

    Вот примитивный пример:

    БазаОле= Новый COMОбъект("V77.Application");
    РезультатПодключения = БазаОле.Initialize(БазаОле.RMTrade,"","");
    Если РезультатПодключения = 0 Тогда
    Предупреждение("Ошибка подключения.");
    КонецЕсли;
    СпрОле = БазаОле.CreateObject("Справочник."+Имя);
    СпрОлеГруппа = БазаОле.CreateObject("Справочник."+Имя);
    СпрОлеГруппа.ВыборГруппы(1);
    СпрОлеГруппа.Выбрать();
    СпрОле.ИспользоватьРодителя(СпрОлеГруппа);
    СпрОле.ВыбратьЭлементы();
    МенеджерДанных = Новый("СправочникМенеджер."+ТипДанных);
    Пока СпрОле.ПолучитьЭлемент() = 1 Цикл
    Если МенеджерДанных.НайтиПоКоду(СпрОле.Код).Пустая() Тогда
    НовСпр=МенеджерДанных.СоздатьЭлемент();
    НовСпр.Код=СпрОле.Код;
    НовСпр.Наименование=СпрОле.Наименование;
    НовСпр.Записать();
    Иначе

    КонецЕсли;
    КонецЦикла;
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей