1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

помогите с импортом в 1С

Тема в разделе "Базы данных и администрирование", создана пользователем mic-at, 1 июн 2007.

Статус темы:
Закрыта.
  1. mic-at

    mic-at Гость

    Репутация:
    0
    1С 7.7 установленная SQL версия и в базу данных 1С на SQL Server необходимо подкидывать данные из другой базы данных на этом же сервере. Как это организовать? Мое приложение написано на VB6 работает с базами данных и именно оно должно производить импорт данных в базу 1С. Возможно ли это? Подскажите в каком направлении двигаться.

    С уважением mic-at
     
  2. Typhoon

    Typhoon Гость

    Репутация:
    0
    А что тебе мешает конектить саму 1с к базе и тягать то что ей нада из другой?
     
  3. mic-at

    mic-at Гость

    Репутация:
    0
    Я не очень давно изучаю 1С, по тому как это сделать стандартными средствами не знаю, подскажите где почитать. А еще база имеет структуру отличную от структуры 1С и возможно ли в таком случае стандартными средствами 1С взять информацию и перенести ее в базу 1С
     
  4. Typhoon

    Typhoon Гость

    Репутация:
    0
    никаких проблем нет в том чтобы подключиться через оле соедиение из приемника к источнику и читать то что нада и писать куда нада! Могу только порекомендовать возпользоваться мистой там есть инфа для новичков!
     
  5. mic-at

    mic-at Гость

    Репутация:
    0
    :( что такое миста по подробней скажите. А вот что еще спросить хотел этот процесс можно както автоматизировать чтоб не приходилось каждый раз руками все это делать? И как это сделать легче програмировать под 1С или самому писать прогу?
     
  6. vitfil

    vitfil IT-интегратор

    Репутация:
    0
    Регистрация:
    2 апр 2004
    Сообщения:
    2.062
    Симпатии:
    0
    Миста - www.mista.ru
    Автоматизировать можно так: шедулером запускать вашу программу для экспорта данных в 1С (как один из вариантов).
    Программировать "под 1С" придется в любом случае, если планируете использовать ОЛЮ для передачи данных.
     
  7. Typhoon

    Typhoon Гость

    Репутация:
    0
    Если будет больше информации могу помочь написать обработку для синхронизации баз!
     
  8. mic-at

    mic-at Гость

    Репутация:
    0
    у меня есть база в ней хранится информация к примеру об остатках средств и необходимо синхронизировать её с базой учета в 1С. Я просто сам еще не знаю какую точно информацию надо синхронизировать если можите помогите с примером
     
  9. Typhoon

    Typhoon Гость

    Репутация:
    0
    Вот примитивный пример:

    БазаОле= Новый COMОбъект("V77.Application");
    РезультатПодключения = БазаОле.Initialize(БазаОле.RMTrade,"","");
    Если РезультатПодключения = 0 Тогда
    Предупреждение("Ошибка подключения.");
    КонецЕсли;
    СпрОле = БазаОле.CreateObject("Справочник."+Имя);
    СпрОлеГруппа = БазаОле.CreateObject("Справочник."+Имя);
    СпрОлеГруппа.ВыборГруппы(1);
    СпрОлеГруппа.Выбрать();
    СпрОле.ИспользоватьРодителя(СпрОлеГруппа);
    СпрОле.ВыбратьЭлементы();
    МенеджерДанных = Новый("СправочникМенеджер."+ТипДанных);
    Пока СпрОле.ПолучитьЭлемент() = 1 Цикл
    Если МенеджерДанных.НайтиПоКоду(СпрОле.Код).Пустая() Тогда
    НовСпр=МенеджерДанных.СоздатьЭлемент();
    НовСпр.Код=СпрОле.Код;
    НовСпр.Наименование=СпрОле.Наименование;
    НовСпр.Записать();
    Иначе

    КонецЕсли;
    КонецЦикла;
     
Загрузка...
Похожие Темы - помогите импортом 1С
  1. Tayrus
    Ответов:
    2
    Просмотров:
    46
  2. KanycTa
    Ответов:
    1
    Просмотров:
    51
  3. Samyrro
    Ответов:
    1
    Просмотров:
    61
  4. Tayrus
    Ответов:
    0
    Просмотров:
    51
  5. bronnn
    Ответов:
    0
    Просмотров:
    112
Статус темы:
Закрыта.

Поделиться этой страницей