помогите с обработкой

Тема в разделе "1C и всё что с ней связано", создана пользователем inn, 4 фев 2008.

  1. inn

    inn Гость

    Подскажите как создать обработку,чтобы в справочнике в зависимости
    от значения одного реквизита, типа (Перечисление.Логическое) менялось
    значение другого типа ("Число").
    Ошибок не выдаёт но не работает
    Код:

    Процедура Сформировать()
    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
    СпрЗаказы.ВыбратьЭлементы();
    Пока СпрЗаказы.ПолучитьЭлемент()=1 Цикл
    Если СпрЗаказы.Актуальность = Перечисление.Логическое.Да тогда
    СпрЗаказы.флАктуально=2;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
     
  2. Isabela

    Isabela Гость

    Процедура Сформировать()
    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
    СпрЗаказы.ВыбратьЭлементы();
    Пока СпрЗаказы.ПолучитьЭлемент()=1 Цикл
    Если СпрЗаказы.Актуальность = Перечисление.Логическое.Да тогда
    СпрЗаказы.флАктуально=2;
    // сюда надо вставить СпрЗаказы.Записать(); !
    // и неплохо еще обработать ветку СпрЗаказы.Актуальность = Перечисление.Логическое.Нет
    // else и т.п.
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
     
  3. inn

    inn Гость

    Большое спасибо, всё получилось!
     
Загрузка...

Поделиться этой страницей