1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

помогите с обработкой

Тема в разделе "Базы данных и администрирование", создана пользователем inn, 4 фев 2008.

  1. inn

    inn Гость

    Репутация:
    0
    Подскажите как создать обработку,чтобы в справочнике в зависимости
    от значения одного реквизита, типа (Перечисление.Логическое) менялось
    значение другого типа ("Число").
    Ошибок не выдаёт но не работает
    Код:

    Процедура Сформировать()
    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
    СпрЗаказы.ВыбратьЭлементы();
    Пока СпрЗаказы.ПолучитьЭлемент()=1 Цикл
    Если СпрЗаказы.Актуальность = Перечисление.Логическое.Да тогда
    СпрЗаказы.флАктуально=2;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
     
  2. Isabela

    Isabela Гость

    Репутация:
    0
    Процедура Сформировать()
    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
    СпрЗаказы.ВыбратьЭлементы();
    Пока СпрЗаказы.ПолучитьЭлемент()=1 Цикл
    Если СпрЗаказы.Актуальность = Перечисление.Логическое.Да тогда
    СпрЗаказы.флАктуально=2;
    // сюда надо вставить СпрЗаказы.Записать(); !
    // и неплохо еще обработать ветку СпрЗаказы.Актуальность = Перечисление.Логическое.Нет
    // else и т.п.
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
     
  3. inn

    inn Гость

    Репутация:
    0
    Большое спасибо, всё получилось!
     
Загрузка...

Поделиться этой страницей