1. Спонсор публикаций Marketplace codeby. Сервис, который так долго ждали. При расчетах используем биткоин. Первый товар уже в продаже: Консультация на тему ИБ от Ondrik8

    Скрыть объявление
  2. Спонсор публикаций Marketplace codeby. Сервис, который так долго ждали. При расчетах используем биткоин. Второй товар маркетплейса: Надёжная обфускация вашей программы от PingVinich

    Скрыть объявление

помогите с обработкой

Тема в разделе "1C и всё что с ней связано", создана пользователем inn, 4 фев 2008.

  1. inn

    inn Гость

    Репутация:
    0
    Подскажите как создать обработку,чтобы в справочнике в зависимости
    от значения одного реквизита, типа (Перечисление.Логическое) менялось
    значение другого типа ("Число").
    Ошибок не выдаёт но не работает
    Код:

    Процедура Сформировать()
    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
    СпрЗаказы.ВыбратьЭлементы();
    Пока СпрЗаказы.ПолучитьЭлемент()=1 Цикл
    Если СпрЗаказы.Актуальность = Перечисление.Логическое.Да тогда
    СпрЗаказы.флАктуально=2;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
     
  2. Isabela

    Isabela Гость

    Репутация:
    0
    Процедура Сформировать()
    СпрЗаказы = СоздатьОбъект ("Справочник.Заказы");
    СпрЗаказы.ВыбратьЭлементы();
    Пока СпрЗаказы.ПолучитьЭлемент()=1 Цикл
    Если СпрЗаказы.Актуальность = Перечисление.Логическое.Да тогда
    СпрЗаказы.флАктуально=2;
    // сюда надо вставить СпрЗаказы.Записать(); !
    // и неплохо еще обработать ветку СпрЗаказы.Актуальность = Перечисление.Логическое.Нет
    // else и т.п.
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
     
  3. inn

    inn Гость

    Репутация:
    0
    Большое спасибо, всё получилось!
     
Загрузка...
Похожие Темы - помогите обработкой
  1. number27
    Ответов:
    0
    Просмотров:
    75
  2. Rina
    Ответов:
    0
    Просмотров:
    89
  3. maksiiimka
    Ответов:
    2
    Просмотров:
    86
  4. Ким
    Ответов:
    23
    Просмотров:
    605
  5. Sr233
    Ответов:
    2
    Просмотров:
    190

Поделиться этой страницей