Помогите с тестовой задачкой! Очень срочно! Пожалуйста!

Тема в разделе "1C и всё что с ней связано", создана пользователем napagokc, 11 июл 2010.

  1. napagokc

    napagokc Гость

    Пожалуйста, помогите с простой задачкой. Я понимаю, что она не слишком сложная, но я 1С начал изучать только вчера :lovecodeby:. У меня опыт программирования есть (я специализируюсь в делфи), но тут я даже не знаю с чего начать. Если не сложно, то напишите, по возможности более подробно, как начать. Код процедур приводить не надо, я уже это нашел в книгах. Меня интересует какие объекты надо создавать? Ну, вот самое-самое начало...

    Вот задача:

    есть 2 фирмы: продающая и покупающая. Одна фирма продает товары другой.
    Из продающей фирмы нужно выгрузить отгрузочный документ и в покупающую фирму - загрузить в приходный документ.
    Формат выгрузки - xml.
    Нужна внешняя обработка, т.е обработка ,которая не входит в конфигурацию.


    Я так понял, нужно создать две БД: одну для продающей фирмы, другую для покупающей. А что в конфигурациях к этим фирмам нужно сделать?
     
  2. evgenyatam

    evgenyatam Well-Known Member

    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    зачем сразу конфигурации? взять торговлю (которая УТ) и размножить. Только через XML надо прогнать чють ли не все содержимое элемента номенклатуры - вдруг отсутствует. И предусмотреть механизм контроля привязки - вдруг существует но с другим кодом. наименование тоже может не совпадать. А артикул может попросту отсутствовать.
     
  3. tanat

    tanat Well-Known Member

    Регистрация:
    2 мар 2007
    Сообщения:
    265
    Симпатии:
    0
    Это для учебы, или за деньги?
    Если для учебы: тогда создайте справочники. Организации.Контрагенты. Номенклатура. Документы: приход, расход. Регистры: регистр накопления ( остатки и обороты) : Товародвижения. Затем создавайте внешнюю обработку ( файл-новый-внешняя обработка). Ну а там, как говорится, "флаг Вам в руки, гранату - на шею".
    Если для работы: на этом форуме не приветствуют вопросы в стиле " как из го..на слепить конфетку". Тут требуют конкретики: платформа, конфигурация, делаю вот это вот так-вот, не получается, ошибка ( описание ошибки).
     
  4. napagokc

    napagokc Гость

    Задачка на зачет. И я бы не просил помощи, если бы не было нужно так срочно.

    Как бы то ни было, с выгрузкой в xml-файл я что-то намутил. Точнее, мне помогли очень сильно. Сам бы я еще возился и возился...
    Помогите теперь обработать чтение из xml-файла, если не сложно...
    я пока на самом начале. Если что получится - отпишусь. Пока у меня есть это:
    Код ( (Unknown Language)):
       
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл(Файл);
    Пока ЧтениеXML.Прочитать() Цикл
    Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда            
    Если ЧтениеXML.Имя = "Данные" Тогда              
    // пока нахожусь тут
    КонецЕсли;                                
    КонецЕсли;                                                
    КонецЦикла;      
    ЧтениеXML.Закрыть();
    пример xml-файла (данных может быть много):

    <?xml version="1.0" encoding="windows-1251" ?>
    - <Данные>
    - <РасходнаяНакладная Номер="ДПс0078" Дата="01.04.2010" КодПокупателя="000000020/000000021/000000027">
    <Товар Код="R2804" Наименование="какой-то товар (4" Цена="1234" Количество="1" ЕдИзм="уп." Сумма="1234" СтавкаНДС="0" НДС="" ГТД="" Страна="" />
    </РасходнаяНакладная>
    </Данные>
     
Загрузка...
Похожие Темы - Помогите тестовой задачкой
  1. limbra
    Ответов:
    3
    Просмотров:
    47
  2. NylevoiChelovek
    Ответов:
    5
    Просмотров:
    112
  3. Ruska132
    Ответов:
    49
    Просмотров:
    418
  4. gURaBA_N
    Ответов:
    7
    Просмотров:
    149
  5. uxbmw3w
    Ответов:
    0
    Просмотров:
    69

Поделиться этой страницей