• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фаззинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь. Мобильный клиент для IOS находится в itunes по этой ссылке

Проблема Помогите с USB Wi Fi адаптером в Kali Linux.

fantomchik

New member
20.05.2018
1
0
#1
Установлен Кали Линукс. Куплен адаптер wn821n Wi Fi. Запущен через виртуалку. Хоть убей не видит сетей и сам адаптер, но интернет есть. Ставил драйвера по инструкции, но на последних шагах выдает ошибку
Код:
root@kali:~/Desktop/1/1# make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.15.0-kali3-amd64/build M=/root/Desktop/1/1 modules
make[1]: Entering directory '/usr/src/linux-headers-4.15.0-kali3-amd64'
CC [M] /root/Desktop/1/1/core/rtw_cmd.o
In file included from /root/Desktop/1/1/include/osdep_service.h:47:0,
from /root/Desktop/1/1/include/drv_types.h:27,
from /root/Desktop/1/1/core/rtw_cmd.c:17:
/root/Desktop/1/1/include/osdep_service_linux.h: In function ‘_init_timer’:
/root/Desktop/1/1/include/osdep_service_linux.h:299:8: error: ‘_timer {aka struct timer_list}’ has no member named ‘data’
ptimer->data = (unsigned long)cntx;
^~
/root/Desktop/1/1/include/osdep_service_linux.h:300:2: error: implicit declaration of function ‘init_timer’; did you mean ‘_init_timer’? [-Werror=implicit-function-declaration]
init_timer(ptimer);
^~~~~~~~~~
_init_timer
cc1: some warnings being treated as errors
/usr/src/linux-headers-4.15.0-kali3-common/scripts/Makefile.build:329: recipe for target '/root/Desktop/1/1/core/rtw_cmd.o' failed
make[4]: *** [/root/Desktop/1/1/core/rtw_cmd.o] Error 1
/usr/src/linux-headers-4.15.0-kali3-common/Makefile:1537: recipe for target '_module_/root/Desktop/1/1' failed
make[3]: *** [_module_/root/Desktop/1/1] Error 2
Makefile:146: recipe for target 'sub-make' failed
make[2]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-kali3-amd64'
Makefile:1828: recipe for target 'modules' failed
make: *** [modules] Error 2
Уже 3 дня маюсь с бубном. Ничего не получается. Я не останусь в долгу, если поможете поставить адаптер. Также пробовал другие драйвера от реалтека, вроде без ошибок все, но эффекта нет.

root@kali:~/Desktop/1/1# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.
 

yarr

Red Team
05.10.2017
206
382
#2
Дичь какая-то. Драйвера для туполинков в Kali по дефолту, если в монитор не может, значит увы.
Далее - с виртуалкой вечно проблемы, особенно с адаптерами. Можешь попробовать поставить на VMvare, а не на коробку с мусором. А лучше ставь на HDD/Live CD.
Так же проверь настройки бокса, ты мог забыть поставить расширенный пакет и пакет для работы с USB, да-да коробка с мусором (Vbox), она такая.

Но главное, меня смущает
Для просмотра контента необходимо: Войти или зарегистрироваться
. Там 3 версия, а значит есть как минимум еще 2 с другими чипсетами (там на самом деле 6 РЕВИЗИЙ). И какая у тебя?

Как узнаешь ревизию, гугли чипсет на совместимость с монитором, инъекцией и т.д. Затем запиши Kali на флешку и попробуй завести адаптер в монитор, deauth, wps и т.д.
 
Последнее редактирование:

NeskO

Well-known member
10.01.2018
72
31
#5
Установлен Кали Линукс. Куплен адаптер wn821n Wi Fi. Запущен через виртуалку. Хоть убей не видит сетей и сам адаптер, но интернет есть. Ставил драйвера по инструкции, но на
eth0 no wireless extensions.
а разве вайфай адаптер подписан,eth0? может быть wlan0
 

SmokeDog

Well-known member
20.06.2018
108
131
#6
В кали линукс по дефолту стоят адаптера.
Попробуй sudo apt-get upgrade

Я бы тебе не советовал копаться с системой если не получаеться, а то еще зависимостей набьешь. И все тогда трындец.И там есть в инете список совместимых адаптеров с кали линукс. Просто посмотри, выбери, купи и живи. Т.к там уже установлены дрова для указаных адаптеров.
И кстати вот ссылка:
Для просмотра контента необходимо: Войти или зарегистрироваться

А с этим адаптером купленным у тебя тебе врятли ктото поможет.Там в кали линукс очень сложно все с дровами
 
Симпатии: Понравилось De_eR
Вверх Снизу