Помогите с выделением ячейки

  • Автор темы ivsm88
  • Дата начала
Статус
Закрыто для дальнейших ответов.
I

ivsm88

Гость
#1
Задача, надеюсь, не сложная

Платформа 1С Предприятие 8.2.9.356
Есть Справочник, в нем Таблица, в ней колонка "Наименование". Мне необходимо чтобы
при Активизации Строки Таблицы текущая ячейка в этой колонке выделялась желтым цветом.

В модуле ФормыСписка пишу код:

Процедура ПриВыводеСтроки (Элемент, ОформлениеСтроки, ДанныеСтроки)
ОформлениеСтроки.Ячейки.Цвет=webЦвета.Красный;
КонецПроцедуры

При запуска выдается ошибка "Значение [Ячейки] не является значением объектного типа"

В чем проблема, подскажите, пожалуйста!
 

puh14

Well-Known Member
11.07.2008
1 412
0
#2
Сильно подозреваю, что надо что-то типа ОформлениеСтроки.Ячейки[1].цвет - а то прога не может понять какую ячейку имеют ввиду.
 
I

ivsm88

Гость
#3
Сильно подозреваю, что надо что-то типа ОформлениеСтроки.Ячейки[1].цвет - а то прога не может понять какую ячейку имеют ввиду.
Та же самая ошибка все равно!
Не пойму, почему так происходит. И так и так пробовал - одно и тоже!
 
K

KoTRiK

Гость
#4
Задача, надеюсь, не сложная

Платформа 1С Предприятие 8.2.9.356
Есть Справочник, в нем Таблица, в ней колонка "Наименование". Мне необходимо чтобы
при Активизации Строки Таблицы текущая ячейка в этой колонке выделялась желтым цветом.

В модуле ФормыСписка пишу код:

Процедура ПриВыводеСтроки (Элемент, ОформлениеСтроки, ДанныеСтроки)
ОформлениеСтроки.Ячейки.Цвет=webЦвета.Красный;
КонецПроцедуры

При запуска выдается ошибка "Значение [Ячейки] не является значением объектного типа"

В чем проблема, подскажите, пожалуйста!
"ОформлениеСтроки.Ячейки" cодержит коллекцию значений ОформлениеЯчейки для строки.

Т.е для обхода коллекции и задания цвета нужно использовать такой код

Для каждого ОформлениеЯчейки из ОформлениеСтроки.Ячейки Цикл
ОформлениеЯчейки.ЦветФона = Новый Цвет(255, 255, 255);
КонецЦикла
 
I

ivsm88

Гость
#5
"ОформлениеСтроки.Ячейки" cодержит коллекцию значений ОформлениеЯчейки для строки.

Т.е для обхода коллекции и задания цвета нужно использовать такой код

Для каждого ОформлениеЯчейки из ОформлениеСтроки.Ячейки Цикл
ОформлениеЯчейки.ЦветФона = Новый Цвет(255, 255, 255);
КонецЦикла
Тоже Самое ((
 

Darlock

Well-Known Member
04.01.2008
560
1
#7
О какой ячейке идет речь?

Код:
ОформлениеСтроки.Ячейки.{ИмяКолонки}.ЦветФона = ...
 

Darlock

Well-Known Member
04.01.2008
560
1
#8
ОформлениеЯчейки.ЦветФона = Новый Цвет(255, 255, 255);
Такой подход сильно тормозит компиляцию. Лучше один раз определить цвет
Код:
ЦветФона = Новый Цвет(255, 255, 255);
а потом использовать переменную

Код:
ОформлениеЯчейки.ЦветФона = ЦветФона;
 
Статус
Закрыто для дальнейших ответов.