помогите сделать отчет "Шахматка"

Тема в разделе "1C и всё что с ней связано", создана пользователем Jivch1C, 8 фев 2008.

Статус темы:
Закрыта.
  1. Jivch1C

    Jivch1C Гость

    На стажеровке дали задание, помогите сделать с "нуля", какой код будет

    это отчет "Шахматка", по товару и контрагенту, на пересечении ячеек - количество товара купленного контрагентом, документы "Реализация". В прикрепленном файле показанна схема отчета. Спасибо

    такой вот отчет надо запрограммировать для Комплексной конфигурации 4.3

    прилагаю файл шахматки в Excel

    если есть возможность вот мой №ICQ 300-199-620

    Спасибо.
     

    Вложения:

    • ________.rar
      Размер файла:
      1,6 КБ
      Просмотров:
      32
  2. jcnby

    jcnby Гость

    К сожалению архивы на работе не открываются......
    Код как я понял тебе вообще и не нужен толком...., т.е. только для занесения наименования товара, и его количества.

    Говаря грубо - нужно найти и выбрать все документы "реализация" с данным контрагентом. и суммировать (если есть повторные) кол-ва товара по наименованию. Таблица в 1с схожа с Экселем, т.е. туда только ссылки повтыкать и форматнуть как душе приятнее.

    Осуществить можно с помощью запроса, либо же простой выборкой. Запрос- тяжелее объяснить, выборка будет пожалуй гразмоздкая.
    ( с 4.3 не знаком) выкино обычный эксель ( а не в архифе) - может чего подскажу поконкретнее.
     
  3. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    А для какой это платформы нужно-то - 7 или 8? Если 7.7 - знаю навреняка Шахматку можно легко сделать при помощи конструктора. Насчет 8 - может такое тоже есть... Попробуй повнимательнее посмотреть
     
  4. jcnby

    jcnby Гость

    <!--QuoteBegin-KiR+8:02:2008, 16:27 -->
    <span class="vbquote">(KiR @ 8:02:2008, 16:27 )</span><!--QuoteEBegin-->А для какой это платформы нужно-то - 7 или 8? Если 7.7 - знаю навреняка Шахматку можно легко сделать при помощи конструктора. Насчет 8 - может такое тоже есть... Попробуй повнимательнее посмотреть
    [snapback]97283" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    Не в коем случае не пользуйтесь конструктором!!!! Он убивает мозх!!!!

    лутше так.......из конфигуратора Файл- новое- Внешняя обработка.
    тама на форму вешаем Реквизит Диалога , ТИП- выбираем справочник контрагентов, в индефикаторе -*** тот же что в и запросе. ( контрагент всмысле)

    Далее открываем модуль, смотрим на него, как надоест смотреть начинаем присать внутри процедуры:

    Код (Text):
    Запрос=СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(СФОРМИРОВАТЬ)
    |Контр=Документ.Реализация.Контрагент;  - тут Контрагент - так как объявленно в конфе;*****
    |Товар=Документ.Реализация.Товар; - так как объявлен товар в конфе.
    |Количество=Документ.Реализация.Количество; - реквизит количества в доке " реализация"
    |Группировка Товар по Контр;
    |"//}}ЗАПРОС

    Если ЗАпрос.Выполнить(ТекстЗапроса)=0 Тогда
    Возврат;
    КонецЕсли;
    что-то типа, а птом ето все в таблицу , типа
    Код (Text):
    Пока Запрос.Группировка("Товар")
    =1 и т.д.
     
  5. Jivch1C

    Jivch1C Гость

    дело в том что я очень новичек, мне поставили задание на саморазбор... сделать отчет-шахматку, со всеми втекающими-вытекающими последствиями. У меня проблема с кодом, не знаю как к нему подойти, просмотрел литературу... в принципе не понял, опыта нет.кусочек набросал отовсюду, но это так... конвульсии, даже не знаю с чего начать. Вот то что я от кудато взял

    Процедура Сформировать();

    Док=СоздатьОбъект("Документ.Реализация");
    Док.ВыбратьДокумент(Дата1, Дата2);
    Пока.Док.ПолучитьДокумент()=1 Цикл
    Док.Контрагент = Контрагент;
    Док.Сумма = Сумма;

    КонецЦикла;
    КонецПроцедуры;

    как к этому подойти незнаю, к сожалению

    суть задания в самообразовании, чтобы сам поискал решение, но к понедельнику сказали отчет нужен

    платформа 7.7 Комплексная конфигурация 4.3

    файл в MSWord

    Посмотреть вложение ________.doc
     
  6. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    1. Конструкторы, новый отчет, далее, далее,
    2. птаха на конструктор бух. запросов, Готово.
    3. Ок, шахматка, Далее,
    4. за период, будет выбираться в диалоге, Далее,
    5. (теперь не помню, реализация, вроде, делается по счетам 62-41 тогда выбираем один из них) добавляем нужное субконто (контрагенты или, номенклатура), можно поставить выбор в диалоге - будет отбор по конкретным значениям(не лишне), Далее
    6. (проделываем то-же со вторым счетом и его субконто) Далее, Далее,
    7. указываем субконто по строкам и колонкам, ставим птаху про количество, Далее, Готово.

    Получили 47 строк кода учитывая комментарии, форму настройки отчета, и таблицу. Теперь внимательно разбираемся, что этот код делает, где не работает, почему, что нужно поменять. С конкретными вопросами приходим сюда. Если, вдруг, комплексная 4.3. не делает бух проводок, сохраняем этот отчет, как пример постройки шахматки на основе данных бух запроса, строим аналогичных запрос по документам (правда шахматки там не будет) и скрещиваем. Но тут без понимания того, что делаешь не обойтись... или разбирайся, или в личку любому программеру с форума с предложением помочь воздмезно :)
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей