Помогите сократить процедуру в 1с7.7

  • Автор темы petrovi4
  • Дата начала
P

petrovi4

Гость
#1
Цена1,2,3... - числовые поля ввода в форме внеш обработки

[codebox]Процедура УстановитьЦену(Ном,Значение)
Если Ном=1 Тогда
Цена1=Значение;
КонецЕсли;
Если Ном=2 Тогда
Цена2=Значение;
КонецЕсли;
Если Ном=3 Тогда
Цена3=Значение;
КонецЕсли;
Если Ном=4 Тогда
Цена4=Значение;
КонецЕсли;
Если Ном=5 Тогда
Цена5=Значение;
КонецЕсли;
Если Ном=6 Тогда
Цена6=Значение;
КонецЕсли;
Если Ном=7 Тогда
Цена7=Значение;
КонецЕсли;

...

КонецПроцедуры[/codebox]

можно тело процедуры задать одной строкой?

а если тип поля ввода будет например - справочник?

спасибо.
 

vitfil

IT-интегратор
02.04.2004
2 062
0
44
Минск
#2
Через Шаблон
Код:
Функция Присвоить(Чему,Что)
Чему = Что;
Возврат "";
КонецФункции // глПрисвоить(Чему,Что)
...
Процедура УстановитьЦену(ном,значение)
Шаблон("[Присвоить(Цена"+ном+","+Значение+")]");
...
 
P

petrovi4

Гость
#3
Через Шаблон
Код:
Функция Присвоить(Чему,Что)
Чему = Что;
Возврат "";
КонецФункции // глПрисвоить(Чему,Что)
...
Процедура УстановитьЦену(ном,значение)
Шаблон("[Присвоить(Цена"+ном+","+Значение+")]");
...


СПАСИБО!