Помогите сократить процедуру в 1с7.7

Тема в разделе "1C и всё что с ней связано", создана пользователем petrovi4, 27 май 2008.

Наш партнер Genesis Hackspace
  1. petrovi4

    petrovi4 Гость

    Цена1,2,3... - числовые поля ввода в форме внеш обработки

    [codebox]Процедура УстановитьЦену(Ном,Значение)
    Если Ном=1 Тогда
    Цена1=Значение;
    КонецЕсли;
    Если Ном=2 Тогда
    Цена2=Значение;
    КонецЕсли;
    Если Ном=3 Тогда
    Цена3=Значение;
    КонецЕсли;
    Если Ном=4 Тогда
    Цена4=Значение;
    КонецЕсли;
    Если Ном=5 Тогда
    Цена5=Значение;
    КонецЕсли;
    Если Ном=6 Тогда
    Цена6=Значение;
    КонецЕсли;
    Если Ном=7 Тогда
    Цена7=Значение;
    КонецЕсли;

    ...

    КонецПроцедуры[/codebox]

    можно тело процедуры задать одной строкой?

    а если тип поля ввода будет например - справочник?

    спасибо.
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.062
    Симпатии:
    0
    Через Шаблон
    Код (Text):
    Функция Присвоить(Чему,Что)
    Чему = Что;
    Возврат "";
    КонецФункции // глПрисвоить(Чему,Что)
    ...
    Процедура УстановитьЦену(ном,значение)
    Шаблон("[Присвоить(Цена"+ном+","+Значение+")]");
    ...
     
  3. petrovi4

    petrovi4 Гость



    СПАСИБО!
     
Загрузка...
Похожие Темы - Помогите сократить процедуру
  1. qwertys
    Ответов:
    6
    Просмотров:
    176
  2. otokys
    Ответов:
    0
    Просмотров:
    55
  3. Nicolay
    Ответов:
    5
    Просмотров:
    139
  4. Տօօօօշ
    Ответов:
    1
    Просмотров:
    119
  5. сергей799
    Ответов:
    2
    Просмотров:
    117

Поделиться этой страницей