1. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

Помогите сократить процедуру в 1с7.7

Тема в разделе "1C и всё что с ней связано", создана пользователем petrovi4, 27 май 2008.

  1. petrovi4

    petrovi4 Гость

    Репутация:
    0
    Цена1,2,3... - числовые поля ввода в форме внеш обработки

    [codebox]Процедура УстановитьЦену(Ном,Значение)
    Если Ном=1 Тогда
    Цена1=Значение;
    КонецЕсли;
    Если Ном=2 Тогда
    Цена2=Значение;
    КонецЕсли;
    Если Ном=3 Тогда
    Цена3=Значение;
    КонецЕсли;
    Если Ном=4 Тогда
    Цена4=Значение;
    КонецЕсли;
    Если Ном=5 Тогда
    Цена5=Значение;
    КонецЕсли;
    Если Ном=6 Тогда
    Цена6=Значение;
    КонецЕсли;
    Если Ном=7 Тогда
    Цена7=Значение;
    КонецЕсли;

    ...

    КонецПроцедуры[/codebox]

    можно тело процедуры задать одной строкой?

    а если тип поля ввода будет например - справочник?

    спасибо.
     
  2. vitfil

    vitfil IT-интегратор

    Репутация:
    0
    Регистрация:
    2 апр 2004
    Сообщения:
    2.062
    Симпатии:
    0
    Через Шаблон
    Код:
    Функция Присвоить(Чему,Что)
    Чему = Что;
    Возврат "";
    КонецФункции // глПрисвоить(Чему,Что)
    ...
    Процедура УстановитьЦену(ном,значение)
    Шаблон("[Присвоить(Цена"+ном+","+Значение+")]");
    ...
     
  3. petrovi4

    petrovi4 Гость

    Репутация:
    0


    СПАСИБО!
     
Загрузка...

Поделиться этой страницей