Помощь по Excel

Тема в разделе "Свободное общение", создана пользователем KoJlbKA, 9 сен 2010.

  1. KoJlbKA

    KoJlbKA Гость

    Помогите пож., с написанием формулы в ексель

    например: есть 4 футбольные комманды в столбце А, есть очки в столбце В, и разница мячей в столбце С, нужно формулой выбрать комманду с максимальным количеством очек, но если в двух комманд очки одинаковые значить выбрать по максимальной разнице мячей.

    очки р.м.

    Комманда А 3 4
    Комманда Б 5 1
    Комманда В 5 -1
    Комманда Г 2 0

    нужно чтобы вывело комманду Б
     
  2. alik86

    alik86 Lotus team
    Lotus team

    Регистрация:
    20 ноя 2008
    Сообщения:
    465
    Симпатии:
    0
    Помниться есть в экселе надстройка "Поиск решения..."
     
  3. Tanya

    Tanya Гость

    Одной формулой не получилось (. Но может, подойдет так:

    __|_____A____| B | C | D
    1 |Команда__ |оч.|р.м|
    2 |Команда А | 3 | 4 | =ЕСЛИ(B2=МАКС($B$2:$B$5);C2;"")
    3 |Команда Б | 5 | 1 | =ЕСЛИ(B3=МАКС($B$2:$B$5);C3;"")
    4 |Команда В | 5 |-1 | =ЕСЛИ(B4=МАКС($B$2:$B$5);C4;"")
    5 |Команда Г | 2 | 0 | =ЕСЛИ(B5=МАКС($B$2:$B$5);C5;"")



    Результирующая формула будет (барабанная дробь, т.к. формула огрооомная))):
    =ЕСЛИ(СЧЁТЕСЛИ(B2:B5;МАКС(B2:B5))=1;ИНДЕКС(A2:A5;ПОИСКПОЗ(МАКС(B2:B5);B2:B5;0);1
    );ЕСЛИ(СЧЁТЕСЛИ(D2:D5;МАКС(D2:D5))>1;"найдено "&СЧЁТЕСЛИ(D2:D5;МАКС(D2:D5))&" команд";ИНДЕКС(A2:A5;ПОИСКПОЗ(МАКС(D2:D5);D2:D5;0);1)))

    Пояснения:
    1) В колонку D для каждой команды добавляется формула, рез-т которой будет показывать разницу мячей для команд с максимальным количеством очков. Колонку можно будет потом скрыть, естественно, чтобы не отображалась лишняя информация ));
    2) Результирующая формула определяет количество команд с макс. кол-вом очков. Если такая команда одна, то она является результатом. Если команд >1, то определяется количество команд с макс. кол-вом очков и макс. разницей мячей. Если такая команда 1, то она и является рез-том. Если команд больше, ты выводится сообщение, о количестве найденных команд;
    3) СЧЁТЕСЛИ(B2:B5;МАКС(B2:B5)) - поиск количества команд с максимальным количеством очков (рез-т: 2);
    4) ПОИСКПОЗ(МАКС(B2:B5);B2:B5;0) - определение индекса (в массиве данных) первой строки с максимальныи значением (рез-т: 2);
    5) ИНДЕКС(A2:A5;ПОИСКПОЗ(...);1) - поиск команды по найденному индексу в массиве (рез-т: Команда Б);
    6) СЧЁТЕСЛИ(D2:D5;МАКС(D2:D5)) - поиск количества команд с максимальным кол-вом очков и макс. разницей мячей (рез-т: 1);
    7) ИНДЕКС(A2:A5;ПОИСКПОЗ(МАКС(D2:D5);D2:D5;0);1)) - аналогично 2) и 3) определяется требуемая команда.
     
  4. Anastasia

    Anastasia Гость

    Здравствуйте, вы бы не могли пояснить как работают следущие формулы.

    Вот например: =ЕСЛИ(B2=""; "";ПРОСМОТР(B2;ОС!$A$2:$A$10;ОС!$B$2:$B$10)). - Если B2 сравнивается с ... с ячейки A2 по ячейку A10 ...
    Я не написала всё пояснение, потому не знаю как. Просто чтобы понятно было.

    1. =ЕСЛИ(B2=""; "";ПРОСМОТР(B2;ОС!$A$2:$A$10;ОС!$B$2:$B$10))

    2. :=ЕСЛИ(D2="";"";ПРОСМОТР(D2;'Подразделения организации'!$A$2:$A$5;'Подразделения организации'!$B$2:$B$5))

    3. ЕСЛИ(B2="";"";ПРОСМОТР(B2;ОС!$A$2:$A$10;ОС!$C$2:$C$10))

    4. ЕСЛИ(F2="Экспл.";G2/H2;"")

    5. =ЕСЛИ(I2="";0;G2-I2)

    (ОС - основные средства)
     
  5. TimeDontWait

    TimeDontWait Well-Known Member

    Регистрация:
    4 янв 2010
    Сообщения:
    383
    Симпатии:
    0
    Ну как еще ? все элементарно.
    Обычное условие ЕСЛИ , если условие(задается первым в скобках) равно TRUE значит выполнится первое значение, если FALSE то второе
     
  6. ProstoTAK

    ProstoTAK Гость

    В самом же екселе есть примеры формул, не помогло?
     
  7. George31

    George31 New Member

    Регистрация:
    19 апр 2014
    Сообщения:
    1
    Симпатии:
    0
    Нужна помощь в решении задач:

    1. При помощи функции ЕСЛИ вычислить функцию
    x^2 при x>0
    y = { x^3 при x<0
    x+1 при x=0
    (это одна система)

    2. Ввести названия и значения координат вершин треугольника. Изобразить треугольник на соответствующей диаграмме.

    Помогите, пожалуйста :lamer:
     
Загрузка...

Поделиться этой страницей