1. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

Поступление ТМЦ" и Excel

Тема в разделе "Базы данных и администрирование", создана пользователем ViRtU, 28 сен 2004.

Статус темы:
Закрыта.
  1. ViRtU

    ViRtU Гость

    Репутация:
    0
    "Поступление ТМЦ" из полученной накладной в формате Excel. Как это сделать ? Прошу помочь :(. Профи отзовитесь :(...
     
  2. vitfil

    vitfil IT-интегратор

    Репутация:
    0
    Регистрация:
    2 апр 2004
    Сообщения:
    2.062
    Симпатии:
    0
    На форме накладной делаем кнопку "Загрузить"
    На кнопку вешаем процедуру: (тут много поскипано, но идея ясна для самостоятельной реализации).

    Процедура ЗагрузитьДанные()
    Перем Эксель, Файл, Лист;
    Перем ИмяФайла, ИмяКаталога;
    Если ФС.ВыбратьФайл(0,ИмяФайла,ИмяКаталога,"Файл для загрузки","Файлы экселя (*.xls) |*.xls","xls",60)<>1 Тогда
    Возврат;
    КонецЕсли;

    Эксел=СоздатьОбъект("Excel.Application");
    Файл=Эксел.Workbooks.Open(СокрЛП(ИмяКаталога+"\"+ИмяФайла));
    Лист=Файл.Sheets(1);

    //поскипано

    //заполним табличную часть

    НомерСтрокиТЧ=23 //строка, с которой в экселевском файле начинается табличная часть накладной
    НачатьТранзакцию();
    Для А=НомерСтрокиТЧ+1 По 1000 Цикл
    Название=СокрЛП(Лист.Cells(А,2).Value);
    // тут надо организовать поиск, например, по наименованию номенклатуры
    НоваяСтрока();

    //поскипано

    КонецЦикла;

    Эксел.WorkBooks.Close();
    Эксел.Quit();
    ЗафиксироватьТранзакцию();
    КонецПроцедуры
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей