Поступление ТМЦ" и Excel

Тема в разделе "1C и всё что с ней связано", создана пользователем ViRtU, 28 сен 2004.

Статус темы:
Закрыта.
  1. ViRtU

    ViRtU Гость

    "Поступление ТМЦ" из полученной накладной в формате Excel. Как это сделать ? Прошу помочь :(. Профи отзовитесь :(...
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    На форме накладной делаем кнопку "Загрузить"
    На кнопку вешаем процедуру: (тут много поскипано, но идея ясна для самостоятельной реализации).

    Процедура ЗагрузитьДанные()
    Перем Эксель, Файл, Лист;
    Перем ИмяФайла, ИмяКаталога;
    Если ФС.ВыбратьФайл(0,ИмяФайла,ИмяКаталога,"Файл для загрузки","Файлы экселя (*.xls) |*.xls","xls",60)<>1 Тогда
    Возврат;
    КонецЕсли;

    Эксел=СоздатьОбъект("Excel.Application");
    Файл=Эксел.Workbooks.Open(СокрЛП(ИмяКаталога+"\"+ИмяФайла));
    Лист=Файл.Sheets(1);

    //поскипано

    //заполним табличную часть

    НомерСтрокиТЧ=23 //строка, с которой в экселевском файле начинается табличная часть накладной
    НачатьТранзакцию();
    Для А=НомерСтрокиТЧ+1 По 1000 Цикл
    Название=СокрЛП(Лист.Cells(А,2).Value);
    // тут надо организовать поиск, например, по наименованию номенклатуры
    НоваяСтрока();

    //поскипано

    КонецЦикла;

    Эксел.WorkBooks.Close();
    Эксел.Quit();
    ЗафиксироватьТранзакцию();
    КонецПроцедуры
     
Загрузка...
Похожие Темы - Поступление ТМЦ Excel
  1. KiR
    Ответов:
    17
    Просмотров:
    5.577
  2. KiR
    Ответов:
    6
    Просмотров:
    2.936
  3. KiR
    Ответов:
    0
    Просмотров:
    5.062
Статус темы:
Закрыта.

Поделиться этой страницей