Поступление ТМЦ" и Excel

  • Автор темы ViRtU
  • Дата начала
Статус
Закрыто для дальнейших ответов.
V

ViRtU

#1
"Поступление ТМЦ" из полученной накладной в формате Excel. Как это сделать ? Прошу помочь :(. Профи отзовитесь :(...
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#2
На форме накладной делаем кнопку "Загрузить"
На кнопку вешаем процедуру: (тут много поскипано, но идея ясна для самостоятельной реализации).

Процедура ЗагрузитьДанные()
Перем Эксель, Файл, Лист;
Перем ИмяФайла, ИмяКаталога;
Если ФС.ВыбратьФайл(0,ИмяФайла,ИмяКаталога,"Файл для загрузки","Файлы экселя (*.xls) |*.xls","xls",60)<>1 Тогда
Возврат;
КонецЕсли;

Эксел=СоздатьОбъект("Excel.Application");
Файл=Эксел.Workbooks.Open(СокрЛП(ИмяКаталога+"\"+ИмяФайла));
Лист=Файл.Sheets(1);

//поскипано

//заполним табличную часть

НомерСтрокиТЧ=23 //строка, с которой в экселевском файле начинается табличная часть накладной
НачатьТранзакцию();
Для А=НомерСтрокиТЧ+1 По 1000 Цикл
Название=СокрЛП(Лист.Cells(А,2).Value);
// тут надо организовать поиск, например, по наименованию номенклатуры
НоваяСтрока();

//поскипано

КонецЦикла;

Эксел.WorkBooks.Close();
Эксел.Quit();
ЗафиксироватьТранзакцию();
КонецПроцедуры
 
Статус
Закрыто для дальнейших ответов.