Позитивчик

  • Автор темы kaa
  • Дата начала
Статус
Закрыто для дальнейших ответов.
K
#1
Предлагаю отдохнуть кто-что веселого встречал в модулях 1С :) :
пару лет назад в ЗиКе(стандарт) в глобальном модуле комментарий //Этот кусок обязательно проверить надо!!!
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#2
Код:
Если ... Тогда
...
Иначе //Хер его знает, почему условие может не выполниться
Сообщить("Срочно обратитесь к программисту!");
Сообщить("Сообщите ему номер документа!");
Сообщить("Документ сохраните без проведения!");
КонецЕсли;
Вот так люди перекладывают обязанности тестинга на пользователей. :)

Тему "закрепляю"! В теме располагать ТОЛЬКО юмор так или иначе связанный с 1С. Все остальные сообщения будут нещадно удаляться.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#3
ну... незнаю насколько юморно, на ваш вкус - если что не обижусь за удаление...
так вот я периодически когда пишу код, набрасывая сетку модуля, особенно если есть проверки выдаю сообщения типа "все плохо!" и "тут нада дописать что делать в случае успеха"... правда потом сам это дело обычно удаляю...

Комментарий Админа:
Я, несмотря на свои монархические взгляды, не вправе решать, что считать смешным, а что - нет. Удалять буду любые попытки пошутить без упоминания 1С. Если расскажите смешной случай про пользователя, который приключился с ним во время работы с 1С, это проходит. Если же будет повествование про "тупого буха" и попытка притянуть "за уши" ситуацию типа "бухгалтера же работают в 1С", будет удалено.
 
K
#4
в отчете видел
Код:
Попытка
Исключение
Сообщить("Не запланированный взрыв процессора!! Отойдите от компьютера! Сообщите программисту!");
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#5
Вот еще вспомнил:
Обработка загрузки данных из клиент-банка.
Код:
Если ДатаЗагрузки.Выбран() = 0 Тогда
Предупреждение("Лена, ты опять забыла указать дату загрузки!",60);
Возврат;
Самое интересное, что девушка, которая загружала выписки, спрашивала у меня: "А как компьютер определяет, что именно я загружаю выписки, а не кто-то другой?".

Еще такое сам писал:
Код:
Предупреждение("Выгрузка необычайно успешно завершена, моя белая госпожа!");
 

puh14

Well-known member
11.07.2008
1 412
0
#6
на первое апреля написал для склада (знал тогда мало, счас бы по другому сделал) так как коллектив чисто женский


Вопрос("Внимание! Дополнительная мера безопасности! Ответьте на вопрос - какой у Вас размер бюста? Замечательный! / Никто не жаловался / Не скажу");
ВвестиСтроку(Ответ,"Введите ответ тут!",25,,);
Если Ответ = "Замечательный!" Тогда
Предупреждение("Так держать! С 1-ым апреля!");
ИначеЕсли Ответ = "Никто не жаловался" Тогда
Предупреждение("Проверим! С 1-ым апреля!");
иначеЕсли Ответ = "Не скажу" Тогда
Предупреждение("Нехорошо скрывать от коллектива! с 1-ым апреля!");
Иначе
Предупреждение("Не шалите! Введите ТОЧНО как из предложенных вариантов ответа:Замечательный! / Никто не жаловался /Не скажу");
СтатусВозврата(0);
Возврат;
КонецЕсли;
 

vbs

Well-known member
18.02.2007
1 708
1
#7
Вопрос("Внимание! Дополнительная мера безопасности! Ответьте на вопрос - какой у Вас размер бюста? Замечательный! / Никто не жаловался / Не скажу");
Конечно, строки ответов надо было вывести в список значений - тогда либо выбрал из трех, либо не выбрал...
 

puh14

Well-known member
11.07.2008
1 412
0
#8
ну да- только тогда я с 1с работал меньше месяца, и почти ничего не умел.
 

unknown181538

НеГуру
28.12.2008
1 417
0
#9
Из типового ТиС ert выгрузки 8.7 - 9.2. Подозреваю, что этот комментарий не один релиз болтается.
<!--shcode--><pre><code class='C++'> // над этим еще нужно поработать...

//гСписокОбработанныхПравил.ДобавитьЗначение(ИдПравила);
//Поз = гСписокНеобработанныхПравил.НайтиЗначение(ИдПравила);
//Если ПустоеЗначение(Поз) = 0 Тогда
// гСписокНеобработанныхПравил.УдалитьЗначение(Поз);
//КонецЕсли;

//Если ФормФлЗапоминатьСсылки = 0 Тогда
// СписокВыгруженныхОбъектов = СписокСписковВыгруженныхОбъектов.Получить(ИдПравила);
// Поз = СписокСписковВыгруженныхОбъектов.НайтиЗначение(СписокВыгруженныхОбъектов);
// Если ПустоеЗначение(Поз) = 0 Тогда
// СписокСписковВыгруженныхОбъектов.УдалитьЗначение(Поз);
// КонецЕсли;
//КонецЕсли;[/CODE]

<!--shcode--><pre><code class='1С'>// Например,
// глРазложить(",ку,,,му", ",") возвратит список значений из пяти элементов,
// три из которых - пустые строки, а
// глРазложить(" ку му", " ") возвратит список значений из двух элементов[/CODE]
Такие вот странные строки раскладывают ТиСовцы в глобальном модуле.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#10
вот знакомая одна надыбала (присылаю переписку):

Эльф (14:09:05 27/05/2011)
комментарий в одном из документов "не нажимайте заполнить! потом сами вручную выправлять будете"

KiR (14:10:55 27/05/2011)
это ты где такое наглядела?

Эльф (14:11:05 27/05/2011)
формирование записей книги покупок
 

Дайнеко

Well-known member
19.11.2009
951
0
#11
А я сделал в 1С звуки. Только воспроизводит программа не "пи-пи" и прочие свистки, а цитаты из старых фильмов, мультов. Применяю 3-мя категориями:
* просто предупреждение. Например, очень удобно, когда программа свернута, а там выскочило входящее сообщение. Выдает реплики типа "Клиент прибыл", "Доброе утро, Ипполит Матвеич", "Киргуду" и т.п.
* ругалово. Это уже реакция на действия пользователя. Здесь посуровей: "Буду бить аккуратно но сильно", "Закусывать надо". Скажу о пользователе что думаю - "Нехороший ты человек - злой", до серьезного голоса Папанова "Чтоб ты сдох!".
* категория фоновых. Это выглядит так. Сидит человек работает, даже клавиш не нажимает. Тут вдруг голос - "Бог в помощь", "И где, интересно знать, мой шарик", "Щас спою". Или мелодия из Ш.Холмса. Иногда вскакивают на стуле.

Самое важно, что все файлы проигрываются по случайному порядку. Т.е. в программе перед Предупреждение() я пишу вызов процы проигрывания звука. У нее параметр - категория (Ругалово, к примеру). А программа сама выбирает звук из 30-40 возможных для этой категории. Т.о. наступая на одни грабли получишь разные матюки.

Особняком стоит фоновая категория. Долго шлифовал, однако. Во-первых, она проигрывает в случайное время после 2-х часов работы.
Может и не вызываться за день. Во-вторых, отыграв 1 раз, в течение остатка дня будет молчать. А т.к. фоновых звуков записал 56 (можно добавлять), то даже опытному пользователю (не делает ошибок, не получает сообщений) не надоедает.

Реакция людей очень различна. Большинство воспринимает нормально. Некоторые напоминают: "А на том компе говорила. Включите". Но найдется и один на десяток, чопорно просят убрать "гадости какие-то". Наблюдение показало, это те, кто делает много ошибок.
 
H
#12
В конфе с которой сейчас работаю:

Сообщить("Негоже, госпожа "+Автор+" проводить документы задним числом!!!");
Сообщить("Жуть!!! "+Автор+", Куда смотрит ваше руководство, что же вы творите!!!");
Сообщить("Нельзя так делать, "+Автор+", стыдно должно быть, проводить документы задним числом!!!");
Сообщить("Что же ты творишь, "+Автор+", знало бы про твои махинации руководство, проводить документы задним числом!!!");

и т.п. <_<
 

Дайнеко

Well-known member
19.11.2009
951
0
#13
Hryv! Восхищен, сударь, вашей деликатностью.
Мои Предупредить() чуть жестче:
"За такое название и по рукам можно дать" (некрасивое название организации)
"Покрасивей надо!"
"Тугодум - твое имя" (программа не дождалась ответа)
"Можете не стараться - дата закрыта для ввода"
"От винта!" (закрыт раздел)

И, ничего. Терпят, сердешные.
 

Дайнеко

Well-known member
19.11.2009
951
0
#15
Да ничего сверхестественного. Придираюсь к
1) номерам документов символьного типа, но с автонумерацией. Зараза-пользователь как напишет буковку в конце, так 1С перестает наращивать номер. Еще критично вместо предлагаемого программой "0003" вумнички исправляют на "3". Нумерует 1С только до 9. Вот за это по рукам.
2) В кратком названии плавающую подсказку (не знаю, как она правильно, при наведении мыши появляется, желтого цвета) пишу по-русски: "Советую не набирать ООО, ЗАО, .... ". Как вы думаете? Видят? За это по голове.
3) А еще у меня маразм такой - первую буковку в названии люблю Большую. Скажите! Тяжело набрать? За это без тяжких телесных, программа просто ругнется и сама исправит.
4) Есть много за что бить и ругать любимых клиентов.
 

puh14

Well-known member
11.07.2008
1 412
0
#17
Свежачок - пришла недавно бухгалтерия и попросила чтобы в складской УТ материалка (самопись) выглядела так-же как у неё оборотка по на сорок первом счете. Сделал ей настроечку, сохранил под именем "как в 41-ом". Слышу, сзади хмыкают. Прочитал, представил... решили так и оставить - звучащее название.
 

vbs

Well-known member
18.02.2007
1 708
1
#18
У меня похожая ситуация - на форме отчета радиокнопка с вариантами печати (кратко, подробно и т.п.)
Одна из бухгалтеров попросила для себя нестандартную форму (типа учет товаров только без цены). Я ее обозвал "Для (фамилия)".
Похихикали, но отнеслись с уважением и привыкли. Потом ей понадобилась форма, где товары только с ценой.
Теперь этот отчет в фирме называют "Как женщина попросит"
 

Darlock

Well-known member
04.01.2008
560
1
#19
Формирование движений по регистру накопления конфигурация одного из партнеров 1С.

НоваяЗапись.ВидДвижения = ВидДвиженияНакопления.Приход;
НоваяЗапись.СуммаУпр = Окр(-Выборка.СуммаУпр, 2);
СуммаДоходаРасходаСуммовыхРазниц = СуммаДоходаРасходаСуммовыхРазниц + НоваяЗапись.СуммаУпр;
КонецЕсли;
НоваяЗапись.Сумма = 0;
// определяемся с хоз. операцией
НоваяЗапись.ХозОперация = ДокументОбъект.ХозОперация;
// ПОДЛЕЖИТ ИСПРАВЛЕНИЮ FEDY
// ДОБАВИТЬ РЕСУРС "ВидОперации" и туда пихать всякие смешные значения
КонецЦикла;
// 3. Если осталась нераспределенная сумма...
Если СуммаВзаиморасчетов>=0.01 Тогда
// посмотрим, запрещена ли по данному документу переплата. и если не запрещена, то паааааадаааааееееем
Попытка

--------------------------------
в тойже конфе, но уже в справочнике:

ЛатинскиеБуковки = "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
КириллическиеБуковки = "АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЬЫЪЭЮЯ";
Цифирьки = "1234567890";
 
Статус
Закрыто для дальнейших ответов.