Предел вычетов

  • Автор темы yullevick
  • Дата начала
Y

yullevick

#1
Хочу продолжить однажды поднятый вопрос!
Программа 1С:Бухгалтерия (не кадры)общая.
Как изменить предел вычета по детским с 40000 до 280000 рублей?
За ранее благодарна.
 

gorlanovmax

Well-known member
19.06.2008
286
0
#2
Открываем конфигуратор
Документ.НачислениеЗП
Открываем Модуль документа
Ищем следующий код:

Код:
Если глСотрудникЧислитсяРаботающим(Сотрудник, БухИт.НачДата) = 1 Тогда
Вычеты = 0;
ТипВычета = Сотрудник.ТипВычета.Получить(БухИт.КонДата);	
Если ДатаГод(ДатаДок) < 2005 Тогда
ПределВычетов1 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ПределВычетов2 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ИначеЕсли ДатаГод(ДатаДок) > 2005 Тогда
ПределВычетов1 = 20000;
ПределВычетов2 = 40000;
КонецЕсли;
Меняем его на такой код:
Код:
Если глСотрудникЧислитсяРаботающим(Сотрудник, БухИт.НачДата) = 1 Тогда
Вычеты = 0;
ТипВычета = Сотрудник.ТипВычета.Получить(БухИт.КонДата);	
Если ДатаГод(ДатаДок) < 2005 Тогда
ПределВычетов1 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ПределВычетов2 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ИначеЕсли (ДатаГод(ДатаДок) > 2005) И (ДатаГод(ДатаДок) < 2009) Тогда
ПределВычетов1 = 20000;
ПределВычетов2 = 40000;
Иначе
ПределВычетов1 = 40000; 
ПределВычетов2 = 280000;	 
КонецЕсли;
 
Y

yullevick

#4
Открываем конфигуратор
Документ.НачислениеЗП
Открываем Модуль документа
Ищем следующий код:

Код:
Если глСотрудникЧислитсяРаботающим(Сотрудник, БухИт.НачДата) = 1 Тогда
Вычеты = 0;
ТипВычета = Сотрудник.ТипВычета.Получить(БухИт.КонДата);	
Если ДатаГод(ДатаДок) < 2005 Тогда
ПределВычетов1 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ПределВычетов2 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ИначеЕсли ДатаГод(ДатаДок) > 2005 Тогда
ПределВычетов1 = 20000;
ПределВычетов2 = 40000;
КонецЕсли;
Меняем его на такой код:
Код:
Если глСотрудникЧислитсяРаботающим(Сотрудник, БухИт.НачДата) = 1 Тогда
Вычеты = 0;
ТипВычета = Сотрудник.ТипВычета.Получить(БухИт.КонДата);	
Если ДатаГод(ДатаДок) < 2005 Тогда
ПределВычетов1 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ПределВычетов2 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ИначеЕсли (ДатаГод(ДатаДок) > 2005) И (ДатаГод(ДатаДок) < 2009) Тогда
ПределВычетов1 = 20000;
ПределВычетов2 = 40000;
Иначе
ПределВычетов1 = 40000; 
ПределВычетов2 = 280000;	 
КонецЕсли;




ОГРОМНОЕ СПАСИБО!!!! ЦЕЛУЮ!!!
 

vbs

Well-known member
18.02.2007
1 708
1
#5
Если ДатаГод(ДатаДок) < 2005 Тогда
ПределВычетов1 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ПределВычетов2 = Константа.ПределВычетов.Получить(БухИт.КонДата);
ИначеЕсли (ДатаГод(ДатаДок) > 2005) И (ДатаГод(ДатаДок) < 2009) Тогда
ПределВычетов1 = 20000;
ПределВычетов2 = 40000;
А в самОм 2005 году в таком варианте какие пределы вычетов будут ?