При печати выходит пустая страница

Статус
Закрыто для дальнейших ответов.

Спартак

Well-known member
02.05.2009
69
0
#1
Доброго времени суток, уважаемые.
До меня в компании был программист. Он сделал в бухе 7-ке новый документ и печатную форму к нему. Проблема в том, при при выводе на печать выходит одна лишняя пустая страница. Уже пересмотрел все, что только можно ;)
Может кто сталкивался с такой проблемой? Подскажите
 
K
#2
а при печати из других документов нет лишнего листа?
 

Renat11111

Well-known member
20.04.2008
123
0
#3
Найдите таб документ в конфигураторе в какой то секции есть неиспользуемы строки или колонки удалите их все должно быть хорошо.
 

Спартак

Well-known member
02.05.2009
69
0
#4
а при печати из других документов нет лишнего листа?
нету

Найдите таб документ в конфигураторе в какой то секции есть неиспользуемы строки или колонки удалите их все должно быть хорошо.
нету :(
макет прилагаю ;)

Найдите таб документ в конфигураторе в какой то секции есть неиспользуемы строки или колонки удалите их все должно быть хорошо.
нету :(
макет прилагаю ;)
 

Вложения

  • 118.4 КБ Просмотры: 47

puh14

Well-known member
11.07.2008
1 412
0
#5
в параметрах страницы что стоит - процент или подогнать по размеру?
 

Спартак

Well-known member
02.05.2009
69
0
#7
в параметрах страницы что стоит - процент или подогнать по размеру?
по ширине страницы

Разместите печ форму сделаю верну обратно.
выложил макет во внешнюю обработку. только поменяйте разрешение на ert. говорит, что нельзя мне загружать такие типы файлов ))
 

Вложения

puh14

Well-known member
11.07.2008
1 412
0
#8
попробуй уменьшить поля и колонтитулы

в процедуре печати не встречается что-то типа НоваяСтраница?

кстати - попробуй печатать на разных принтерах - мож в дело в настройках конкретного принтера.
 

Renat11111

Well-known member
20.04.2008
123
0
#9
расширение поменял. но ошибку дает все равно. скинь на мыло не меняя расширение betek-az@rambler.ru
 

Спартак

Well-known member
02.05.2009
69
0
#10
попробуй уменьшить поля и колонтитулы

в процедуре печати не встречается что-то типа НоваяСтраница?

кстати - попробуй печатать на разных принтерах - мож в дело в настройках конкретного принтера.
пробовал - та же ситуация. даже в предварительном просмотре показывает 2 страницы. одна - пустая

расширение поменял. но ошибку дает все равно. скинь на мыло не меняя расширение betek-az@rambler.ru
отправил
 
H
#11
с макетом все в порядке, надо код процедуры смотреть
 

Renat11111

Well-known member
20.04.2008
123
0
#12
ВО ПЕРВЫХ У ТЕБЯ пустая процедура как ты вообще хоть одну страницу выводишь я не знаю

Процедура Сформировать()

КонецПроцедуры

Во вторых после секции подвал внизу идет пунктирная линия, удали все строки до этой пунктирной линии. не получится будь добр вставь в процедуру что нибудь и вышли на мыло еще раз.
 

puh14

Well-known member
11.07.2008
1 412
0
#13
пробовал - та же ситуация. даже в предварительном просмотре показывает 2 страницы. одна - пустая
тогда надо смотреть метод параметрыСтраницы() в модуле - тамошние параметры всё перебивают.
 

Спартак

Well-known member
02.05.2009
69
0
#14
ВО ПЕРВЫХ У ТЕБЯ пустая процедура как ты вообще хоть одну страницу выводишь я не знаю

Процедура Сформировать()

КонецПроцедуры

Во вторых после секции подвал внизу идет пунктирная линия, удали все строки до этой пунктирной линии. не получится будь добр вставь в процедуру что нибудь и вышли на мыло еще раз.
я просто выделил макет и вставил его во внешнюю обработку. в родной конфе такой линии нет. По поводу пустой процедуры - я же говорю, я просто выделил весь макет и вставил его в НОВУЮ внешнюю обработку. Вообще в конфигурации это документ с печатной формой. В 7-ке по-моему нет такой возможности, как экспорт во внешнюю обработку
 
H
#15
Спартак, просто на форум (в виде поста) выложи процедуру, которая печатает
 

Спартак

Well-known member
02.05.2009
69
0
#16
Процедура Печать()

НомерДокПечатнойФормы = глПреобразоватьНомерДок(НомерДок, 0, 0);

Таб = СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Таблица");


ВерхнийКолонтитул = "Пропуск сформирован "+ТекущаяДата()+" "+ТекущееВремя()+?(ПустоеЗначение(ИмяПользователя())=0," Пользователь: "+ИмяПользователя(),"");
Пока ПолучитьСтроку()=1 Цикл
Если ТипЗначенияСтр(Товар) = "Справочник" Тогда
Если Товар.Вид() = "Номенклатура" Тогда
Если (Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Услуга) или
(Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Работа) или
(Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.ПосредническаяУслуга) или
(Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.УслугаЕНВД) Тогда
Продолжить;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;

Таб.ВывестиСекцию("Шапка|Гор");

Если Профнастил = 1 Тогда
Профнастил=1;
Таб.ПрисоединитьСекцию("Шапка|ПрофнастилКол");
Иначе
Таб.ПрисоединитьСекцию("Шапка|ШиферКол");
КонецЕсли;

// Печать строк документа.
ВыбратьСтроки();
Ном=0;
Пока ПолучитьСтроку()=1 Цикл
Ном=Ном+1;
Если ТипЗначения(Товар) = 2 Тогда
Наименование = Товар;
ЕдиницаИзмерения = "";

ИначеЕсли Товар.Вид() = "Номенклатура" Тогда
Наименование = ?(ПустаяСтрока(Товар.ПолнНаименование)=1, Товар.Наименование, Товар.ПолнНаименование);
ЕдиницаИзмерения = Товар.ЕдиницаИзмерения;

ИначеЕсли Товар.Вид() = "ОсновныеСредства" Тогда
Наименование = Товар.Наименование;
ЕдиницаИзмерения = "";

ИначеЕсли Товар.Вид() = "НематериальныеАктивы" Тогда
Наименование = Товар.Наименование;
ЕдиницаИзмерения = "";

ИначеЕсли Товар.Вид() = "Материалы" Тогда
Наименование = Товар.Наименование;
ЕдиницаИзмерения = Товар.ЕдиницаИзмерения;
КонецЕсли;
ПечДлинаЛиста = ?(ДлинаЛиста > 0, Формат(ДлинаЛиста,"Ч015.3"), "---");
ПечКоличествоПроф = ?(КоличествоПроф > 0, Формат(КоличествоПроф,"Ч015.3")+" ("+ЧислоПрописью(КоличествоПроф)+")", "---");
ПечКоличество = ?(Количество > 0, Формат(Количество,"Ч015.3")+" ("+ЧислоПрописью(Количество)+")", "---");
Таб.ВывестиСекцию("Строка|Гор");

Если Профнастил = 1 Тогда
Таб.ПрисоединитьСекцию("Строка|ПрофнастилКол");
Иначе
Таб.ПрисоединитьСекцию("Строка|ШиферКол");
КонецЕсли;
КонецЦикла;

Таб.ВывестиСекцию("Подвал_1|Гор");

Если Профнастил = 1 Тогда
Профнастил = 1;
Таб.ВывестиСекцию("Профнастил");
КонецЕсли;

Таб.ВывестиСекцию("Подвал_2");


Таб.Опции(0,0,0,0,"ОпцииПечатиПропуск");
Таб.ТолькоПросмотр(1);
Таб.Показать("Печать пропуска","");
// Таб.КоличествоЭкземпляров(2);

КонецПроцедуры // Печать()
 
H
#17
Возвращаемся к макету
Так как в процедуре указана масса секций, которых нет в таблице
Значит, скорее всего, в качестве макета используется другая таблица

У документа только одна таблица или несколько?
Обрати внимание на строку
Таб.ИсходнаяТаблица("Таблица");
 

Спартак

Well-known member
02.05.2009
69
0
#19
ааа... прошу прощения... я не тот макет выложил ))) там 2 пропуска сделали :)
Вот выкладываю нужный макет ))

скажи как таблица называется.
так и наывается... "Таблица" :) она там одна
 

Вложения

puh14

Well-known member
11.07.2008
1 412
0
#20
Мож поля ему не нравятся...

попробуй убрать в секции подвал_2 две нижних пустых строчки и задать програмно параметры страницы.

примерно так для портретной ориентации, поля по 5 мм, верхний колонтитул 6 мм, нижний 0. Автомасштаб включен
добавить рядом с опциями, но перед показать().
таб.ПараметрыСтраницы(1,,,5,5,5,5,6,0,1,0,);
 
Статус
Закрыто для дальнейших ответов.