1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Присваивание значения элементам формы в цикле

Тема в разделе "Базы данных и администрирование", создана пользователем CfK, 10 окт 2008.

  1. CfK

    CfK Гость

    Репутация:
    0
    ситуация следующая

    Если не ПоставщикПоУмолчанию=Справочники.Контрагенты.ПустаяСсылка() тогда
    ПоУмолчанию=ЭлементыФормы.Найти("ПоставщикПоУмолчанию");
    сообщить(строка(ПоУмолчанию.Значение));

    Для с=0 по ЭлементыФормы.ПанельОбъектУчета.Страницы.Количество() цикл
    Если с=0 тогда
    Поставщик=ПоставщикПоУмолчанию;
    Иначе
    П=ЭлементыФормы.Найти("Поставщик"+Строка(с));
    П.Значение=ПоУмолчанию.Значение; //вопрос здесь - как присвоить правильно? ни .значение ни .данные не работает
    КонецЕсли;
    КонецЦикла;
    КонецЕсли

    Тип Элемента формы - поле ввода, тип значения - справочник ссылка, у всех ЭлементовФормы начинающихся с "поставщик" типы совпадают с типами "ПоставщикПоУмолчанию". На каждой странице есть елемент "Поставщик"+ИндексСтраницы

    Необходимо:
    Чтобы у всех поставщиков были значение ПоставщикПоУмолчанию. (СправочникССылка.Контрагенты) т.е. один и тот же елемент справочника.
     
Загрузка...

Поделиться этой страницей