Присваивание значения элементам формы в цикле

  • Автор темы CfK
  • Дата начала
C

CfK

Гость
#1
ситуация следующая

Если не ПоставщикПоУмолчанию=Справочники.Контрагенты.ПустаяСсылка() тогда
ПоУмолчанию=ЭлементыФормы.Найти("ПоставщикПоУмолчанию");
сообщить(строка(ПоУмолчанию.Значение));

Для с=0 по ЭлементыФормы.ПанельОбъектУчета.Страницы.Количество() цикл
Если с=0 тогда
Поставщик=ПоставщикПоУмолчанию;
Иначе
П=ЭлементыФормы.Найти("Поставщик"+Строка(с));
П.Значение=ПоУмолчанию.Значение; //вопрос здесь - как присвоить правильно? ни .значение ни .данные не работает
КонецЕсли;
КонецЦикла;
КонецЕсли

Тип Элемента формы - поле ввода, тип значения - справочник ссылка, у всех ЭлементовФормы начинающихся с "поставщик" типы совпадают с типами "ПоставщикПоУмолчанию". На каждой странице есть елемент "Поставщик"+ИндексСтраницы

Необходимо:
Чтобы у всех поставщиков были значение ПоставщикПоУмолчанию. (СправочникССылка.Контрагенты) т.е. один и тот же елемент справочника.