Присваивание значения элементам формы в цикле

Тема в разделе "1C и всё что с ней связано", создана пользователем CfK, 10 окт 2008.

Наш партнер Genesis Hackspace
  1. CfK

    CfK Гость

    ситуация следующая

    Если не ПоставщикПоУмолчанию=Справочники.Контрагенты.ПустаяСсылка() тогда
    ПоУмолчанию=ЭлементыФормы.Найти("ПоставщикПоУмолчанию");
    сообщить(строка(ПоУмолчанию.Значение));

    Для с=0 по ЭлементыФормы.ПанельОбъектУчета.Страницы.Количество() цикл
    Если с=0 тогда
    Поставщик=ПоставщикПоУмолчанию;
    Иначе
    П=ЭлементыФормы.Найти("Поставщик"+Строка(с));
    П.Значение=ПоУмолчанию.Значение; //вопрос здесь - как присвоить правильно? ни .значение ни .данные не работает
    КонецЕсли;
    КонецЦикла;
    КонецЕсли

    Тип Элемента формы - поле ввода, тип значения - справочник ссылка, у всех ЭлементовФормы начинающихся с "поставщик" типы совпадают с типами "ПоставщикПоУмолчанию". На каждой странице есть елемент "Поставщик"+ИндексСтраницы

    Необходимо:
    Чтобы у всех поставщиков были значение ПоставщикПоУмолчанию. (СправочникССылка.Контрагенты) т.е. один и тот же елемент справочника.
     
Загрузка...
Похожие Темы - Присваивание значения элементам
  1. orion
    Ответов:
    1
    Просмотров:
    1.148
  2. JohnLemon
    Ответов:
    13
    Просмотров:
    1.698
  3. Kaiser
    Ответов:
    0
    Просмотров:
    259
  4. Hehabr
    Ответов:
    1
    Просмотров:
    774
  5. Shouldercannon
    Ответов:
    0
    Просмотров:
    561

Поделиться этой страницей