Private Lan For A Cluster

Wanderer

Well-Known Member
Lotus team
23.03.2006
407
16
37
Москва
#1
Добавил и настроил в кластере дополнительный порт (TCPCluster) для общения кластерных серверов через вторую сетевую карточку напрямую. Всё сделал по хелпу с одноименным топиком за исключением разве что перезагрузки сервера - просто рестартовал новый кластерный порт. Тем не менее, в консоли сервера наблюдаю следующую ошибку:
02/12/2007 11:34:54 AM Error on Listen function: The requested TCP/IP port is in use on this system.
02/12/2007 11:34:54 AM Listener task for port TCPCluster is suspending for 20 seconds due to listen errors
В чем может быть причина? Обязательна ли перезагрузка сервера, если show port в консоли показывает, что сервер подхватил этот новый порт (хоть и не использует его):
sh port TCPCluster
TCP/IP Port Driver
Transport Provider: TCP
Notes Session Local Address Foreign Address
4B90000B 192.168.xx.2:40554 192.168.xx.1:1352
2DEA0020 192.168.xx.2:40555 192.168.xx.1:1352
 

Constantin A Chervonenko

Well-Known Member
Lotus team
#2
Добавил и настроил в кластере дополнительный порт (TCPCluster) для общения кластерных серверов через вторую сетевую карточку напрямую. Всё сделал по хелпу с одноименным топиком за исключением разве что перезагрузки сервера - просто рестартовал новый кластерный порт. Тем не менее, в консоли сервера наблюдаю следующую ошибку:
ЧистА по аналогии: клиент доп.порты без перезапуска точно не подхватывает...
 
F

Fossil Code

Гость
#3
А) Практика показывает, что единственная причина честно сообщается системой: какая-то программа уже "слушает" данный порт. Сей факт можно проверить при помощи netstat или tcpview.

Б) Лучше все-таки перегрузить сервер. Причем вместе с операционкой. Две карточки, две сети... Нужны Вам "тонкие" глюки? Если ситуевина повторится, то однозначно -- пункт А)
 

Wanderer

Well-Known Member
Lotus team
23.03.2006
407
16
37
Москва
#4
Не буду плодить новые темы, напишу здесь, т.к. проблемы, на мой взгляд, возникли при объединении серверов в кластер.
Уже который понедельник возникают проблемы с с одним из серверов кластера. Ровно в 10 часов утра. Он, грубо говоря, зависает.. минут на 10. Но тем не менее, он функционирует - на второй сервак кластера запросы клиентов не перебрасываются, а просто все висят в ожидании. Через какое-то время сервер потихоньку разгружается, отвисает и сам возвращается в работу.
В логах зависшего сервера ничего вразумительного не нахожу. Кроме как ошибку сбоя при попытке коннекта с другими серваками:
Error connecting to server xxx/ууу/zzz: Lite transaction attempted over passthru