Проблема графики в Turbo C++

  • Автор темы dubin
  • Дата начала
D

dubin

#1
Встретился с очень интересной проблемой, после инициализации графики на Turbo C++ 3.1, появляется черный экран, то в самой среде не как не удается инициализировать графику. Само приложение как бы дохнет, то есть не грузит процессор вообще. Инициализирую графику с помощью команд gdriver = DETECT; initgraph(&gdriver, &mode, ""); Для инициализации используется библиотека EGAVGA.BGI. Пробовал сменить windows не помогло, также смена видеокарты не дало положительного результат. Сам не первый год в программировании, но с таким столкнулся впервые. Также создаю exe файл на чужом компьютере, там все работает, на моей же машине этот экзешник отказывается работать.. Также может быть дело в том что у меня PCI-E v2.0.
 
S

sg^_^milytia

#2
Встретился с очень интересной проблемой, после инициализации графики на Turbo C++ 3.1, появляется черный экран, то в самой среде не как не удается инициализировать графику. Само приложение как бы дохнет, то есть не грузит процессор вообще. Инициализирую графику с помощью команд gdriver = DETECT; initgraph(&gdriver, &mode, ""); Для инициализации используется библиотека EGAVGA.BGI. Пробовал сменить windows не помогло, также смена видеокарты не дало положительного результат. Сам не первый год в программировании, но с таким столкнулся впервые. Также создаю exe файл на чужом компьютере, там все работает, на моей же машине этот экзешник отказывается работать.. Также может быть дело в том что у меня PCI-E v2.0.
а ты приведи текст исходника а мы посмотрим, может кто-тосталкивался ужо с таким баГгом!