1. Спонсор публикаций Marketplace codeby. Сервис, который так долго ждали. При расчетах используем биткоин. Первый товар уже в продаже: Консультация на тему ИБ от Ondrik8

    Скрыть объявление
  2. Спонсор публикаций Marketplace codeby. Сервис, который так долго ждали. При расчетах используем биткоин. Второй товар маркетплейса: Надёжная обфускация вашей программы от PingVinich

    Скрыть объявление

Проблема при установке IPBoard v1.1.2

Тема в разделе "SQL", создана пользователем Jack`s Lost Heart, 8 дек 2003.

Статус темы:
Закрыта.
  1. Jack`s Lost Heart

    Jack`s Lost Heart Гость

    Репутация:
    0
    CREATE TABLE ibf_messages (
    ...
    vid varchar(32) default NULL,
    ...
    KEY vid (vid)
    );

    При установке возникает сообщение:
    mySQL Error: Column 'vid' is used with UNIQUE or INDEX but is not defined as NOT NULL

    В чем проблема?
     
  2. Belfisher

    Belfisher Гость

    Репутация:
    0
    Попробуй так :blink:
    Код (Text):
    CREATE TABLE ibf_messages (
    ...
    vid varchar(32) default NOT NULL,
    ...
    KEY vid (vid)
    );
     
  3. admin

    admin Well-Known Member

    Репутация:
    0
    Регистрация:
    8 авг 2003
    Сообщения:
    2.755
    Симпатии:
    1
    Jack`s Lost Heart
    Скачай отсюда нормальную версию 1.2. Устанавливай как написано в инструкции и всё будет OK.
     
  4. Jack`s Lost Heart

    Jack`s Lost Heart Гость

    Репутация:
    0
    <!--QuoteBegin-Belfisher+8:12:2003, 16:16 -->
    <span class="vbquote">(Belfisher @ 8:12:2003, 16:16 )</span><!--QuoteEBegin-->Попробуй так <_<
    Код (Text):
    CREATE TABLE ibf_messages (
    ...
    vid varchar(32) default NOT NULL,
    ...
    KEY vid (vid)
    );
    [/quote]
    Тут дело скорее в базе чем в коде. Я переставил mysql с 3.22.32 на 4.06 и все заработало.
    Но все равно спасибо.
     
  5. Jack`s Lost Heart

    Jack`s Lost Heart Гость

    Репутация:
    0
    <!--QuoteBegin-Серёга+8:12:2003, 20:29 -->
    <span class="vbquote">(Серёга @ 8:12:2003, 20:29 )</span><!--QuoteEBegin-->Jack`s Lost Heart
    Скачай отсюда нормальную версию 1.2. Устанавливай как написано в инструкции и всё будет OK.[/quote]
    Новая версия сразу видно получше, но от ошибки в базе все равно не спасла. Спасибо за совет.
     
  6. admin

    admin Well-Known Member

    Репутация:
    0
    Регистрация:
    8 авг 2003
    Сообщения:
    2.755
    Симпатии:
    1
    Jack`s Lost Heart
    конечно 3.22 старовата
    надо минимум 3.23.58 для этого форума.
     
Загрузка...
Похожие Темы - Проблема при установке
  1. Denybxx
    Ответов:
    5
    Просмотров:
    1.037
  2. Artael
    Ответов:
    1
    Просмотров:
    241
  3. forestLeet
    Ответов:
    1
    Просмотров:
    277
  4. thunder
    Ответов:
    53
    Просмотров:
    1.481
  5. Smorti
    Ответов:
    1
    Просмотров:
    323
Статус темы:
Закрыта.

Поделиться этой страницей