Проблема ретривера

Тема в разделе "Lotus - Программирование", создана пользователем -, 29 янв 2008.

  1. Гость

    Репутация:
    0
    Проблема такова: серверный ретривер игнорирует логин и пароль, которые передаются в методе GetDocumentByURL и вместо того, чтобы скачать страницу, качает окно регистрации. С локальным клиентским ретривером такой проблемы не было ни с бейсик, ни с сессионной авторизацией. База Server Web Navigator создана в R5, не знаю, может, проблема в этом. Кто подскажет ?
     
  2. Sandr

    Sandr Гость

    Репутация:
    0
    А может у пользователя с заданным логином паролем просто нет доступа?

    Как вызываете GetDocumentByURL?

    И, кстати, а от чьего имени отрабатывает GetDocumentByURL? Пользователь выполняющий этот метод должен иметь право создания документов в БД из которой вызываете GetDocumentByURL...
     
  3. Гость

    Репутация:
    0
    У пользователя с заданным логином и паролем точно есть доступ, так как я и являюсь этим пользователем :) Запуск ретривера осуществляется от имени сервера, аналогичные действия с локальным ретривером (от моего имени) не вызывают нареканий, страница закачивается, однако при запуске на сервере к закачиванию доступны только открытые страницы..Кроме того, сервер генерит ошибку: "WEB(2): Unable to find design note for view 'Cookies': Entry not found in index" Видимо, база Server Web Navigator либо неправильно настроена, либо вся эта канитель из-за того, что она рефрешится с пятерочного шаблона, есть у меня такое предположение..Видимой разницы между Server Web Navigator и Personal Web Navigator, через которую ходит локальный ретривер, я не заметил, так что гипотез больше не имею (

    NDB_Current.GetDocumentByURL, где NDB_Current - текущая база (не Server Web Navigator и не Personal Web Navigator), но это в общем не важно, данный метод может быть вызван в любой базе..
    Короче, все замечательно работает на клиентской машине, но на сервере по неизвестной пока причине упрямится
     
  4. Sandr

    Sandr Гость

    Репутация:
    0
    Посмотрите Server Web Navigator на сервере, может там действительно нет этой вьюхи... Чесно говоря, не знаю, как она в 5-ке выглядит. нет под рукой....

    кстати, загляните в ацль Server Web Navigator-а может там че не так...
     
Загрузка...
Похожие Темы - Проблема ретривера
  1. _alexis_
    Ответов:
    4
    Просмотров:
    72
  2. Lisenok
    Ответов:
    19
    Просмотров:
    262
  3. thunder
    Ответов:
    1
    Просмотров:
    120
  4. SevenEight
    Ответов:
    0
    Просмотров:
    121
  5. imendan
    Ответов:
    13
    Просмотров:
    272

Поделиться этой страницей