Проблема с циклом Для...По...Цикл

Тема в разделе "1C и всё что с ней связано", создана пользователем anivaler, 11 сен 2008.

Наш партнер Genesis Hackspace
  1. anivaler

    anivaler Гость

    Пробегаю по регистру сведений и отлавливаю записи, в которых Состояние автобуса = БезШофера. Запоминаю индексы этих записей в массив.

    [codebox]Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    //процедура где идет заполнение и проверка записей регистра
    БезШофера = Перечисления.СостояниеАвтобуса.БезШофера;
    ТекРемонт = Перечисления.СостояниеАвтобуса.ТекущийРемонт;
    КапРемонт = Перечисления.СостояниеАвтобуса.КапитальныйРемонт;
    Набор = РегистрыСведений.СвободныеМашиныГород.СоздатьНаборЗаписей();
    Набор.Прочитать();
    Массив = Новый Массив;
    Если Набор.Количество() = 0 Тогда
    Сообщить ("Внимание! В регистре сведений ""Свободные машины город"" нет информации о текущем и капитальном ремонте.",СтатусСообщения.Информация);
    Иначе
    Для Каждого Запись Из Набор Цикл
    Если Запись.СостояниеАвтобуса = БезШофера Тогда
    Индекс = Набор.Индекс(Запись);
    Массив.Добавить(Индекс);
    Иначе Продолжить;
    КонецЕсли;
    КонецЦикла;
    Для Кол = Массив.Количество()-1 По 0 Цикл
    Набор.Удалить (Массив[Кол]);
    КонецЦикла;
    Набор.Записать();
    КонецЕсли;
    КонецПроцедуры
    [/codebox]

    Проблема с последним циклом. Он не дает никакого результата, хотя регистр у меня не пустой.
    Например пробовал так и так же никакого результата:
    [codebox]Для Кол = Массив.Количество()-1 По 0 Цикл
    Элемент = Массив[Кол];
    Набор.Удалить (Элемент);
    КонецЦикла;
    [/codebox]
    Пробегал полученный массив циклом для каждого и всё как надо выдаёт индексы тех строк, в которых состояние БезШофера. Не знаю в чём ошибка?
     
Загрузка...
Похожие Темы - Проблема циклом Для
  1. lira89
    Ответов:
    3
    Просмотров:
    3.091
  2. Smorti
    Ответов:
    1
    Просмотров:
    19
  3. Denybxx
    Ответов:
    18
    Просмотров:
    133
  4. bes
    Ответов:
    0
    Просмотров:
    52
  5. Denybxx
    Ответов:
    4
    Просмотров:
    156

Поделиться этой страницей