Проблема с обработкой почты.

  • Автор темы dryu83
  • Дата начала
Статус
Закрыто для дальнейших ответов.
D

dryu83

#1
У меня - 1С:Предприятие 8.1 (8.1.8.76).
Есть такая обработка:

Профиль = Новый ИнтернетПочтовыйПрофиль;
Профиль.АдресСервераSMTP = "**.*.*.*";
Профиль.АдресСервераPOP3 = "**.*.*.*";
Профиль.ПортSMTP = **;
Профиль.ПортPOP3 = ***;
Профиль.Пользователь = "******";
Профиль.Пароль = "******";

ИнтернетПочта = Новый ИнтернетПочта;
Попытка
ИнтернетПочта.Подключиться(Профиль);
Заголовки = ИнтернетПочта.ПолучитьЗаголовки();
Исключение
КонецПопытки;

Фильтр = НачалоДня(НачалоДня(ТекущаяДата()) - 60*60*24*5);

КолвоЭлементовВМассиве = Заголовки.Количество();
Для ОбратныйИндекс = 1 По КолвоЭлементовВМассиве Цикл
ЭлементМассива = Заголовки[КолвоЭлементовВМассиве - ОбратныйИндекс];
Если НЕ (Найти(ЭлементМассива.Тема,"Подбор товара") > 0 И НачалоДня(ЭлементМассива.ДатаОтправления) >= Фильтр) Тогда
Заголовки.Удалить(КолвоЭлементовВМассиве - ОбратныйИндекс);
КонецЕсли;
КонецЦикла;

Если Заголовки.Количество() = 0 Тогда
Возврат;
КонецЕсли;

Сообщения = ИнтернетПочта.Выбрать(Ложь, Заголовки);
...............

Проблема: в массив Заголовки все подбирается очень красиво, только письма с указанными условиями, но при выполнении строки
Сообщения = ИнтернетПочта.Выбрать(Ложь, Заголовки);
в массив Сообщения выбираются совершенно левые письма с другими темами и датами отправления, а некоторые строчки вообще выдаются с незаполненными темами и датами. Нужен именно массив Сообщения, т.к. в массиве Заголовки тексты писем пустые, а тексты нужны для последующей обработки. В 8.0 эта обработка работает без ошибок. Не работает на двух разных базах 8.1 и двух почтовых ящиках, также пытался заполнить массив Заголовки идентификаторами - результат такой же. Подскажите пожалуйста, что это за косяк и чей, мой или 1С?
 
Статус
Закрыто для дальнейших ответов.