проблема с обращением к свойству колонки из табличного поля

  • Автор темы CfK
  • Дата начала
Статус
Закрыто для дальнейших ответов.
C
#1
Кво=ЭлементыФормы.тпКомплектацияКомпьютера.Колонки.Количество();
Для к = 3 по Кво-1 цикл

Колонка = тпКомплектацияКомпьютера.Колонки.Получить(к);
Колонка.Видимость=Ложь;
КонецЦикла;
вот такое вот обращение, пишет что нету такого свойства у объекта (Видимость). черт его разберет как к нему обратится, по Колонка = тпКомплектацияКомпьютера.Колонки[к] тоже не работает.
 
T

Tigruga

#2
Кво=ЭлементыФормы.тпКомплектацияКомпьютера.Колонки.Количество();
Для к = 3 по Кво-1 цикл

Колонка = тпКомплектацияКомпьютера.Колонки.Получить(к);
Колонка.Видимость=Ложь;
КонецЦикла;
вот такое вот обращение, пишет что нету такого свойства у объекта (Видимость). черт его разберет как к нему обратится, по Колонка = тпКомплектацияКомпьютера.Колонки[к] тоже не работает.
Свойство видимость присуще только Элементам формы.
Количество колонок взял из элемента формы, а вот видимость присваивается уже таблице значений "тпКомплектацияКомпьютера", а не элементу формы....
Инми словами, в цикле должно быть что-то типа :

ЭлементыФормы.тпКомплектацияКомпьютера.Колонки.Получить(к).Видимость=Ложь;

А цикл я бы вообще делал по другому:

Для Каждого Колонка Из ЭлементыФормы.тпКомплектацияКомпьютера.Колонки Цикл
Колонка.Видимость = Ложь;
КонецЦикла;
 
Статус
Закрыто для дальнейших ответов.