Проблема с открытием базы Access

Тема в разделе "Остальные БД", создана пользователем -, 27 июл 2006.

Статус темы:
Закрыта.
  1. Гость

    Уважаемые господа! Сделал БД на Access (Office 2003) и пользовался ей. Потом сделал (черт его дери)обновление для Офиса и потерял возможность внесения изменений в свою БД. Т.е. в существующих формах (таблицы Exelleвские прилинкованные) не могу ничего изменить, хотя все данные на месте. Одна из форм вообще чистая, хотя в конструкторе все кнопки и поля на месте. Клик в поле дает только звук из спикеров. Копировать можно, но не стирать. Пытался исправить по описаниям хелпа через разрешения, но там поля изменений записей (что по левую сторону), кроме таблиц и запросов, неактивны и не имеют галок. Пробовал также входить как админ (хотя это по-моему происходит по умолчанию) и с монопольным доступом и импортировать, но все не помогло. Новая база, которую пробовал создать, тоже имеет ограничения на изменения. Потом разозлился и полностью снес Офис, вычистил реестр и вновь поставил начисто. Тоже не выгорело, все как было, так и осталось. На другом компе также не идет. БД не шифровал, ограничения не вводил. Что делать не знаю. Подскажите кто может!!!
     
  2. ????

    ???? Гость

    Для: Майк
    при открытии базы access не ругается что "база находиться в режиме только чтение"?
     
  3. Гость

    в настройках смотрел (где закладки с галочками)?
     
  4. Гость

    Отвечаю на предыдущие вопросы.

    При входе программа запрашивает только разрешение на включение макросов.

    "Галочки" в Разрешениях, которые не относятся к изменению макет, не активны в отношении форм и отчетов. Т.е. могу редактировать структуру, но не дает изменять сами данные.

    P.S. Боюсь, что дело не в самом Access-е, а в том как происходит заход в Винду, хотя он происходит с правами админа. Может срубить вообще все и переставить систему начисто!? Но пока не хочется, уж больно это топорно, да и мороки много с переустановками.
     
  5. Гость

    Если поезд еще не ушел, предложу вот еще что: У меня что-то отдаленно напоминающее было, когда не были изначально подключены компоненты DAO - имеется в виду "в таком духе" - ожидаемые действия не только не выполнялись, но и не могли быть введены в программу. Так может быть, и у Вас какие-то компоненты не подключились при "мадэрнизации" системы? Если это так, то просто: определите имена этих компонентов, войдите в свою БД в режиме конструктора к программным кодам и через Tools выйдите к списку компонент и поставьте соответствующие галочки, сохранитесь, выйдите и перезапуститесь. Имена модулей можно попытаться поподбирать по ключевым словам в английском переводе. Во всяком случае, это - последнее, что смогли придти мне в голову.
     
  6. Гость

    Спасибо за совет, попробую покопаться.
     
Загрузка...
Похожие Темы - Проблема открытием базы
  1. rasim270490
    Ответов:
    3
    Просмотров:
    887
  2. rasim270490
    Ответов:
    2
    Просмотров:
    739
  3. sanch
    Ответов:
    26
    Просмотров:
    6.860
  4. pbnoob
    Ответов:
    1
    Просмотров:
    2.318
  5. AgniXRudra
    Ответов:
    1
    Просмотров:
    39
Статус темы:
Закрыта.

Поделиться этой страницей