Проблема с созданием новой роли в Бухгалтерии 8.1

  • Автор темы Guest
  • Дата начала
Статус
Закрыто для дальнейших ответов.
G

Guest

#1
Никак не могу разобраться почему не получается создать роль.
1С Предприятие упорно не хочет запускаться с пользователем у которого выставлена новая роль.
Пробовал добавить роль в перечисления результат тотже - "У текущего пользователя нет доступных ролей для загрузки базы данных"

Помогите пожалуйста!!!! Сил больше нет исправлять эксперименты сотрудников, еще неделя и я повешусь....
 
G

Guest

#2
Пока сам сибе не поможешь никто не поможет :(

Кароче тема перечислений как в 8.0 не работает, я сначала удивился почиму к перечислению "НаборПравДоступа" добавили "Удалить". Нужно смотреть общих модулях "УправлениеПользователями"
процедуру "ПроверитьВозможностьРаботыПользователя(Отказ)" и добавить там новую роль в условии.
Нашел я ее с помощью поиска набрав фразу которая мне за последнии две недели надоела до ужаса: ("У текущего пользователя нет доступных ролей......
Ниже приведена эта процедура и новая роль "Менеджер". Может кому пригодится.

Код:
// Процедура проверяет возможность запуска ИБ с определенными для текущего
// пользователя доступными ролями
//
Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт

Если НЕ РольДоступна("ПолныеПрава") И НЕ РольДоступна("Бухгалтер") И НЕ РольДоступна("Менеджер") Тогда
Отказ = Истина;
#Если Клиент Тогда
Предупреждение("У текущего пользователя нет доступных ролей, для запуска информационной базы.", 10, "Недостаточно прав доступа");
#КонецЕсли
КонецЕсли; 

КонецПроцедуры
 
T

Typhoon

#3
А можно сразу тебе еще пару вопросов поставить? Дать право на запуск проблем никаких нету просто можно было поставить второе право ("Например бухгалтер"), но вопрос такой а как ты дальше учитываешь права своих менеджеров?

Да и зачем это нада было делать просто даже в типовой есть два типа прав тот же бухгалтер (полные права и бухгалтер ограниченный)?
 
G

Guest

#4
В том экземпляре что нам впарили никакого ограниченного бухгалтера нет и в помине.
До этого в нашей организации работали в пиратской 7.7 и то только для первички тоесть для печати накладных и счетов.
Так что никто понятия не имеет как работать с программой и обучение идет в процессе, причем обучать приходиться мне а
я сам только три недели назад увидел данную прогу и к бухгалтерии до этого отношения не имел. Я там менеджером по маркетингу
числюсь. Да и бухгалтера и Главного бухгалтера я тож малость подрезал потому как думать и читать они разучились, вот уже неделю
как учатся платежку делать....
 
T

Typhoon

#5
Ну тогда все что можно сделать в твоем случае, это принести свои соболезнования по твоему времени и нервам которые ты потратишь на обучение!
 
G

Guest

#6
Спасибо канешно но если посмотреть с другой стороны то я потихоньку учусь и за это мне платят зарплату.
А тема меня всерьез заинтерисовала, вот собираюсь летом курс на профессионала взять а потом бог даст
и до специалиста добраться. Так што не все так плохо :lol:
 
Статус
Закрыто для дальнейших ответов.