1. Акция на весь декабрь! Получай оплату х2 за уникальные статьи, объемом от 200 слов, если в заголовке темы и теле статьи присутствует слово Python
    Скрыть объявление

Проблема с вьюхами

Тема в разделе "Lotus - Программирование", создана пользователем Sandr, 3 окт 2007.

  1. Sandr

    Sandr Гость

    Обновили БД по шаблону с обновленными некоторыми элементами дизайна. После этого при открытии НЕКОТОРЫХ вьюх вылазит ошибка Note Item Not Found. Ошибка происходит как и в клиенте, так и из под ВЕба... При этом в клиенте она нормально открываеться дальше, а в ВЕБе нет... Сразу скажу, что элементы дизайна не задвоились, прохибитов (No Refresh) никаких нет... Если открыть вьюху в дизайнере и пересохранить, проблема исчезает...

    Если создать новую БД по этому шаблону - проблем нет...

    Кто-нить знает, почему это и как с этим бороться?
     
  2. root

    root Гость

    Для: Sandr
    дебагер что говорит ?
     
  3. Sandr

    Sandr Гость

    Ошибка вылетает раньше, чем открывается окошко дебагера... Да и что там дебажить? Кода там как такового нет.. вьюха как вьюха...
     
  4. root

    root Гость

     
  5. Sandr

    Sandr Гость

    Не то.... Детских ошибок не допускаем... Кроме того, если бы причина была в этом, то ошибка была бы всегда, а не только в базах, где прореплейсили дизайн...
     
  6. root

    root Гость

     
  7. Sandr

    Sandr Гость

    Тоже не то... нет там шеред акшенсов... :(
     
  8. Kee_Keekkenen

    Kee_Keekkenen Well-Known Member

    Регистрация:
    5 сен 2006
    Сообщения:
    616
    Симпатии:
    4
    ctlr+shift+f9 не помогает ?
     
  9. Sandr

    Sandr Гость

    не... помогает тока пересохранение в дезайнере...

    To root
    Таки да... все дело в шаред акшенсах... не внимательно посмотрел...

    Спасибо за помощь... Вот теперь гемора прибавилось... во все вьюхи отдельно экшенсы пихать...

    А откуда кстати приведенные описания? В хелпе такого не нашел...
     
  10. root

    root Гость

    Для: Sandr
    ...откуда уже не помню просто, пол года назад сталкивался.
     
  11. Sandr

    Sandr Гость

    Объяснить такую ошибку можно тем, что при сохранении формы или представления сохраняется UNID Shared Actions-а, на который ссылается форма или представление. Заменив дизайн БД, заменяется и ссылка(UNID) на нужный нам Shared Actions.

    Вопрос, многие уже сталкивались с ЭТИМ?

    ЗЫ: Ща появится Мышко и скажет, что конечно знал :( И что нам еще учиться и учиться...
     
  12. Omh

    Omh Lotus team
    Lotus team

    Регистрация:
    4 июл 2007
    Сообщения:
    2.210
    Симпатии:
    0
    Там не UNID сохряняется, насколько я знаю.
    А id sharedaction'a
    Что-то вроде

    <actionbar>
    <actionbuttonstyle properties_here />
    <sharedactionref id='7'/>
    <sharedactionref id='8'/>
    </actionbar>
     
  13. Sandr

    Sandr Гость

    Походу дело ваще в другой вещи... Тока шо открыл в дезайнере базу с глючными вьюхами, залез в закладку sharedactions, а там пусто... Куда они делись? - ХЗ...
     
  14. K-Fire

    K-Fire Гость

    Возможно при обновлении дизайна сначала обновились вьюхи, а только потом шаред-акшны.
    В лотусе рефреш дизайна операция не 100% безглючная к сожалению. Или делался реплейс?
     
  15. Sandr

    Sandr Гость

    реплейс делался...
     
Загрузка...
Похожие Темы - Проблема вьюхами
  1. c0de3r
    Ответов:
    4
    Просмотров:
    107
  2. DobermannTT
    Ответов:
    10
    Просмотров:
    128
  3. SoulPaladin
    Ответов:
    3
    Просмотров:
    114
  4. Artael
    Ответов:
    1
    Просмотров:
    106
  5. ENSLER
    Ответов:
    0
    Просмотров:
    100

Поделиться этой страницей